Dimension problems - no vertical dimension

Hi, I am working with Rhino 5 for Windows. A few days ago my dimension tool didn’t work anymore in the perspective view. Whatever I try, I cannot measure in any other direction than horizontal. I tried every single of the dimension tools, restarted Rhino, restarted my computer, I tried it in a new file, but nothing changes.

could it be that I changed the settings somehow accidentally? I can still use vertical dimension in top and right view…

can you please help me?

Is the ‘Project’ option enabled on the Osnap bar?

The regular ‘Dim’ command should follow x or y but not the z of the current CPlane - is that what you mean? Dims always lie parallel to the CPlane.

-Pascal

1 Like

You can’t dimension in the Z-axis from the Perspective viewport with the default X and Y c-plane. Instead, dimension vertically in the Z-axis by using the front or side viewport. You’ll then see it in Perspective in a z-axis orientation.

Alternatively, you could try to move the Perspective view C-Plane to either front or side orientation … and do it that way.

3 Likes

I just came across this topic, after trying everything and being sure I must be missing something. It appears I wasnt missing anything and once again Rhino has stumped me with its unique “quirks”.

It seems like a pretty simple and common task: measure or dimension something in Perspective view. The terms “horizontal” and “vertical” just don’t make any sense in the context of 3D space in the way Rhino interprets them. In standard perspective view horizontal refers to the X-axis and vertical to the Y-Axis, and not the Z-Axis as literally everyone would expect. If they were strictly for 2D views, then why have them in the 3D view?

But I guess its all related to the whole Z-is-up-Y-is-depth-only-in-Rhino mess, where suddenly the depth of the world becomes vertical, because 2D is flat like on a table. What was the reasoning behind that again?

Would it really have hurt to add a way to measure something in the Z-axis even while in perspective view? I know there is the distance command, but it doesn’t leave an annotation in the model itself.

Being able to dimension something in 3 dimensions in a 3D viewport in a 3D modelling software surely should be possible and I don’t see any reason why it shouldn’t be!? Maybe because you would have to come up with a third term for the direction that is perpendicular to both “horizontal” and “vertical” to call that dimension style… :wink:

1 Like

I dont know if I understand you correctly but I made a vertical dimension macro that makes it possible to set a vertical dimension in the perspective view;

_CPlane object _pause
_Dim _Pause _Pause _Pause
_CPlane _World Top

it will ask you to set a CPlane to an object and you have to choose a vertical surface somewhere in the model and then it starts ordinary dim which now will be vertical. It resets the Cplane to back default again.
/Fredrik

3 Likes

Okay, thats pretty nice. Works well. Had to look up how to save a macro as a button and it seems pretty straight forward, if somewhat archaic. Rhino could really take a hint from Grasshopper regarding UX.

Thanks!

You could also try using the OneView mode in RH6 (or an AutoCPlane script for RH5). You’ll still have to rotate your 3D view to align with a CPlane but that’s just rotating…

3 Likes

Thank you!

This would be a priority for me.

1 Like

2020, and this still seems to be the way to do it?

(I like that you can replace the default toolbar icon behavior with this little scipt at least!)

Is it really so tricky? Here in the Rhino Layout tutorial

is a water bottle modelled by Rhino folks with vertical dimensions in it. Does that suggest that it’s a basic action? It sounds from the above that vertical dimensions require a special script?

Dimensions are always created coplanar to the CPlane in the current viewport.
To make a “vertical” dim that shows in the Perspective viewport (bad practice), create it in the Front or Right viewport/

Why is it bad practice? We are not all creating production ready files or drawings for products. Sometimes you just want to measure something quickly and see it in 3D.

Not everyone uses Rhino as a CAD program, but for more general 3D object creation, modelling, etc. A bit like in SketchUp. There you can create a dimension in any direction incidentally. You just click 2 points it snaps to and creates a dimension. It’s really not that outlandish of a request.

2 Likes

He didn’t say it couldn’t be done; in fact he told how to do it. I suspect his “bad practice” remark stems from decades of experience in drafting to industry standards.
I do what you’re talking about a lot.

1 Like

Agreed, adding the ability to add z-axis dim capability in perspective would be pretty helpful in streamlining workflows. Just a humble request! Thanks so much!

1 Like

i have talked with @mary recently about this. hopefully this will be in v8. there are many examples of easy and intelligent dimensioning from other softwares. i think it should automatically detect direction and orientation similar to how gumball detects planes when you orbit model.

1 Like

Agreed. I also recently saw the command “OneView” in action in that cool video on sketching in Rhino 8 by @theoutside and that also cleverly sets the C-Plane depending on view. Therefore making the dim command equally “clever” when in perspective view should not be a problem.

this is a great application of oneview

Just gave it a go, but cannot get it to work. Say I have a simple cube. If I look at it in normal front view I can easily create a dimension in z (ie. the height). But if I enable oneview and am in the perspective viewport, I cant do the same, even though it says “front” in the top right corner. Does Linear Dimension not respect OneView? Or am I missing something?