Select Occluded Objects

I’m no longer able to select occluded objects when running a command in shaded display mode, i.e. selecting the occluded edge of a box when running the ExtrudeCrv command. This is still possible in Rhino 6 but not in Rhino 7, I’ve gone through my advanced options settings too see if I messed up something but couldn’t find anything.

Hi Samuel,
in Rhino 7 you can’t select hidden objects (this was asked by many users to avoid selecting things that are behind the scene).
The only workaround I know is to use a ghosted view (if you want that the objects appears “solid” you can apply a very low transparency i.e. 3 or 4).

Thank you Lucio,
I knew some users complained about it, I think McNeel could have made an option to let us customize this aspect, for me it makes the modeling process a bit more fluid in certain circumstances.

I agree.
Also, I found that would be necessary a little bit more tolerance when identifiing what is hidden and what is not…
Sometimes, if i have the mesher setted on low quality, i can’t osnap on borders that aren’t at the top of the scene i.e. selecting the bottom border of a hole (I have to put the mesher at high levels so the border is fully visible).

I agree that this could definitely use some tuneup.

I did not realize that is the case in V7 and being intentional. (Still doing most of the work in V6 over here until we determine V7 had enough SRs to fix obvious issues).
I would also like to see this behavior optional (an Advanced Option?) since quite often we actually DO want to pick an edge that is occluded but we know it’s there, instead of rotating the view or switching the display mode.
@pascal , @mikko - is that something that could be allowed again or added as an option?

There won’t be new settings added to V7. You can effectively turn off the culling by using either transparent grid or grid on top of objects. For Shaded viewport the setting is at Options->View->Display Modes->Shaded->Grid->Grid appearance.

It does not seem to have any effect in Rendered mode and perspective view. Not that his is a good workaround for the lost functionality, but I can’t even get this one to work. In a quick modeling setting (normally we don’t use the grid and most modeling is done in Perspective, directly in one viewport) this is not a viable equivalent. Obviously it is quicker to go to Ghosted mode or rotate the camera, but still a slowdown. If not an option in V7, maybe a wish for V8, in the meantime I guess we’ll have to live with this new limitation. thanks Mikko.


1 Like

Also, is this only affecting mouse-picking and NOT window-pick? We are still able to window-select occluded object, but not individual pick…(any reason for the inconsistency with this?)

1 Like

Hi to all

I accidentally found that, running the ExtrudeCrv Command, a double click in the place where I expect to find an edge actually selects it, regardless of the viewport Settings.


Seems to work over here in Rendered, and in perspective.

We don’t have tools for checking the perceived visibility of entire object. That’s why the visibility culling is single pick only.

hmm… could you screenshot the grid settings you are using in the Display Mode that work for you?
(thx for the note on the single pick vs. window - got it)

It’s all default settings, the only setting I changed is the grid appearance. Try reopening the model, or restarting Rhino, or changing some other settings too. I’ve got a vague memory the settings sometimes don’t kick in immediately.

hi @mikko,

Just realized that the Dot objects follow this behavior (not being able to be selected by pick if “occluded”). We find it quite problematic, because this type of object is not really visually occluded since they are always drawn in front, so intuitively trying to click and pick them to no avail. We use them quite often to mark centers of 3D objects etc. therefore by this definition they are always “occluded” (yet visible!) and impossible to click-pick. Moreover, in one of my plugins (Armadillo) dots are used as an UI element, indicating centers of arrays of objects and their transform values, and this behavior makes the whole UI system very hard to use - picking the dots by window selection is not really working that well or being intuitive.
Is there a chance Dot objects can be excluded from this new behavior in V7 SRx? Really makes no sense to make a visible, unlocked objects not pickable.



@Jarek , thanks for reporting this. It will be fixed in a near future service release for V7.

1 Like

Hi @mikko, thanks, works well already in the latest build!