Section Tools won't install in Rhino V6

I sent the following in to McNeel tech support but didn’t get a response, so I thought I’d try here:

I am trying to install a couple plugins to Rhino V6 and am receiving the error in the screen cap below, and double clicking either of these .rhi files will still open Rhino V5 rather than Rhino V6. A little googling led me to RhiFix.exe, but running that didn’t fix the issue, see summary below.

Please let me know if there is anything else we should try. I really need to get section tools running in Rhino 6 so we don’t have to deal with back saving all the models.

These are the files I am trying to load:

Here is the error message:

Here’s the summary from RhiFix:
----- Summary -----
A fix was applied to your computer.
Version 6 (x64) of the Rhino Installer Engine will install packages for Rhino 6 and older.

RhiFix.exe version 6.0.6726.16913 starting…


  • Detecting Rhino Installer Engine Executable … 6.15.19164.21011
  • Detecting Rhino.InstallerPackage registry key in HKLM … 6.15.19164.21011
  • Detecting .rhi registry key in HKLM … found.
  • Detecting Computed .rhi File Association … 6.15.19164.21011
  • Detecting User .rhi File Association (Windows 7) … not found.
  • Detecting User .rhi File Association (Windows 10) … not found.
  • Detecting 32-bit Rhino 5 … not found.
  • Detecting 64-bit Rhino 5 … 5.14.00522.08390
  • Detecting Rhino 6 … 6.15.19164.21011
  • Detecting Rhino 7 … not found.
  • Detecting File association mismatch … not found.
  • Fixing .rhi registry key in HKLM … succeeded.

----- Data -----

  • rhiexec_installed_version = 6.15.19164.21011
  • rhiexec_install_path = C:\Program Files\McNeel\Rhino Installer Engine\x64\rhiexec.exe
  • rhiexec_exists = True
  • rhiexec_platform = x64
  • rhi_system_registry_open_command = “C:\Program Files\McNeel\Rhino Installer Engine\x64\rhiexec.exe” “%1”
  • rhi_system_registry_open_command_path_exists = True
  • rhi_system_extension_registry_key_found = True
  • rhi_system_extension_registry_class = Rhino.InstallerPackage
  • rhi_file_association_exists = True
  • rhi_file_association = C:\Program Files\McNeel\Rhino Installer Engine\x64\rhiexec.exe
  • rhiexec_associated_version = 6.15.19164.21011
  • v5x64_version = 5.14.00522.08390
  • newest_rhino_version = 6.15.19164.21011
  • v5x64_install_path = C:\Program Files\Rhinoceros 5.0 (64-bit)\
  • v5x64_install_path_exists = True
  • v6_install_path = C:\Program Files\Rhino 6\
  • v6_version = 6.15.19164.21011
  • v6_install_path_exists = True

And here is the printout from _SystemInfo:

Rhino 6 SR15 2019-6-13 (Rhino 6, 6.15.19164.21011, Git hash:master @ e41c99d36bb5000377057645e96b3ea6facf6171)
License type: Commercial, build 2019-06-13
License details: Cloud Zoo. In use by: Craig (JENSEN)

Windows 7 SP1 (Physical RAM: 24Gb)
Machine name: SEAA1-LR909ZZA2

Hybrid graphics system.
Primary display: Intel® HD Graphics 4600 (Intel) Memory: 1GB, Driver date: 8-16-2018 (M-D-Y).
Primary OpenGL: NVIDIA Quadro K2100M (NVidia) Memory: 2GB, Driver date: 8-17-2017 (M-D-Y). OpenGL Ver: 4.5.0 NVIDIA 382.99

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 8x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.5
Shading Language: 4.50 NVIDIA
Driver Date: 8-17-2017
Driver Version:
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 2 GB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.15.19164.21011
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.15.19164.21011
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.15.19164.21011
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.15.19164.21011
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”

According to Food4Rhino, this is for Rhino 6.12 or later, so won’t install in Rhino 5.

Just tried the install into Rhino 6 and it was OK, but only after I had removed any traces of Section Tools folders and files previously installed (I had a WIP version from 2018). Old file locations included C:\Users<whoever>\Appdata\McNeel\ subfolders and C:\Program Files\Common Files\McNeel subfolders. I didn’t need to use RhiFix.

Can’t help with devsrfv6.rhi, I’m afraid, but maybe it’s a similar issue.


Changed title to say install rather than run

My recollection is the DevSrf plugin was separate from Section Tools. DevSrf was replaced in V6 by DevLoft which I believe is automatically installed as part of V6.

A version of DevSrf for V6 is available.

Thanks Jeremy,

What appears to be happening is that when I double click .rhi files, they automatically launch Rhino 5, and then the installation fails because it is supposed to be launching Rhino 6. This is the file association that RhiFix is supposed to fix.

I bet that uninstalling all versions of Rhino and re-installing just Rhino 6 would fix it, but I can’t do that because of the third party software that is still not compatible with Rhino 6 files. (Navisworks for example).

Thanks David, DevLoft is nice, but it’s not quite as good as DevSrf, hence my looking to keep using it. The version for V6 from food4rhino is the one that I’m trying to install.

The most recently installed Rhino associates RHI files to the Rhino Installer Engine for that version of Rhino.

If you “Repair” the installation of V6 after installing V5, RHI files will be associated with V6.

Since RHI tools can be installed for “All Users” (requires Admin password), or “Just me”, it can get pretty complicated.

So if I installed Rhino 6 after Rhino 5 then RHI files should associate with Rhino 6?

In any case, I would just as soon get rid of Rhino 5 all together, if I knew for sure that Section Tools and DevSrf would for sure work in Rhino 6. I’m in the middle of a project where we need section tools working.



My R6 Rhino Installer has the same version number as the Rhino Service Release, so installing an R6 SR should be sufficient to get the right association.

However you can search for it (rhiexec.exe) on your C: drive and you should find all the varieties for R5 & 6, and 32 & 64 bit. If you identify the R6 64bit one, you can drop the .rhi file on it and that ought to install to R6. It’s probably in C:\Program Files\McNeel\Rhino Installer Engine\x64.


1 Like

Rhino V6 Service Releases, are complete installers. That’s why they are so big. When you run one, it uninstalls the old V6 first.

I have both V5 and V6 installed with Section Tools and DevSrf functioning in both.

However you can search for it (rhiexec.exe) on your C: drive and you should find all the varieties for R5 & 6, and 32 & 64 bit. If you identify the R6 64bit one, you can drop the .rhi file on it and that ought to install to R6. It’s probably in C:\Program Files\McNeel\Rhino Installer Engine\x64.

This worked! Thank you!