SectionTools update will not install

Downloaded the latest SectionTools update. However, dragging it into Rhino gets me this error. Am I installing incorrectly? Do I need to remove the old version? I also ran the RhiFix.exe program.
RH 6.17
Win 10
I do have WIP7 installed.

Can you please update to the latest Rhino Service Release, and try to install?
Let me know if you still have issues.

Still the same on 6.18. Could my playing with the Rhino “Advanced options” have anything to do with this? I’m skeptical since all my Advanced Options changes relate to colors, SS installed on my laptop which has the same changes.

The Feb 19th version of SS is installed and works. Should I try removing it first?

I just recently installed this but had to remove the Feb 19 version first (it was installed but the tab wasn’t showing in R6).

Jeremy

Here is what I’d like you to try. Download and run the RhiFix found under "Installer Repair Utility, in the Downloads section here (https://www.food4rhino.com/app/sectiontools-rhino).
If SectionTools does not install after that, then please email us (or post) the following 3 things

  1. A screenshot of the error,
  2. Repair Utility log (all the text below RECOMMENDED ACTION), and
  3. The RHI installer log. Here is where you find for [Rhino 6]: %appdata%\mcneel\rhinoceros\6.0\logs

Rajaa, I did the RHIFix in the last version. Dosen’t work in 6.18 either. Here are the items requested.

logs.zip (1.2 KB)

Hi @CalypsoArt,

Did you try this?

I’m pretty certain that I saw the same error message when trying to install without removing the old version first. Oh, and I probably restarted Rhino between deleting the old and dragging in the new. Hope that helps.

Regards
Jeremy

I’m kinda worried about doing that. If I remove the working version and the update doesn’t install, then I no longer have SS. I’ll wait for Rajaa’s response then try it.

Fair enough. Just one “teach Grandma to suck eggs” thought: did you do the File Manager ‘Unblock’ thing on the .rhi file before you dragged it into Rhino?

@brian can you help?

Another customer has mentioned that the RhiFix tool didn’t run as Administrator for them - can you please try right-clicking RhiFix, then clicking Run as Administrator?

Tried all of the above and nothing worked. I re-downloaded the ST rhi and it installed. Thanks all for your efforts.

1 Like

Strange. I think the next step is for me to remote control your computer and see if I can figure it out. I’ll DM you.