Installing RHIs with R6.4


#1

Has anything changed with how R6 installs RHIs? Until just recently, when double-clicking an RHI, the Rhino Installer Engine would install the plug-in for R5 and R6.
I’ve just upgraded to R6.4, and this behavious has changed. The RHI is now only installed for R5. I haven’t worked out yet how to actually install an RHI for R6.4
The plug-in in question is done in Python and Script Compiler.


(Dale Fugier) #2

Hi @axa,

You might consider repairing your Rhino 6 installation.

Control Panel > Programs and Features > Rhino 6 > Change > Repair

– Dale


#3

Tried this, but to no avail. Double-clicking an RHI only installs it for R5.
Even dragging the RHI into R6.4 opens up the R5 installer.
The ‘Install’ button in the PluginManager only allows me to browse for RHP and DLL files.
I cannot install an RHI for R6.4 Please advise.


(Dale Fugier) #5

@axa, I’ve moved this to the 'Rhino for Windows` category so it gets attention from our support staff.

– Dale


(Brian Gillespie) #6

Hi @axa,

It sounds like your file association for .RHI files might be misconfigured on your computer. There’s a utility called RhiFix that might help:

Details are under the first section here:
https://wiki.mcneel.com/rhino/5/rhi-problems


#7

Hi Brian,
thanks for pointing me to the RHI-problems page. I ran the RhiFix.exe

----- Summary -----
A fix was applied to your computer.
Version 6 (x64) of the Rhino Installer Engine will install packages for Rhino 6 and older.
...

Double-clicking on an RHI still opens R5. However, when I right-click, I can select Open With… > Rhino Installer Engine, which appears to be the R6 installer.
So although double-clicking doesn’t work, it does allow me to install RHIs for R5 and R6.
I should mention that I rebooted my machine after running RhiFix.exe

here is the full output:
----- Summary -----
A fix was applied to your computer.
Version 6 (x64) of the Rhino Installer Engine will install packages for Rhino 6 and older.

RhiFix.exe version 6.0.6660.17177 starting...

------Details------
  * Detecting Rhino Installer Engine Executable ... 6.4.18130.19341
  * Detecting Rhino.InstallerPackage registry key in HKLM ... 6.4.18130.19341
  * Detecting .rhi registry key in HKLM ... found.
  * Detecting Computed .rhi File Association ... 6.4.18130.19341
  * Detecting User .rhi File Association ... not found.
  * Detecting 32-bit Rhino 5 ... not found.
  * Detecting 64-bit Rhino 5 ... 5.14.00522.08390
  * Detecting Rhino 6 ... 6.4.18130.19341
  * Detecting Rhino 7 ... not found.
  * Detecting File association mismatch ... not found.
  * Fixing .rhi registry key in HKLM ... succeeded.

----- Data -----
  * rhiexec_installed_version = 6.4.18130.19341
  * rhiexec_install_path = C:\Program Files\McNeel\Rhino Installer Engine\x64\rhiexec.exe
  * rhiexec_exists = True
  * rhiexec_platform = x64
  * rhi_system_registry_open_command = "C:\Program Files\McNeel\Rhino Installer Engine\x64\rhiexec.exe" "%1"
  * rhi_system_registry_open_command_path_exists = True
  * rhi_system_extension_registry_key_found = True
  * rhi_system_extension_registry_class = Rhino.InstallerPackage
  * rhi_file_association_exists = True
  * rhi_file_association = C:\Program Files\McNeel\Rhino Installer Engine\x64\rhiexec.exe
  * rhiexec_associated_version = 6.4.18130.19341
  * v5x64_version = 5.14.00522.08390
  * newest_rhino_version = 6.4.18130.19341
  * v5x64_install_path = C:\Program Files\Rhinoceros 5 (64-bit)\
  * v5x64_install_path_exists = True
  * v6_install_path = C:\Program Files\Rhino 6\
  * v6_version = 6.4.18130.19341
  * v6_install_path_exists = True

(Brian Gillespie) #8

@axa thanks for letting me know.

It sounds like your computer is using yet another way to set up a file association for RHI files than the ones that I was able to find and fix with that utility. I’ll send you a private message to see if we can set up a time for me to get more information from your computer.