Section Tools on Rhino6

unhandled

#1

Anyone else out there finding that when they use the View command, the Section show up in the viewport 180 degrees? Either mirrored, or just plain upside-down?


(Rajaa Issa) #2

I see it in SetView=Yes option in stViewSections. I’m looking into it now.


(Rajaa Issa) #3

@Alan_Farkas I fixed it and posted a release candidate. Can you please try it and confirm that it works as expected?
https://www.rhino3d.com/download/sectiontools/1/wip/rc


#4

Great, thanks. Will try when I get a moment… Can I just install it over the existing?

Alan


#5

Works great, thanks!

I do have another problem – When I make a new section, I used to be able to see the arrows on the section line as I was putting it in place. I can’t see them now (nor could I before the updated install you sent today) – Any reason for that?

Not sure when I stopped being to see them. I go through periods of nt using sections here and there. But when I need them, I REALLY need them. Great plug-in!

Thanks

Alan


(Rajaa Issa) #6

Any chance the ArrowScale is set to 0?


#7

No, I’ve set it as high as 10 with no change.

Also: For some reason when I use the BOTH (Surface and Hatch) under the hactch option, I lose the ability to make the hatch as the ansi-style cross hatch. Like, there’s no option up in the command line. Now that means I have to go into each Section, select the hatch, and change it manually - and when I “Update” my sections after a modeling change, they revert to solid hatch.

Thoughts? This is ALMOST working great!


(Rajaa Issa) #8

Can you share a file and image of what you are seeing? I’d like to repeat at my end to be able to fix it. Thanks for your help.
As for the Hatch issue, this is a know bug. the plugin fetch existing hatch patterns in Rhino. If a hatch command has not run before, and other hatch patterns used a least once, SectionTools only gets one pattern (Solid). This is the only one that loads with a new Rhino session or file. As a workaround, you can run hatch command with the pattern you like first (then delete). Next time you run SectionTools commands, you should have the default patterns available.


(Djhg) #9

I can report the following anomalies and questions:

  1. Undo doesn’t work on stCreateSection. Not sure it works on all other operations either.

  2. After SetView>Pick"NamedView" at 06:56 in the general tutorial (arch and 6 columns), when I return to the 4 viewport model space layout, the fill in my perspective view is corrupted. (If I then hit undo, undoing the SetView>Pick"NamedView" operation, the corruption goes away.)

  3. Though the option of selecting a hatch other than the defrault solid hatch showed up after a couple of days with Section Tools, I do not think it was intially available.

  4. Section Tools is the only Sectioning method for RHino with a reliable clipped fill. VisualARQ’s Section Tool is the only Rhino sectioning method I can find for creating a jogged section line. I’m attempting to develop a method for creating jogged section lines which generate a reliable fill. I’m not succeeding and I welcome suggestions.

  5. Sometimes Sections can be selected and deleted (they segment at any face they cross) as curves, sometimes they can’t:

  6. Fill of plan-sectionned surfaces, like those of elevation-setionned surfaces, is unreliable in Rhino. Section Tools remedy this for elevation sections, but when I attempt to place one in a front or side view to crfeate a reliable plan section fill, it disappears. Is it not possible?

7a) In the print below, the fills in elevation 2 have no linework, apparently because there is also a clipping plane along the same axis. Is there a simpler way to remove the linework? 7b) I am looking for a way to adjust the thickness of the lines that show in the fills. 7c) One thick line around only the perimeter of the entire fill area would be the best arrangement, but I don’t see a way of accomplishing this.__Ed:On opening this file the next day, the fills in all elevations print without lines like Elevation 2. So it’s not the effect of the clipping plane. This is concerning. Consistentcy is important.

  1. HEre’s a Bug: Layout with SEC Views visible, one of SEC layers current > Copy Layout > Copied version of Layout is corrupt - has contents of SEC Layers (from Model Space) randomly visible in Layout space and selected. Deleting Corrupted New Layout deletes Sections and Views from Project. Here it is in action:

(Rajaa Issa) #10

Thank you for the detailed feedback. I’m interested to make it work better for you. Please find below my response. I look forward to your follow up.

Undo (or Ctrl+Z) works at my end. Is there specific model or settings that is not working for you?

The fill sometimes appear corrupted if you have both solid hatch and surfaces as fill (SolidMode=Both). Make sure you have the latest Rhino6 SR, and the latest SectionTools. Let me know if this persists, but generally you do not need to combine a Solid Hatch and Surfaces at the same time.

This is a known bug. Rhino does not load all hatches when you open a new session. Only Solid is available. While SectionTools try to load these hatches, it does not always succeed. Rhino load default hatches when Hatch command is ran for the first time, and a pattern other than Solid is selected. At that point, SectionTools can access these default hatches. It is on my list to explore more robust way to load Rhino default hatches.

SectionTools use Rhino clipping planes. Until Rhino CP start supporting jagged clipping, This request will be out of reach. VisualArq uses different clipping method. Their fills should be made more reliable. Maybe @fsalla can help. An example where jagged section fill not working in VA will help.

There are 2 ways to delete sections. Either use stDeleteSections command, or in the LayerManager panel, select the section layer, and delete it. I’ll be interested to see an example where you could not delete a section. One situation I can think of is incomplete Undo that corrupts the section, but this is only guessing.

Can you share an example please?

I see the image, but I’d like to see an example to test here. Line thicknesses might be difficult to control unless you create NestLayout (static projection of the section) then edit lines on that one.

A simple example will help.


(Djhg) #11

Thanks Rajaa

One:

It will undo some, but it won’t go all the way back to before the invokation of stCreateSection

Four:

It improves on them - they don’t fill reliably in any other implementation.

I have tried to use both ST and Va (one to jog, the other to fill) in the same locations, but Va’s faulty fills take precedence

Five:

My point isn’t really about how to delete sections, but that in some cases the section behaves as though it has been exploded into lines, which I think represents a corruption somewhere. The parts of a section line can occasionally (unexpectedly) be selected as lines (and deleted - and perhaps otherwise edited - that way.) I think it’s a bug. My gif shows an example of how some otherwise identical functioning sections can be selected that way, and some can’t.

Six:

I am talking about a section that looks along the z axis of the world’s coordinates. Should I be able to invoke StCreateSection in a side view? No section line appears when I do that.

Eight:

If you can’t duplicate the error by copying a layout which contains any stSectionView, it may be specific to my project. I found the work-around is not to copy such a layout.


(Rajaa Issa) #12

I will help if you have an example.

I’ve seen it once in relation to incomplete Undo, but it is not easily repeatable. If you see an example where it happens consistently, then I’ll appreciate if you can share.

They should work reliably. Please share an example when they don’t.

Thanks once again for the feedback. Always helpful if you can share an example and steps so I can debug at my end.


(Djhg) #13

IN the file I am working with, all the issues you mention above are present. CreateSection won’t undo, THere’s a section that’s selectable as if it is exploded into lines. The problem with the z axis section, though I have managed to create it, is that the hatch as it shows in a perspective detail window (“24x36” layout) is a corruption alternating between three different colours: The desired fill colour, the object colour, and black. Only hatch is chosen, not both hatch and surface. I will upload it. As I continue to work with the project, it’s susceptible to crashes. These are probably related to VisualARQ, juding from the crash report, and tend to occur when restoring a named view to a floating viewport so that a section can be clipped in a view on a layout. (BTW, that multistep method of transferring a section view into a layout is too cumbersome for me to want to often use. The way clipping planes are assigned to views is much more straightforward) Anyway, the recovered files after such crashes become stripped of their Section Tools sections. Below is a gif of the corrupted hatch:

Below is the same item with the section moved down a foot and a coplanar clipping plane. (It wouldn’t display at all until the clipping plane was added). It doesn’t print at all. I’ve spent days attempting to get RHino to display clipped fills properly. It’s extremely frustrating. :


#14

Can you provide more information about these “faulty fills”?


(Djhg) #15

Yes: in my experience, clipped fills in Rhino and Va seldom display correctly, and never print, from a layout. There are a number of posts on the forums about this going back 4 years. At this point only Section Tools’ clipped fills display and print from a layout ortho view (and I believe even that only works if a clipping plane is created coplanar with the section.)

No clipped fills print from a perspective view in a layout in Rhino, Va, or Section Tools, even if there’s a coplanar clipping plane.

I can’t imagine the myriad problems needing solutions in CAD development, but I have to say that It’s a big challenge to a user to repeatedly need to draw these shortcomings, related to this basic CAD function, to the attention of the developers as if for the first time.


#16

Sectioned fills should print fine using VA Sections (jogged or not) and VA section attributes. And they can be printed to vector output as long as you use the Hidden display mode.
If you have some example where this is not working, let us know and we will check it out.


(Djhg) #17

Does it work now to produce clipped fills on solids and extrusions and polysurfaces as well as Va objects, Francesc? There have been limitations in this regard in the past.

If it has to be the hidden display mode, it’s not going to serve my needs, unless that includes rendered modes with hidden line removal. I’m using Ambient Occlusion Render modes.


#18

Forgot to reply to this. Yes, that fix works to get Ansi Hatch going, thanks.


#19

Yes it does.

You can print then to Raster output. Section fills also show up in Shaded or Rendered views. But if you need to print 3D geometry to vector output with hidden line removal, then Hidden display mode is the only way.


(Djhg) #20

That’s the problem with setting up an updatable versatile document to render a design.

Section Tools used in conjunction with clipping planes seem to be the only solution for that. They can’t jog though, unfortunately.