Section tools clipping plane not working?

I can’t get the clipping plane to show up using section tools. If I set a section and go to view it using the View clip view from the section menu nothing happens.

Ironically I was having the same issue last night, my work around was to select “List” in the command line when prompted to select a section and then select the section I would like to clip from the list and then select the viewport and the view then it worked for me. Hope this works for you as well!


Hi, Are you selecting the “viewport” to clip in?

Hi Rajaa,
I had the view selected but it wasn’t working. I reopened the file and tried again and now I have it working.

The fill with the both option has many visual artifacts just try a cube and view a section.
The section dot has a limitation in that it doesn’t rotate with the view and show the label, the label turns black when the view is rotated. That’s a problem with the both option I don’t see when hatch option is chosen.
How to delete sections why no delete section/s command on the SectionTools menu?

This is a great tool and should be updated.
Can you make it so we can define a plane as the section? Setting a line doesn’t allow the odd angle. How about a set initial section to current cplane and or a choose 3point option to define the section plane not just a line. In regular Rhino intersect works with the clipping plane now so it’s easier to use that to get sections then it is to use this tool in the case of the odd angle. Maybe I am missing a setting in the attached file how do I set up section tools so that it matches the angle of the cplane in the perspective view ?

AutoSectionCPlane2.3dm (272.5 KB)

I’ve always admired your work especially paneling tools.
Thanks for your help,

Thanks that got me to try it again.

@rajaa any ideas or is section tools dead?

I see this, and it is a bug with Dot viewed when a ClippingPlane is active, when the dot happen to be aligning with the clipping plane. I tested with Rhino ClippingPlane command and get that same bug. I created a bug item for it to be looked at here…

Currently section planes are set normal to the active CPlane of the view. That is similar workflow to Rhino Section command. I see how it can be handy to define the plane without changing the CPlane of a view. Selecting a plane or 3 points will need an extra point to define section direction. Maybe add an “Extrude” option to stCreate that defaults to CPlaneNormal, but can be set with a vector. Any suggestions here @pascal ?

See attached. In your example, you already have the CPlane set to the desired section plane in perspective view. I used “SynchronizeCPlanes” and then created the Section in “Front” view with Dir=X-Axis. I realize this is a extra step, but modeling in Rhino involves changing CPlanes to orient modeling sometimes.
AutoSectionCPlane2_RI.3dm (242.4 KB)

To Delete a section, and this is documented in the “SectionTools Manual”, you just need to delete the section layer. I’ve added a wish to turn this into a command. I agree that this might be clearer.

@rajaa - maybe allow access to the ‘InfinitePlane’ command in Rhino - that may work already.


I think plane 3 points is a good option and it’s about time it made it into section tools.
I’m more interested in getting one good section rather than many sections at this point, section direction doesn’t always apply it’s something to consider. So the line for direction is not always needed.

Ok that was the silver bullet, I haven’t used st in a while so I forgot about that. Yes the extrude would be a good thing then we wouldn’t have to create the line after the 3 points.
Thanks for your response and help.

Added to the list here…

Hi, Im currently having the same problem of clipping plane are set to the object but it doesnt appear on the make2d section result. I’ve tried everything but nothing was working. Help please? Would appreciate it

Can you post that file? Are you using Section Tools in this workflow?

Hmm no i was only using clipping plane and setting the view to plan view and making a make2d from that view. I’ve attached the sc here. so basically the make2d that came out from the clipping plane just showed a make2d of the model without the section.

Can you post the 3dm file? That would make it possible to check what is going on.

tunnel.3dm (15.7 MB)

I noticed a little late that you are working in Rhino 5. I can repeat the problem there, yes.
This works correctly in Rhino 6.