Section Display Properties of Walls


(Djhg) #1

These two walls, shown here in section perspective at the Section Plane, are identical in settings except that the one on the left has a material applied to it.

How do I get walls with material applied to respect behave as the one without the material. It doesn’t follow cutplane settings set in the View Mode, either (but everything else does.)

WallSectionDisplay|690x418


#2

@djhg I cannot see the image attached. Can you also send the 3dm file of this issue so I can better understand this request?


(Djhg) #3

I hope this shows. I can see it on the forum in my browser. I will upload the project.


(Djhg) #4

I uploaded the image too.

It’s worth mentioning that setting the global section fill settings for the VirtualArq Section Tool didn’t work to apply a specified fill colour globally, but Rhino’s clipping plane eventually worked globally (as described below) to apply a chosen colour on all of them except the one with a material applied. (Which is where I really need it to work, unfortunately.) I hope the project allows you to find a solution. Setting them for each object individually won’t really work, and I still need them to display with Layers visible as set in Wall Styles, in Plan View.

It’s also worth mentioning that the solution on the Rhino forum (in one place) of applying a fill pattern and colour to a Clipping Plane didn’t work for me (as it has not worked for others reporting on the forum in other places) for adjusting the colour of a global fill (or anything else) on all Clipped Planes. The only thing that worked was setting a custom property for Clipped Plane display in Preferences for Render View Mode - but that did not work (only) for the Wall with a material applied.


#5

I see the image now.

What are the cut plane setting you mean? Clipping plane settings on Rendered Display mode perhaps?

The VisualARQ section takes the Clipping plane settings per Display mode. It should work also for Rendered Display mode, regardless if objects have material or not. Can you send that model so I can better understand what’s happening?


(Djhg) #6

That’s the problem, as mentioned above. It isn’t working that way for me with VaSection Active OR Clipping Plane. Material shows on the cut plane with both section modes. Above is the result with VaSection and this is the result with CLippingPLane (please see more below the image):

As mentioned above, I uploaded it (via drop box) when I posted that a couple of days ago. It’s called "“ClippingPlaneIssuesCamera1view” . I sure hope you can help with that. It’s quite urgent at this point. Thanks.


#7

I got the file, thanks. And I can see now the issue you report. We will investigate why this is happening and get back to you when we fix it.


(Djhg) #8

Thanks. I’d lobby for this being a priority; there’s no fast work around, and a section perspective is misleading with materials wrapping the Cut Plane.

Whether this happens with the Vray plug-in is even more important.