Section Fill Properties in Conceptual View Mode

In Conceptual View Mode, I can’t seem to get clipped objects to display as set in the Section Properties panel for the object. Wondering if it’s possible. I can do it in Hidden View mode. I am looking for a view mode which can show Silhouettes, AO illumination, render materials, and different section fills for different objects. It appears that Conceptual fulfills all but the last. If there’s another option, I’d like to try it.

1 Like

Some of the display options aren’t consistent between plan view cuts and the 2D vaSectionViews. I’ve actually made special section views for my linework, my hatch patterns, and the shading itself, with the intent to actually overlay 3 plans on top of one another. I’m contemplating either doing that or using a view style/plan cut and overlaying two detail views in paperspace.

I’m not 100% sure what you’re looking for but I’ll share my result in case it helps.

This is conceptual view using the clipping plane settings shown on the dialog:

Note that it’s hard to see, but I have the inner wall shaded in a light beige color.

The walls are a vaObject which offers some advantages over non vaObjects. But to be honest I might start doing my concrete geometry with Rhino Solids. Here’s a non-va object, same display property settings, with the object’s section attribute settings in the second clip:

Note that the pattern color is set to red, but my pattern stays black.

This last view is the default “rendered” setting, except with edges turned on in the “Display Properties” dialog. The pattern shows red now. To be honest I’m not sure why it is, the Clipping Plane is still set to “Viewport”.


I’ve been down a similar road but to achieve something a little different. My advice would be to just settle for something that’s almost right. Depending on your workflow and if you’re using Visual ARQ objects or not, there’s going to be different approaches. I have a feeling (and I’m hoping) that things improve in Rhino8 and VA3.


Hi @djhg,

I have been testing it and it looks like it is working fine:

Wich Rhino and VisualARQ versions are you using?
Maybe you have made some changes in this display mode, you can restore the default values from the Rhino Options:

Hi @keithscadservices,

Why do you prefer to do it with Rhino geometry instead of VisualARQ objects?

This was designed by this but you can change it by editing the display mode and selecting “Plane’s color” here:

Anyway, we will probably change it in future versions to make it work as the other display modes so I’ll keep you updated about it.

Which other improvements regarding this topic would you like to see in VisualARQ 3?

I can also get a hatch-filled component of a wall assembly to work as you did in your example, but I can’t get a solid-filled component to work. In the below jpeg, a solid-filled component as the Section Properties of the wall (bottom centre) shows, doesn’t display as solid. The gif shows that resetting the View Mode to Default doesn’t help. Generally if I want fills and section view materials and shadows to work properly, I need to layer a Hidden view mode (for section materials to show properly) on top of a rendered view mode, so it’s been a consistent issue in my workflow.


Hi @djhg,

I still couldn’t reproduce the issue with a solid fill. I see you are using a custom display mode, can you reproduce this issue with the regular Conceptual display mode?

Shouldn’t resetting to defaults be restoring that?

Hi @djhg,

It depends on the default settings you have in this display mode. I am not sure if it has got the same settings as the regular Conceptual display mode.

I dont know how to purposefully change default settings. I guess there must be a “save as default” button? (I haven’t used that as far as I recall.)

Ok, maybe you can send me your display mode so that I can test it with the same settings. You can export the display mode from the Rhino Options>View>Display Modes>Export.

Thanks Alfonso
ConceptualAOTextures40%Shadows.ini (13.0 KB)

1 Like

Hello @djhg,

I think the problem is in the display mode. If I change the color usage to “Viewport” in the Clipping Plane Settings it looks fine.

Solid fill

Thanks Alfonso, but it doesn’t seem quite right. Is it actually following the wall’s fill settings? The fill level on those walls (if youre’ using my wall objects) is set at level 150/255 (isn’t it?). It’s displaying at the “viewport setting” as totally black. I have tried all those Clipping plane settings, and so far I haven’t found one where it follows the wall’s fill settings reliably.

Hi @djhg,

What do you mean by “level 150/255”? So I understand the problem is now with the colour. The conceptual display mode is defined to paint the section in black (however, you can modify this; look at the settings in the hidden display mode to see how it is defined in this display mode).

I havent found a setting which displays and prints the different fill colour settings for a VaWall.

Hi @djhg,

I have been comparing the Hidden display mode settings with the Conceptual display mode settings. Having the Conceptual display mode settings this way, walls follow the wall style fill settings: