Scroll mouse zoom bug (MAC)

I have 3 problems that I’ve encountered here, 2 are new since the latest update (5A580), and the other has been bothering me off and on for a year and I finally decided to mention it.

  1. Since the latest update to the MAC BETA, in the middle of working ill go to scroll my mouse to zoom into a section of my project and all the sudden it moves my page up and down, and i would have to hold CMD i think to get it scroll with the wheel…I thought i was hitting some hot key causing this to happen, until it began to happen to all the other students in my class with Macs and they all complained about it. The only way that we could get it back to working correctly was to save our work, exit the program, and open a rhino fresh, then everything is good for about an hour and it happens again, and again, and again… I don’t think it matters which viewport I’m in, but i want to say that it always happened when my viewport is maximized, but then again, i almost always used maximized viewports so…

  2. Also since the latest update, when i pull up another program or window, such as safari, or photoshop, or anything that will push rhino to the background, SOMETIMES when i go back to rhino (not sure how to explain this) the program will not come back to the forefront, the menus stay greyed out and i can’t click things. I seemed to only do this when i step away from rhino and i was in the middle of a network surface or sweep2 rail. Sometimes id leave the Network Surface popup menu up so as to keep manipulating my options, but ill click out to view my sketch render in another program and when i go back, i can’t do anything except pan my model. It freaked me out one time when the “save” button was greyed out and i thought i was going to lose a half hour of work, then i let it sit there for a few min and it came back… Your immediate thought may be a performance issue but i doubt it, i didn’t have a significant amount of layers built up creating much information, and i have basically a top of the line 15" MacBook Pro. I don’t normally get sluggish…

  3. This problem has been happening for as long as I’ve used rhino, but its probably more of an occasional annoyance, and seems to be happening more and more frequently. When i zoom WAAYYY in on something, sometimes it seems to go from zooming at normal speed, to zooming at 1/10 speed, and then, no more zoom, it just stops, and i won’t even be close to what I’m trying to work on. Other times it will zoom in and out no matter how far, with no problems. Nothing really seems to fix it other than the passing of time. Ill zoom WAAAYYY out and then back in a few times, and then i pan the screen in circles hoping it will reset it but it usually doesn’t help. Rebooting doesn’t usually help either.

P.S. Would it be possible to add more mouse controls for the scroll speed/sensitivity function? Ive tried adjusting my mouse software on the computer but it doesn’t seem to affect anything in rhino… Ive pretty much learned to deal with it, but when i barely touch the wheel to zoom, its zooms way too far and fast. My logitech mouse wheel has the ability to be toggled so that you can feel the physical clicks of the wheel or make it smooth, and I’ve tried both, the wheel clicks are tremendously worse because each single click is like making 3 or 4 full rotations of the wheel…

i cant help you with 1 & 2 but i can say for #3, every 3d modeling program i have used (not many) do this. you need to zoom to object or reset the view with one of the zoom commands to get you close then you can continue to zoom with the mouse from there. why it does this, i have no idea.

Have the same problem erratically. My conclusion is that the Logitech drivers are simply buggy. If it’s any consolation to you, they are also on Windows. Sometimes I get the same zoom thing happening in windows Rhino (goes nuts, way too fast), sometimes the middle mouse button just stops working. The cure in Windows is to bring up the Logitech driver app, let it load and then click Cancel. Oddly enough, that fixes both mouse problems.

On the Mac side, to slow down the zoom, you can go into Preferences>View and set the zoom scale factor closer to 1 - the default is 0.9, mine is set to 0.97 (1 will stop zooming altogether, larger than 1 will invert the mouse zoom direction)…

Or get a new, non-Logitech mouse… :confounded: I love my M705’s but Logitech drivers have just gone to s---- in the last few years, especially under Win 7 and 8…


thats funny mitch, i use a 705 as well on my mac. i love the mouse and i have no issues with it other than as you say, each click of the scroll wheel is just 10 times too far, just too sensitive. it does anything outside of rhino at normal speed. on the windows side i have a 560 and that is always fine. normal zoom speed no problem and always consistent. my space navigator however is another story. that does exactly what you guys are saying where it doesnt pick up the speed settings and axis directions you have set in the driver so you touch the thing and your all over the place. i have to hit the calibrate button or make a change in the driver then save. all goes back to normal then. i dont have this problem when its hooked to my mac. i have to do this just about every time i use it.

rhino has a camera target whose position (generally) doesn’t change when you’re navigating… when you’re zooming in like crazy but going nowhere, the camera has bumped into the target… to see this better, use the _Camera command then ‘show camera’… the camera will appear in the top viewport and you can see what’s happening with it as you navigate in the perspective viewport.

possibly the simplest way to deal with it is with the default macro ‘ZS’ (zoom selected)… select an object you’re trying to zoom to, type ZS <return>… the camera target will now move to that object and you’ll spin around it, be able to zoom to it, etc.

re: Logitech.
i’ve always used logitech mice on macs… right now, i have the MX series (mx anywhere and mx performance)…
i’ve never used nor installed the logitech drivers… OS X drives them just fine… plug&play
(though you will need to use apps such as rhino which have configurable mouse options in order to make use of some of the available buttons)

1 Like

I wasn’t able to program my thumb button on the 705 without the Logitech driver… --Mitch

that’s a letdown… maybe i’ve just been lucky with the (mice) models i use…
the one i’m on right now has 3 thumb buttons and rhino recognizes all of them.

Without drivers? Can you program the thumb button (mine also has 3, but I only use the lower one) as middle mouse click? I use that to popup a toolbar in Windows… —Mitch

yep, without drivers…
and no, i can’t remap a thumb button to think it’s a middle mouse click…

i could put this macro on a thumb button for the popup menu though:

_ShowToolPalette _ToolPalette=Popup _UnderCursor=YES _Enter

personally, i use these commands/macros on my thumb buttons:


'_Zoom Target

'_Zoom Selected

but if i wanted to remap the mouse or do things like ‘right mouse button = left mouse + cmmd + shift’, i’d have to use the logitech driver.


you should try ToggleOsnapPanelUnderCursor on one of those buttons… i think i might be the only person using that but it seems like more people would use it if they knew about it.

Funny, my Windows MMB tool palette includes osnaps which I also use often. It has a bunch of other stuff in there as well, though, including frequently used commands and scripts. I guess I’ll get around to customizing my Mac workspace sometime - as soon as I’m done teaching my class perhaps, for that I need to remain fairly “default”.


ok, i tried that, but I really have no clue what to do with it. :-/

tried what? the _Zoom Selected macro?

it should help you next time you feel like your zoom isn’t doing anything.

No, that actually did help a little, I mean the camera thing, when it came up, I wasn’t sure what to do with it lol.

oh… i meant the camera thing just as a visual aid to help understand what the rhino camera is doing… granted, it could possibly be confusing to look at… it helped me when i first encountered the problem (#3 in your list) so that’s why i said something about it.

Wanted to bump this. Been keeping an eye on my #1 problem listed at the top. There doesn’t really seem to be a definite pattern to cause the mouse scroll zoom to suddenly switch to a vertical pan, but its doing it more and more frequently. Its getting quite irritating. In the last 2 or three hours of working, I’ve had to re launch rhino an average of 3 or more times per hour to get it back to normal. It almost always happens immediately after panning around my project in fullscreen perspective viewport. When i go from panning to immediately zooming in with the mouse scroll wheel, it randomly changes the scroll wheel to a vertical pan and stays that way until i relaunch rhino. If anyone knows something that i could be pressing let me know, but as of now, I’m convinced its a bug because this never happened to me before the latest update.

i didnt notice what mouse you were using. it could be coincidence but double check to see if the mouse driver software didnt update in the background at around the same time rhino did. you could also uninstall the driver, download a new copy and install it. maybe it will correct the issue. check to see and maybe you could roll back the driver one edition. i have not seen this problem at all with my logitech mouse on my imac.

I also have the Logitech MX Anywhere mouse. I’ll reinstall my mouse software, but the fact that other mac users in my class are all having the exact same problem (ONLY since this last rhino update), while using a mix of Microsoft and Logitech mice, to me says it’s not necessarily a Logitech problem. The two guys sitting on either side of me in class both have basic Microsoft mice and I’ve seen the problem occur on their MacBook Pros.

what happens with the trackpad when your mouse controls mess up? can you still pinch zoom and rotate with 2fingers or does that go backwards too?
(just curious is all)

ok it just did it again in my top viewport, the trackpad controls worked like normal, and even more strange was that after using my trackpad, i went back to my mouse and it had fixed itself after using the trackpad, so thats new, and i haven’t reinstalled my drivers yet.

On the mouse issue (zooming), if you’re on a Mac and using a Logitech mouse, you should immediately get rid of the logitech driver and purchase the $20(?) Steermouse app. ( It allows complete customization of speeds for cursors, scrolling, etc., and recognizes all the buttons on non-mac mice of any variety, but particularly Logitech, and makes it much easier to control on an individual app basis. (Assign buttons per app, that is).

On the zoom issue: I’ve had the same problem but usually I ‘fix’ it by doing a zoom extents all “ZEA” on the keyboard. This seems to reset the mouse’s behavior for zoom-levels.