Scroll button changes to pan

I recently download the new version of rhino for mac and my scroll bar has started switching over to the pan command instead of zooming in and out. I have to talked to some other people that are having this same issue but I have yet to find a solution besides quitting out of rhino and restarting. Is there a way to stop this from happening?

it’s possible your preference has been inadvertently changed.

Rhinoceros-> Preferences…-> Mouse-> Mouse:

uncheck that one.

Those settings seem to be right. When I initially open the file the the scroll bar works fine, but after I use trim, split or a number of different functions, it switches over.

oh. I didn’t realize it was changing behavior during a session.
I don’t have a clue then.

Sorry, but I don’t understand what you mean by scroll bar in your post. These images are what I understand to be a scroll bar on a Mac.

Are you referring to an Apple Mighty Mouse with a scroll ball, or some third party mouse with a scroll wheel?

If your mouse behavior is changing, have you noticed what you are doing at the time it changes?

Seems like not many ppl are experiencing this problem. I just had this happen to me where the scroll wheel function on the mouse changes from zoom to pan (vertically only) without any changes to the preferences. It’s suddenly changed back but not sure why or how…

sorry to revive this topic.

From time to time my students have this issue also.
In yesterdays classroom 2 (Mac) students also had this issue:

Suddenly the scrollwheel was panning (scrolling) the perspective view vertically - instead of zooming.

Is this a bug ?
Is there any shortcut / hotkey that changes the behaviour ?
is there something hidden in the advanced preferences ?

(I was not able to intentionally reproduce the behaviour by any settings)

this is - as far as I think the default setting and works fine:

@pascal ?
@theoutside ?
how to change the scroll-Wheel from rotating the view to vertical pan in perspective view ? (and back - which I am more interessted)

thanks

tom