Script Compiler plugins won't load in Rhino 6

unhandled

#1

Hi all,
I wonder if I am the only one having this problem but plugins created with the current Script Compiler won’t load in Rhino 6.

I’m using the latest compiler from this link: https://www.rhino3d.com/download/rhino/5.0/rhinoscriptcompiler
It is supposed to work with Rhino 6 but at least here it doesn’t work.

I tried drag&drop… no luck. I tried the Options > Plugins > Install route… no luck. I tired to create an installer (rhi). Now it’s even worse. Every time I start Rhino 6 I get an error message: “Done installing plug-ins, press close to continue” saying Error loading - blah.rhp
I get this every time…

Please can someone help me here? @stevebaer ?

Thanks, Tobias


I need help! I so much want to like Rhino 6
#2

Hi Tobias,

I remember having same problem with Rhino 6 SR3…but it was fixed later and never happened before. Are you running the latest SR of Rhino 6? What is your version?

Here is the problem from before:


#3

Hi Jarek,
It’s true that it wasn’t like that in the past.

And I just checked… I was running SR3. Funny enough Updates and Statistics showed “This Rhino is up to date”. But when I hit the Check now link it says a newer version is available.
I’m downloading it now. I hope it’ll fix the issue.

Thanks, Tobias


#4

Unfortunately SR4 doesn’t fix the issue… :frowning:


#5

Sorry…:frowning: I have no idea how to fix it then. Hope @will or @stevebaer have some advice.


#6

Ok, seems to work with a different compiler. I used the one from Pascals post in this thread:
Script Compiler or Rhino V6 Bug?

Don’t know whats the difference with the actual one from this link:
https://www.rhino3d.com/download/rhino/5.0/rhinoscriptcompiler

thanks Tobias


#7

One issue I ran into is having duplicate entries in the registry for plugins. I had to manually delete one of two entries for them, and then, many of the issues, I was having, went away. Check your plugins under Options and see if there are any duplicate entries.

HTH,
Don


#8

Hi Don,
I see this too. Double entries which doesn’t list any commands…
So with deleting you mean deleting the rhp, sestart Rhino, the d&d again?

thanks, Tobias


#9

No, I had to delete the registry keys to get rid of the double entries. If you look at the properties of the plugin in Rhino it will show you the registry key, they will both show the same key until you delete one of them, and restart Rhino. Then the single entry will show you the other registry entry.

Maybe uninstalling Rhino would fix this, don’t know.

HTH,
Don


#10

Thanks Don! Deleting the reg key worked. Now it shows just one entry with the correct command listed.

Thanks, Tobias


#11

Glad it helped!

Maybe one of the McNeel guru’s can write a cleanup script or something.

Don