Script Compiler or Rhino V6 Bug?

rhino
unhandled

#1

Compiled .rhp files have no commands in Rhino V6. I can look at the properties in V5 and it list the command names, V6 is blank.

Thanks,
Don


#2

Bump


(Steve Baer) #3

Can you send me your .rhp? I’ll see if there is anything weird going on during pliug-in loading / initialization


#4

@stevebaer

Curve_Solutions.rhp (32 KB)


#5

SetObjectDisplayModeAll.rhp (10 KB)


(Pascal Golay) #6

Hi Don - I see that no commands show on your plug-in… the ones I’ve compiled here do show commands - is yours RhinoScript or Python ?

-Pascal


#7

Rhinoscript. Here is a package with all three file types. (.rvb, .rhp, .rhc)

HoleLocation.zip (12.3 KB)


#8

Another issue is my scripts are showing up twice in the plug-ins list under options.

Thanks,
Don


(Pascal Golay) #9

Hi Don - I’m not sure what is going on - if I modify your rhc file for my paths and compile it makes an rhp that shows the commands:

HoleLocation_PG.rhp (15 KB)

-Pascal


#10

It is interesting that yours doesn’t have a registry path:


#11

It has one after a restart of Rhino.


Script Compiler plugins won't load in Rhino 6
(Steve Baer) #12

Hey guys, I haven’t had a chance to load this in the debugger yet. Hopefully within the next few hours I’ll get a chance.


#13

Okay, Thanks Steve. I tried again, from scratch, still not working. (Here are the new files) I used the default rhinocommon settings.

HoleLocation.zip (12.3 KB)


(Steve Baer) #14

Don, it looks like you used the very old Monkey script compiler for this RHP. Is that correct?


#15

I used the newest command line version I can find.

Don


(Pascal Golay) #16

RhinoScriptCompiler.zip (36.9 KB)

Hi Don - this one claims to be from 2016 - give that a try.

-Pascal


#17

I had to delete the file three times before the command showed up in the plugins list.

I started from scratch, with the compiler you posted, and created a new .rhp file. replaced the old one and there were no commands. Deleted the file, started Rhino, the plugin was not listed, closed Rhino, restored the file, plugin listed, no commands.

I tried some variation of this 3 times and finally had commands show up in the list.

It is still listing the plugin twice in the plugins list. I noticed on another plugin it was listed in two different places in the registry under Rhino, is this causing it to be listed twice?

Computer\HKEY_CURRENT_USER\Software\McNeel\Rhinoceros\6.0\Plug-Ins\4fc08cee-44f0-bab7-f2e5-afb634870b7d

Computer\HKEY_USERS\S-1-5-21-3897607376-3925783431-1811251700-1002\Software\McNeel\Rhinoceros\6.0\Plug-Ins\4fc08cee-44f0-bab7-f2e5-afb634870b7d


#18

I have to: Close Rhino, Delete the file, Start Rhino, Replace the deleted File, Drag and Drop Again, Then The commands show up.

The next time you start Rhino there are two identical instances of the command in the plugins list.

HTH,
Don


(Steve Baer) #19

I’ll have to try and repeat this


#20

@stevebaer Is there a way to set the version number of the script in the compiler? Everything shows as 1.0.0.0 now.