Saving Failure

Process Explorer gives me the name of the original problem file: 211029_E9_Block.3dm
(I right-click>properties>Rhino.exe to see this window)

However, the file I have open and running at the time of this screenshot is my _saveAs file: 211029_E9_Block_2.3dm

To me, it looks like compute.geometry.exe is blocking my file.
I have seen compute.geometry.exe block files before in the Task Manager.

What version of Hops do you have installed? This was an issue several versions ago that was fixed (or at least I thought I fixed it).


Looks like you have 0.4.1 installed. @will and @Trav the UI for the package manager is not very clear on this subject. It is easy enough to think that 0.10.1 is installed based on the above screenshot.

@kevin3 I believe this old version of Hops may have been the problematic one that you need to either remove or install a newer version over.

I don’t think so. Kevin was getting an error code of 32 which is different than what you were getting. I also think we now understand the cause of his problem and this will go away once he installs a newer version of Hops

4 posts were merged into an existing topic: Package Manager UI installed version unclear

@stevebaer so it seems like you abandoned the idea of searching the cause of the issue affecting my (and other similiar?) system, did you?

Consider that, if possible, I can go on searching for the issue origin on my own: I just need some indication from you about the right tools I could use, to make the correct moves in that direction.

Let me know!

I haven’t given up on this, it’s just that I don’t know what to try next to determine the cause.

I am one month out from this and my problem has not returned.
I am hopeful!
Thanks for the help.


I started having this problem a few days ago. I’m attempting to write to a google drive folder and cannot save new files or existing files on the drive.

WriteLocalTempFileWhenSaving is set to “True” (also tried false and got same errors)

Results of Debug command TestLocalTempWriteDebug gave me: No error detected when saving

I am able to save to desktop.

Specs below:
Rhino 7 SR17 2022-4-12 (Rhino 7, 7.17.22102.05001, Git hash:master @ 13b57035af8fb22da005ef72c56e4555d9dbcfe3)
License type: Commercial, build 2022-04-12
License details: Cloud Zoo

Windows 10.0.22610 SR0.0 or greater (Physical RAM: 32Gb)

Computer platform: DESKTOP

Standard graphics configuration.
Primary display and OpenGL: NVIDIA GeForce GTX 1060 6GB (NVidia) Memory: 6GB, Driver date: 1-28-2022 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 511.65
> Accelerated graphics device with 4 adapter port(s)
- Windows Main Display attached to adapter port #0

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 3.3

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 1-28-2022
Driver Version:
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 6 GB

Rhino plugins that do not ship with Rhino
C:\ProgramData\McNeel\Rhinoceros\7.0\Plug-ins\Datasmith Rhino Exporter (d1fdc795-b334-4933-b680-088119cdc6bb)\DatasmithRhino7.rhp “Datasmith Exporter”
C:\Program Files\Chaos Group\V-Ray\V-Ray for Rhinoceros\V7\VRayForRhino.rhp “V-Ray for Rhino”

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.17.22102.5001
C:\Program Files\Rhino 7\Plug-ins\WebBrowser.rhp “WebBrowser”
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino 7\Plug-ins\IdleProcessor.rhp “IdleProcessor”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.17.22102.5001
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.17.22102.5001
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\Alerter.rhp “Alerter”
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.17.22102.5001
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.17.22102.5001
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”

Also one thing to note is that it does write a 3DM_TMP file to the drive location during the save process.

Hi @stevebaer @brian

Problem came back today with last Rh7 update: seems like the “WriteLocalTempFile…” value in the advanced settings was set back to “True”.
I set it again to “False” and things are working again.

Still any clue yet of what’s causing this?

Hi @gian,
Yes we switched the default to True for this setting in the latest SR with the hope of being able to debug the problem and figure it out. We had a lot of luck with remote debugging on another user’s computer to solve a somewhat related network file bug. Would you be willing to let us get on your computer and try to repeat the error that you are seeing in a remote debugging session?


Yes of course @stevebaer

1 Like

@stevebaer please just let me know a possible date/time so I can arrange to be “in house”.

RH-63409 is fixed in Rhino 7 Service Release 21

Just started having this issue today. Disabling WriteLocal appears to have fixed the issue.
Saving to a networked drive (Linux server with Samba/SMBD).
August 28, 2022
Version 7 SR21
(7.21.22208.13001, 2022-07-27)

1 Like

Hi @brian , here too the issue is still present.
And also my Fileserver in running on Linux (Raspbian)/SAMBA.

Hi Gianpietro -

Just to make sure… please be specific:
Does disabling WriteLocal on your system solve the issue in 7.21?

Yes. It does solve.

@stevebaer knows everything about the issue…and about my network, indeed! :smile:

: Gian :