Rhino 8 Temporary File Could Not Be Renamed

Recently I’ve been updating a bunch of old Rhino 6 & 7 sessions in Rhino 8 for a client and I’ve been running into an issue that I’ve never seen before:

It happens when I copy something in a second instance of Rhino, then paste it into the session I’m working in. Save then fails and the only way I can actually save is to use Save Small. I searched the issue and found these older threads:

Saving Error: renaming tempory This one has a potential solution in post 6, but that doesn’t help in my case. It just gives me a different error message when I change that setting to False in Rhino 8:

Furthermore with that setting in Rhino 8 changed to False, when I attempted to save this second screenshot in Paint, that app also said I couldn’t save the file. When I change the setting back to True in Rhino 8, then I could save the screenshot in Paint. This is definitely strange.


System Info:
Rhino 8 SR6 2024-4-10 (Rhino 8, 8.6.24101.05001, Git hash:master @ 32c244aa711e0034e75bec2e87d093c764820b96)
License type: Commercial, build 2024-04-10
License details: Stand-Alone

Windows 10 (10.0.19045 SR0.0) or greater (Physical RAM: 16GB)
.NET 7.0.0

Computer platform: LAPTOP - Plugged in [98% battery remaining]

Non-hybrid graphics configuration.
Primary display and OpenGL: NVIDIA GeForce GTX 1060 (NVidia) Memory: 6GB, Driver date: 4-2-2024 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 552.12
> Integrated accelerated graphics device with 4 adapter port(s)
- Windows Main Display is laptop’s integrated screen or built-in port
Primary OpenGL: NVIDIA GeForce GTX 1060 (NVidia) Memory: 6GB, Driver date: 4-2-2024 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 552.12
> Integrated accelerated graphics device with 4 adapter port(s)
- Windows Main Display is laptop’s integrated screen or built-in port

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 8x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 4-2-2024
Driver Version: 31.0.15.5212
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 6 GB

Rhino plugins that do not ship with Rhino
C:\Users\MSI\AppData\Roaming\McNeel\Rhinoceros\7.0\Plug-ins\XNurbs (80be33b0-13b2-4ac4-9c77-03829214f9e9)\5.2.0.0\XNurbsRhino7.rhp “XNurbs”

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 8\Plug-ins\SolidTools.rhp “SolidTools”
C:\Program Files\Rhino 8\Plug-ins\Commands.rhp “Commands” 8.6.24101.5001
C:\Program Files\Rhino 8\Plug-ins\WebBrowser.rhp “WebBrowser”
C:\Program Files\Rhino 8\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 8\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino 8\Plug-ins\RhinoBonusTools.rhp “Rhino Bonus Tools”
C:\Program Files\Rhino 8\Plug-ins\AnimationTools.rhp “AnimationTools”
C:\Program Files\Rhino 8\Plug-ins\IdleProcessor.rhp “IdleProcessor”
C:\Program Files\Rhino 8\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 8.6.24101.5001
C:\Program Files\Rhino 8\Plug-ins\RhinoRender.rhp “Legacy Rhino Render”
C:\Program Files\Rhino 8\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 8.6.24101.5001
C:\Program Files\Rhino 8\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 8\Plug-ins\MeshCommands.rhp “MeshCommands” 8.6.24101.5001
C:\Program Files\Rhino 8\Plug-ins\IronPython\RhinoDLR_Python.rhp “IronPython” 8.6.24101.5001
C:\Program Files\Rhino 8\Plug-ins\RhinoCycles.rhp “RhinoCycles” 8.6.24101.5001
C:\Program Files\Rhino 8\Plug-ins\Grasshopper\GrasshopperPlugin.rhp “Grasshopper” 8.6.24101.5001
C:\Program Files\Rhino 8\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 8.6.24101.5001
C:\Program Files\Rhino 8\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 8\Plug-ins\Displacement.rhp “Displacement”
C:\Program Files\Rhino 8\Plug-ins\SectionTools.rhp “SectionTools”

Is this “D:” drive being automatically synchronized to a backup somewhere?
If so, that would explain it. The synchronizing tool has to temporarily lock the folder while the files are copied. If you have the bad luck of doing a Rhino file operation during the temporary lock, this is what will happen.

You might try enabling this Advanced setting to minimize the traffic on that folder location:

My D drive is not synchronized to backup, no. Someday I’d like to set that up though.

That advanced setting has always been set to True for me and I still get the “Temporary File Cannot Be Renamed” error message. If I set it to false I get the other error message that says: “Writing to the disk or storage device failed” error message.

I’ll assume that your C: drive is too small to put your file there?
Does your D: drive have lots of free space?
Are you running any local antimalware tools? If so, maybe temporarily disable it to see if that effects the problem.

Sorry, but I’m out of ideas.

Oh man, I went and took a look at my D drive (1TB spinning) and it only had 108MB of free space left currently. I just freed up 60 gigs of space and I will report back about this.

That could have easily been the problem.
Generally, you don’t want your storage drives more than 80% full.