Saving Error: renaming tempory

I just did the latest Rhino update yesterday. Since then I can’t save files, unless I save them with a new file name.

I tried to safe them in

  • my normal cloud folder (nextcloud), didnt work
  • Folder outside cloud (d:), didn’t work

Looks like a permission problem. I tried to change permissions (right click on rhino - settings) but didn’t help. Only difference i can save now on desktop.


Error translates like this:
Saving of Rhino-7 file failed. Temporary [file?] couldn’t be renamed,

Any suggestions? Any updates to fix it?

Rhino 7 SR21 2022-7-27 (Rhino 7, 7.21.22208.13001, Git hash:master @ c31aea87137a5d0de449338a7ef6856f49dd4797)
License type: Kommerziell, Build 2022-07-27
License details: Cloud Zoo

Windows 10 (10.0.18363 SR0.0) or greater (Physical RAM: 16Gb)

Computer platform: LAPTOP - Plugged in [98% battery remaining]

Standard graphics configuration.
Primary display and OpenGL: Intel(R) HD Graphics 620 (Intel) Memory: 1GB, Driver date: 2-3-2022 (M-D-Y). OpenGL Ver: 4.6.0 - Build
> Integrated graphics device with 3 adapter port(s)
- Windows Main Display is laptop’s integrated screen or built-in port

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: Intel
Render version: 4.6
Shading Language: 4.60 - Build
Driver Date: 2-3-2022
Driver Version:
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 1 GB

Rhino plugins that do not ship with Rhino

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.21.22208.13001
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.21.22208.13001
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.21.22208.13001
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.21.22208.13001
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.21.22208.13001
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”
C:\Program Files\Rhino 7\Plug-ins\Calc.rhp “Calc”

Hi Aurèle -

I would think it doesn’t, but, just to make sure, does reverting to SR 20 make this any better?

Hey wim. Actually it helped. I can save with Rhino 7.20.

  • deinstalled Rhino
  • installed 7.20
  • saving works normal again
1 Like

Hi Aurèle- by this do you mean that with 7.21 you can save files to the desktop without needing to re-name, but to other locations on your local hard drive you cannot?


@hauptsachetiny are you saving to a network location? If so, please install 7.21 and try this:

  1. From the Tools menu, click Options
  2. In Rhino Options > Advanced, type “write” in the search box
  3. Change “Rhino.Options.FileSettings.WriteLocalTempFileWhenSaving” to false

Does this fix the issue for you?

Hey Steve,

kind of network location. I is on my local hard disk but I am using Next Cloud to sync my files.

Saving didnt work on folders which are not synched neither btw.

I’ll try your solution with the next update. Dont want to do run the update right now to 7.21 right now as it is kind of working right now