Save-Open doesn't maintain displayed viewport

YT: RH-42421

On my dual-display setup, when I save a file with a floating maximized perspective viewport on the secondary monitor active and a maximized Right viewport on the primary monitor, exiting Rhino and then opening that file will switch out the Right viewport with the Top viewport. Screenshots in bug report.

Hi Wim - thanks - I see something differently wrong here, at least for now – the floater is correct but the maximized vp is not maximized - I get four views when I reopen my test file.


Just to make sure, the floater is also correct on my end. And if I remember correctly (not near a machine at the moment), when I save a file with maximized floater on secondary at work where I use two external displays that are connected to my docking station, and then open that file at home where I only use the laptop screen, the floater is small but the main window has become a 4-view.

I’m running into a somewhat similar problem.

I’m running non-maximized Rhino and GS on my secondary screen. When I restart Rhino and GS, they first appear on the right screen and position before jumping to the middle of the primary screen.

During the same session if I close GS (with both Rhino + GS running on secondary screen) it reopens in the middle of the primary screen.

When running on primary screen both Rhino and GS retain their position.

Problem described above seems to be related to NVIDIA’s nView Desktop Manager > Windows Manager > Open Windows On setting defaulting to Display 1 after a driver update few weeks ago. Resetting to Default Display seems to fix the issue.

Hi Pascal,
an update on this one. Looks like some of my customization might be causing some of this.

For whatever reason I can’t remember now, I removed a MaxViewPort toggle from my startup commands.
After that, I’ve been getting annoyed with my default template always opening with a maximized perspective viewport. To try and fix this, I decided to update my default template today by making sure to save a new file with 4 views.

I didn’t get that to work (it would always open with maximized perspective viewport) and so I had to dig deeper.
I removed all my startup commands and then realized that the OneView command maximizes the perspective viewport. … which is something I don’t want - hence the MaxViewPort toggle in the startup.

At any rate, without my customizations, I see the same as you are seeing - the floater is correct but I get four views when I reopen the file.

Going off-topic - start rant…
As stated on several occasions before, I still reckon it was a mistake to mix function with setup when the AutoCPlane script was internalized as the OneView command. And on top of that, using the setup as the command name! It’s the function that is looked for in that command, not the viewport setup.
-wim out…

Hi Wim - thanks -

@piac - do you think we can add MaximizeView=Yes/No as an option in OneView for the future ?


@pascal we certainly can. I am just doing as told with this one. A YT item might be useful not to lose this. Logged as RH-42698.