Save as dxf problem

hiya all

I save some of my files as dxf files to send to the people who cut fabric for me, in Rhino 6 everything looks fine and I can save as a dxf without errors. But when I open the dxf file in any other dxf viewer there are lines missing and the text is oriented wrong ?
is there a tutorial for saving as dxf anywhere as this is quite urgent for me …
also in windows file view the file type never says .dxf ?? only Rhino 3-D ModelV4 DXF BMW.dxf (277.6 KB)

Hi @fragged8
Can you take a look at the file attached, does it work?
DA-test.dxf (252.6 KB)

hiya

it opens in rhino fine, but if i open in Vectric aspire the x,y scale is way off x=12257.085 y=1935737.933 ? and no model in sight … ? and if i open in Jetcam viewer the scale is massive too and no model seen…

@fragged8
I didn’t do anything with the scale nor change it’s orientation.
Maybe you could open it and scale it to the right size and orientation, then upload it again.
However, are you seeing the missing lines?

This is the odd thing, I seem to get very random results ? I didn’t see the model at all in the other software it disappeared ?
The only thing I changed was save as dxf R14

@fragged8,
After orienting and scaling to the right dimensions, can you try saving it as 2007 lines. see attached.

HI Doaa.

thank you I believe that has worked, i opened the file with Vectric Aspire and it looks much better and scaled correctly :slight_smile:
When I save as dxf, do I need to make sure the Front view window is active ? because sometimes when I save and email the files to my cutting guy he can only see an edge view of the drawing .

thank you for your help :-):rainbow:

hmm, I do not believe so.
but, the orientation depends on the software x,y,z.
For example: Rhino Y is SolidWorks Z, meaning the orientation depends on the software and will align the geometry to the its own X,Y,Z.

Hope this makes sense.

1 Like

It looks to me as if you have modelled this in Front view as the geometry in the dxf is vertically orientated. For 2D cnc cutting, the geometry ought to be in the ‘World Top’ Cplane to begin with.

You can select all the geometry (turn all layers on in case you miss something) and use the Gumball to rotate to the correct orientation, followed by project to Cplane to put the geometry at the correct elevation. You could Also use orient3pt for this operation.

I noticed your cut lines in the dxf are all exploded - this can be a trap in some of Rhino’s dxf schemes, maybe the cnc software will join them up, but best to get it right in the first place.

image

1 Like

yes I understand thank you …

Hi @BrianM
I did notice the explode check box but just left it checked, from now on I will turn that off. and I stopped using the gumball and don’t really know why but tonight have been playing with it again, I think saving in 2007 lines has helped most of my saving problems but yes i’m full of bad habits at the mo I need to shake off :wink:

This is about one third of a building end wall I am making for BMW to show Mini’s in at an event and has to be made and fitted before the 27th so I hope I get this one right … over 40m of fabric !

As for the boat covers Brian here’s the first one during fitting and fitting another tomorrow .

I usually just turn the Gunball on for this sort of operation.

The Dxf scheme, it can be useful to save the scheme to a custom name and change the settings to suit your requirements.

Cover is looking good, although the light blue one on the bow could do with a tighten up… :smile:

2 Likes

If it makes you feel any better I made the same mistake a few times when I first started doing engraving layout in Rhino and sending it to my engraver in dxf.

I now make sure I layout everything from the world top view for my engraving software as BrianM wrote.

I have been using the default and @BrianM `s point about the Explode Curves checkbox prompted me to check. Default has it exploded. Changing to another profile to see if that option unchecked gives me a better engrave…guessing it will.

1 Like

I used to have the same problem with various CNC machines. What works for me is when exporting, make sure you export to the CPlane & I dropthe ACAD value to an older version

2 Likes

Hi all - RemapCPlane is the deal, when you find you have everything correct but in the wrong plane.

-Pascal

3 Likes