Round Hole and Boolean difference failling?

I am trying to add a simple counterbore to this model and for some reason the round hole command and boolean difference command are failing. The red plug is what I am trying to remove from the model. What am i doing wrong?

BOOL_DIFF_FAIL.3dm (132.6 KB)

Works here just fine. Are you sure you picked the polysurface to subtract from (the rod) first, and then the plug?

Yes, I just tried again and it fails for some reason???

Here is my version for what it is worth.

Version 5 SR10 64-bit
(5.10.41201.11145, 12/1/2014)

I clicked on “check for updates” & “check now” but I just get a blank browser for some reason (google chrome). Usually it tells me I have the most current version.

I had this same problem yesterday with a different model, but I eventually got it to work. Not sure what I did to make it work?

I just tried it on a different machine and it worked fine? Any Idea why it only fails on my machine?

If you make the plug just a little too long, so that it protrudes slightly this will be more reliable. It works here either way however…


Tolerance ? …

There is a bug in the latest service release which affects surfaces of revolution that have the curve parameter first and angle parameter second. The inner cylinder in your green thing is one of those. To work around the bug, extract that surface, call Dir, then choose swapUV. Now rejoin. The boolean will work. The bug has already been fixed for the next sr.

Surfaces with that property should not be all that common, but I’ve seen several in the past week. Do you recall how you made the green object?


This would not work in this Version 5 SR10 64-bit (5.10.41015.17045, 10/15/2014).
I opened it in Version 5 SR8 32-bit (5.8.40315.18095, 3/15/2014) and it worked just fine.

All my best … Danny

Pascal - I know that it tends to work better when there are less co-planar faces so I tried that before I created this thread and it still did not work.

Chuck/Lopacki - The other machine I have is running SR9 and it performs the operation fine. I will try swapping the UV and report back.

Chuck - Swapping the UV of the deep cylinder in the green part made no difference, but swapping just U made it work. I originally made the cylinder using the “RoundHole” command.

Thanks for checking on this. I’m not sure why swapping uv didn’t work for you. It did for me, using the same version as you. At any rate, the problem is fixed in the next service release.