Boolean Difference failed

rhino
booleandifference

(Ashlynw1998) #1

boo

Anyone have any idea why this boolean difference is failing? Trying to subtract the red shapes from the grey slope. Please let me know if you have any suggestions!!


#2

Is it possible to upload the model, or the parts that failed?
It would be difficult to guess what went wrong.

One is tolerace, perhaps if you can extend down the red object further into the grey one, it will be blooleaned.


(Info) #3

I always have some overlap in boolean solid differences, just in case…


#4

Other is if surface seam is right at the boolean?
srfseam can be used to move the seam perhaps…

or… I guess manual trim maybe faster…


(Ashlynw1998) #5

The red shapes are definitely hitting it and going into the grey slope polysurface. I can try to upload the file, but I’m not sure what you mean by tolerance


#6

Tolerance, I mean the file tolerance, sometimes distance between or too acute angle in some objects/edges and others that rhino can’t see it as close enough and may fail to boolean the objects.

Just one other is as you mentioned since red is solid and grey is just a surface?

In anycase, if the grey is just a surface, it seems easier if you just use trim command to trim to remove unneeded parts and join to combine.


(Ashlynw1998) #7

The grey surface is a polysurface and I did MergeAllFaces. I did something extremely familiar just outside of the picture but with the same polysurface and same type red boxes and it worked. I’ll attach pictures.
The fact that it worked before and not now is what’s puzzling me.


#8

Hmm not sure…

I’d just use the trimimage in that case.

Select to highlight the grey polysurface, then trim the upper part of the red box.
Then highlight bottom half of the trimmed Redbox and trim away the grey surface.
(I’m supposing you’d like to dig up the grey ground using the red box.)


(Wim Dekeyser) #10

Sorry, but that’s rubbish. Booleans fail if the trim curves that are generated behind the scenes are not complete. It has nothing to do with objects being open or not.