Rotating a view in paper or model space

I use rhino for 3d but I do also use as my 2d drafting layouts but I tend to project my 2d drawings out from the plan as the pic attached: But when it comes to paper space or even when working in model space I cant seem to work out if there is a way of rotating the view (without turning the model around), so I can display and work on each elevation the right way up. in auto cad I was able to do this by rotating the view

Hi @peterson_perg, I have the following 2 x command lines on Alias’s for quick rotation.
_RotateView Left
_RotateView Right
Each time you run these it turns the modelspace viewport or a layout detail viewport by the degrees set in the Rhino Options:
FILE - PROPERTIES - RHINO OPTIONS
Then look for the Rotate menu on the right hand side.
Increment in divisions of a circle: 60
which effectively makes a 6° turn every time you run the command.
Change to 72 if you want 5° increments. Or change to 4 if you want to turn 90° each time.
Note that this applies to modelspace Top view. Layout Space is normally Top view but same here.
Hope that helps… Michael VS

Hold the SHIFT + ALT hey and rotate the active detail.
Notice how the cursor hand changes near the border of the view/detail.
At the edges the rotation increments with x degrees for easy rotating to exactly 90 deg.

HTH
-Willem

1 Like

hi @mvyess this is exactly what I wanted thank you! Just one note I had to change the option to rotate around Tworld view for it to rotate how i wanted

Hi @Willem I didnt understand this is if I hold shift and alt I cant rotate? using gumball rotate?

thanks

Hold both keys and RMB than rotate the view ( or an active detail)

HTH
-Willem

Hi Ferg - the command version is TiltView - you can enter a specific angle.

-Pascal

2 Likes

BTW - for those who try this ALT-SHIFT RMB rotate of your viewport, and you get stuck in some weird angle, and you want to get back to your original non-angled view, just type “4” in the command line for your original 4-view viewport situation and it snaps back to the normal view.

I block my 2D views, then I can rotate at will and not alter the viewports. For a basic 4 sided room I block the plan then rotate it 4 times and project the elevation up from each block. That way everything is always right reading.

1 Like

Hi @peterson_perg can you please tell me what you wrote to make it rotate the world view?

Also, to @mvyess – I assume it is different on a MAC, but I don’t see where to change the increment to 4 in order to rotate 90º each time. Is this something you can write into the command macro for the alias?

Thank you!

Try:
_TiltView Angle 90

1 Like

thank you!

How about using CPlane command with either Object or 3Points option, then typing _Plan command to align your vport? Does that do the trick?

Thanks to “Jarek” on the forum

2 Likes

couldn’t link to his original post for some reason…

Thanks. that was super!

1 Like

hey,

i don’t understand why someone hast to use a command [tiltview] to rotate the drawing within the layout, which disables pan btw, instead of simple rotate the layout?

cheers,
Ben

TiltView works only in model and detail views; it does not work in layout space.

Any help in order to rotate the view in some details of the layout?

Thanks!

hello @armengoligasull , In my experience Tiltview works fine inside a layout detail when the detail is active and for 90 degree 2D rotations I use the command:
_TiltView Angle 90
If you want to rotate the actual layout detail border then this can also be done using the normal Rhino rotate tool but only really works at 90deg increments properly. - Michael VS

1 Like

Thanks Michael!
The point was to activate the detail (being inside) I was missing that point!!! And then run the command _tiltview. Using the angle wasn’t working properly (need to learn more) but instead I used the click and drag option.
Thanks a lot!

1 Like