''Rotate Around World axis'' doesn't rotate around world axis


#1

Hi all. When I create a simple part in a new file, the rotate view (right mouse button) works the first time (i.e the centre of rotation is around the world axis). However, when I zoom in and then try to rotate the view, the centre of rotation moves somewhere else- very frustrating indeed. Any ideas anyone? I’m sure I have something checked/ unchecked that i’m not suppose to. I usually use ‘zoom extents’ when this happens, but it doesn’t seem to work in the mac for rhino version.

Cheers,
Anthony


#2

Select something desired to rotate around, then issue ZS (Zoom Selected) for one window or ZSA (Zoom Selected All) for all windows.

~Dave


#3

Hi Dave, Thanks for the suggestion. I do this a lot in the PC version, and even have a shortcut for this function under my middle mouse button. However, in the current mac version, even the ‘zoom selected’ function doesn’t work properly.


#4

Sounds like you may have some corrupt preferences? ZS and ZSA both work fine for me in MacRhino.

~Dave


#5

what do you mean, exactly, by ‘it doesn’t work properly’

I think you might have to be more descriptive of your problem.

(because to me at least, zoom selected does ‘work properly’ in the latest mac build)


#6

Hi Jeff, apologies- my description of the problem was pretty poor. To elaborate;
When I have an object selected and click the ‘zoom selected’ function, the function does indeed work initially. Then, when I rotate immediately after doing this, the centre of rotation is correct (i.e. I am able to rotate around the previously selected object. However, as soon as I zoom out and then try to rotate around the object, the centre of rotation has moved a really long way from the intended point. It sounds complicated put into words, but it really makes the program unusable, as the intended object is rotated out of the viewport. I’ve tried playing with the ‘‘preferences>view>rotate>rotate around world axes/ rotate relative to view’’ and this does not seem to solve the problem.


#7

heh, then i actually do know what you’re talking about and like you, find it hard to put into words…

i’ve tried to bring it up here&there in the past but i’ve never really went for it since i don’t know how to describe it in words (it would be difficult to show in a video even… almost like it would require sitting down at the same table/computer with a developer to explain :wink: )

i see the problem much more readily on my laptop/trackpad than i do when using a mouse… when using a trackpad, i pretty much have to zoomSelected or zoomExtents after any zoom/rotation in order to reset the camera… and like you, i find the program almost unusable under those circumstances for any serious/efficient work and basically only use the trackpad for simpler drawings which don’t require much navigation… i have to always have my mouse on-site (i do drawings on a job site at times) in case i need to do any more complex drawings…
it’s not nearly as bad when using a mouse but the problem does still persist…

the problem as i’ve tried to call it in the past is “objects lose or fail to gain focus when navigating” – i feel when i said that before that nobody really understood what i meant but you probably do.

anyway-- if you’re saying this doesn’t happen on windows rhino then that’s good news and it’s what i’ve assumed all along… (i don’t have windows so i don’t really have much to compare to other than different 3d apps in which this problem doesn’t exist… in other apps, i might zoomExtents or selected in order to get a certain view-- but never as a means to reset the camera which is why i most often use those commands in rhino)

i’ve just been hoping that someone at mcneel would eventually try out rhino-for-mac and be like “hey, something isn’t right here”… i know @pascal has a macbookAir but i don’t know if he’s found this weirdness with the camera while drawing with the trackpad (to me, the difference is pretty obvious within a minute or two of drawing.

in the meantime, something you can do to ‘see’ what’s going on with the camera is:
show 4 viewports, bring focus to the perspective viewport, run the command _Camera, choose ‘Show’… now navigate the the perspective viewport and you can watch what the camera is doing in the other viewports…

maybe based off what you see with that set up, you’ll be able to come up with a way to better explain the issue? (because i can’t explain it properly… here’s a wall of words and i still don’t think i’ve made the point :wink: )


#8

One thing that seems to help mitigate this (for me) is to keep your objects centered at the world origin. If objects are far from this, some pretty funky things can happen when rotating.

I tip my hat to you, Jeff, if you can model on your laptop without a mouse while keeping your sanity!

~Dave


#9

ha.
thing is, in sketchup, I can use the trackpad just as effectively as a mouse… but sketchup doesn’t have gestures like rhino does and also requires more mod keys and/or depressed trackpad while swiping. (for example-- cmmd-control-trackpad button depressed + another finger to swipe = orbiting… It’s ingrained so I don’t worry about it to much but rhino’s simple two-finger setup is way better)

but sketchup’s camera behavior is a lot better. if the camera in rhino worked better (or- was better at predicting where to rotate around based on what a user sees on screen), then rhino would be a lot better than sketchup regarding trackpad use to the point where I’d often prefer using a trackpad over a mouse.


#10

Thanks Dave and Jeff,

As suggested, I ran the command _Camera and then ‘‘show’’. As expected, the centre of rotation (of the camera) moves away from object/ world axis when the camera is zoomed out. Very frustrating. Let’s hope they fix this pretty soon.

Thanks anyway for the suggestions. If you come across any fixes, it would be great if you could let me know.

Anthony


#11

i guess step1 would be seeing if the developers feel the behavior is ‘broken’ in the first place…

as in- i’m not even sure if it’s a request or more of a bug report.

(to me, it’s something that needs fixed… but i can also realize there’s room for multiple interpretations here and it’s not so easy to ‘prove’ that it’s broken)


#12

this isn’t a fix but, it might be a decent way to show an example which more closely resembles the desired behavior… (and, in some scenarios, would be fine to work this way and eliminate the camera issues-- albeit with the caveat of the user needing to select items in order for it to work right)…

turn on gumball then select an object… click the white circle on the gumball then choose ‘settings’… choose the option ‘Rotate view around Gumball’…

now, when you select an object, the camera will be focused on the object…

i wouldn’t say that’s exactly the way the camera should work (and it obviously shouldn’t require you to select an object) but it’s pretty close.


#13

Thanks Jeff! This is more like the behaviour I’m used to and makes the program much more usable. Looks like it’s pretty important to have gumball turned on then!
Maybe there are good reasons the developers have implemented the function in this way, but for the moment those reasons escape me.

Much appreciated,
Anthony


#14

well, it’s only sort of ok since it only works out right if you have the item selected and problems will still arise due to that… (or, if you’re in the middle of drawing something which requires you to zoom in pretty close, snap to a point on object1, then needing to snap to object2 over there-- there’s no way to use the gumball workaround in this scenario since i can’t select an object while in the middle of a command.)

but yeah, i can see it helping out in many scenarios.


#15

How are you zooming? On the Windows side, mouse wheel or Ctrl + right mouse button will zoom keeping the target in (mostly) the same place. Alt + RMB or Alt + mouse wheel will do what you are describing, which is to move the camera and the target.

If you find your target is off, you can manually reset it with PlaceTarget, or zoomTarget.


#16

Hi Sam,

Thanks for the advice. The middle mouse button alone, RMB + Apple key and RMB + alt all zoom in the mac version, but all not very well.
The RMB+ apple key is the closest to the desired behaviour (i.e around the world axis or an object). However, even this shifts the rotation point somewhat.

Anthony


#17

yeah, mac rhino has those controls too.
if drawing in perspective view using a combo of all of them while the camera is visible in the top viewport, you can typically get around ok… i think it would be impractical to work that way though.

realistically, you want to be able to get around using only the scroll wheel which zooms to cursors…

something i noticed about zoom-to-cursor is that rhino is only considering the left-right-up-down position of the cursor on screen and it’s not paying any attention to what the cursor in the 3D scene is on… or- actual objects in the scene are not being considered.

in other words, zoom-to-cursor is doing two things at once… it’s zooming in the same way cmmd-RMB (ctrl on windows?) as well as panning the camera…

the expected behavior is that the target point would also move towards or be influenced by objects which are ‘behind’ the cursor when using the scroll wheel… not necessarily in the way that dollying (opt-RMB) works because that also ignores objects and will simply place the target ‘behind’ an object.

basically what i’m saying is the the camera is completely unaware of the objects in the scene in regards to navigation… but the user’s main focus are the objects therefore the camera should be a little more intelligent about what we’re seeing on the screen (imo)


(Pascal Golay) #18

Hi all, I’ll take a look… sorry for the delay. BUT, in general, I am way too stupid to work with a track pad in Rhino, so I’d never run into this if it is specific to track pad. (the gesture, tap to click touch action on the Air trackpad drives me mad, btw, and I only use the click, not tap, to interact with it. Otherwise it cannot distinguish between accidental touches and deliberate ones, so I find my cursor pops to some other location if my cuff ever so slightly brushes the thing, or I send an email by accident before I’m done… There is no way to disable the damned thing either, in Windows, if a mouse is connected either… Phew, I feel better now.)

-Pascal


#19

haha. yeah, I can’t use tap to click either. bummer you can’t turn it off with windows installed.

generally, the problems described are worse with a trackpad but they still apply to mouse usage as well (what I said in the last post was mouse related)

for starters, does rhino work the same way on windows as I (attempted to) outline in my post before yours?

thanks for looking into it


(Pascal Golay) #20

Zooming in and out does change the camera target - you can see this if you use F6 to turn on the camera in the perspective view- dynamic zooming depends upon the cursor location and I suspect the location on the trackpad is much less precise than on screen with a mouse, so the change may be accentuated.

-Pascal