Right click rotating sometimes cancels operation

Experiencing a frustrating MacRhino bug where right click rotation in perspective mode randomly cancels the current operation. I have “right click” set to rotate and “shift right click” set to pan when in perspective view. When executing an operation like “multiple points” or “orient 3d” where I have to rotate around in space multiple times before the operation is finished, right clicking to rotate will randomly end the operation as if I had hit enter or the space bar. Same thing happens in WIP. Using a magic mouse, but same problem occurs when using a wired 3 button mouse.

anyone else experiencing the same problem?

Anyone?? Mcneel??

@dan, @marlin - probably something for you to look at.

It also appears to happen when right clicking to pan in 2D mode (Top, Side, Front, etc)

(emphasis on randomly mine)

I have seen similar reports of this and I think I have experienced this myself…I think. This is one of those very difficult to reproduce ones.

I have been right-clicking to orbit in “Orient3pt” for the last 10 minutes and I cannot reproduce this. I understand this one might be one of those “I can’t seem to reliably repeat it, but I know it happens!” type of bugs…so any more clues you can give would be greatly appreciated.

Yeah I think you’re right on the money. Unfortunately I can’t seem to find any more specifics… All I can tell you is if I just right click under the same circumstances (not right click and drag like I was describing before) it does absolutely nothing. Doesn’t cancel the operation like when I right click and drag. Also I noticed it seems to happen when I shift right click to pan in perspective mode as well as right click to rotate. Problem is, it seems entirely random and it happens all the time for me… If I can find any more correlations I will certainly post them here

In the past couple week, I’ve also noticed the same thing happening to me, but I use Rhino on Windows. When I hold shift to pan or just orbit with the right-click, sometimes it will randomly register as a regular right-click. This results in either initiating the previous command or exiting out of my current command. And sometimes, holding shift and right-click-drag does not pan at all. I’m not sure if this is a performance thing (my model is not that complex/heavy) or just some bug. It did not happen before and I don’t think I’ve updated the software in the past few weeks.

If the mouse isn’t moving when you right-click, Rhino interprets that as pressing “Enter”. If the mouse if moving, it’s a Pan/Rotate.

I would expect this to be effected by your current mouse motion and click speed settings.
You might try an adjustment of those and see if anything changes.

It’s definitely not that… I will very deliberately make sure to click and drag to prevent this from happening and it happens anyway. This is definitely a bug and not user error. Also a simple right click does not work like it does on PC… right clicking will do absolutely nothing (as I believe it’s supposed to on Mac) or it can pull up menus which I have disabled in settings, but it does’t function like enter or the space bar as it does on PC (although I wish it would!)

I understand.
Please understand that we can’t fix problems until we can reliably repeat them in a “debug” build of Rhino so we can see the issue in code as it happens.

I have not had the problem myself. I do a fair amount of Mac Rhino testing, but I do not run it all day every day.

Of course. Thank you for your help!

I’d wish for that too…

Philip

It appears that this bug was a direct result of having Better Touch Tool installed on my system. After I finally thought to try quitting BTT, the error has not reoccured. It was also causing similarly frustrating bugs in Adobe Illustrator. What a relief!

Hi,

I know this is a very old topic, but am still experiencing this behaviour in Rhino 6.23. When you orbit your camera using the right mouse button while a command is active, Rhino will sometimes end the operation if you do not rotate enough while right-clicking. This seems to be because it registers it as a simple right-click instead of a right-click + drag.

Is there any way to disable right-click ending the current operation?

One example where this is troublesome is when your are drawing a curve and it will suddenly end the curve before you want it to, so that you either need to extend the curve by creating a second one and joining the two, or by deleting the curve and recreating it from scratch.

Kind regards,
Yurrit

I have been experiencing this as well (Rhino for Windows) but have not figured out yet when it exactly happens. I’ve gotten used to working around this though (of this is the same thing we’re talking about): When I try to rotate or pan and I see nothing is happening in the viewport while I move my mouse I know it will register it as an “enter”, this either finishing the command or repeating the last command. My solution to this so far has been to keep holding the right-mouse button while dragging the pointer outside of the viewport. If I let go of my right-mouse button outside of the viewport, it doesn’t get registered as a “enter” and I don’t accidentally exit or repeat the command.

When that happens to me, it’s time for me to charge up my mouse battery again.
Are you running a wired USB mouse or running fresh batteries?

1 Like

In my case I almost always use a wired mouse. I’ve also noticed this at our workshop on another computer with wired mouse.

Has this been resolved? I’m running 6.29 on windows - I’ve never had this issue previously. I’ve tried the workarounds posted on this thread and others but can’t find a solution.

Hi,

Nothing has been filed or worked on regarding this to my knowledge. I think because it is intermittent and seems to be system specific making it hard to reliably reproduce. You also replied to a Rhino for Mac thread but are using Rhino for Windows so replies might get confused if anyone suggests Mac specific changes to try.

I’d suggest trying another mouse myself. I’ve had stuff like this happen over the years due to dust getting in the RMB contact for instance or the mouse needing new batteries. Since RMB is both rotate and Enter in Rhino, if it sticks or double clicks that can cause what you described.