RhinoPython editor not opening; changed Paths available in Tools -> Options, not sure how to fix

rhino
rhinopython
python

#1

I was testing out which paths we could not include in installing IronPython in a given Windows PC (EDIT: I had another IronPython version installed externally in Progam Files (x86)), and accidentally removed one of crucial paths to IronPython (I’m referring to the one that is shipped with Rhino), which is now preventing the RhinoPython Script Editor from opening up when I try to call it from the Rhino Command Line (i.e. EditPythonScript).

tools options

I think I only left behind C:\Users{UserName}\AppData\Roaming\McNeel\Rhinoceros\5\Scripts (exactly what I’m talking about is pictured above). The thing I removed by accident was c:\Program Files\Rhinoceros 5 (64-bit)\Plug-ins\IronPython\Lib. I’ve only ever installed IronPython once and that was it, so I’m not sure how to go about fixing this problem. Any links or instructions on what to do/uninstall/open up would be much appreciated.

I’ve also been getting the following error message, so I’m not sure if it’s a question of uninstalling and installing IronPython again:

scriptcontext test


#2

You shouldn’t have to install IronPython, as Rhino comes with its own build*. I would recommend uninstalling IronPython on your system and then click the Restore Defaults button in the Rhino Python Options window.

*If I recall there were a few threads a while back dealing with the issue of having IronPython AND Rhino installed on the same system (in case you need both).


#3

Well, what’s happening right now is that I can’t even open up the Rhino Python Script Editor, so how would I go about doing the ‘Restore Defaults’ if that were the case?


#4

You could try to edit the xml file where these settings are stored directly, located here-ish:

C:\Users\YOURUSERNAME\AppData\Roaming\McNeel\Rhinoceros\5.0\Plug-ins\IronPython (814d908a-e25c-493d-97e9-ee3861957f49)\settings\settings.xml

If I recall one might simply delete this file to restore defaults. Don’t hold me to that though. Could save a copy and then try that out. I’m sure Steve and Giulio can answer these questions.


#5

@piac, @stevebaer, any thoughts on this? Not really sure how I should proceed, since I’m afraid I might delete something and make the situation worse.


#6

@AndersDeleuran, tried that out (I made copies of the settings.xml files) but no luck even after I restarted Rhino. :frowning:


#7

UPDATE: Okay, solve this somewhat: I edited the text of the settings.xml file to contain the missing addresses of the IronPython package already shipped with Rhino. That appeared to solve the Rhino Python editor not initializing, but I’m not sure if this is just a stop-gap or an actual solution.


(Giulio Piacentino) #8

HI @Bianchi

I think you solved the issue now. If you want to make sure, just “Restore Defaults”.
If you need any more help, please let us know,

Giulio


Giulio Piacentino
for Robert McNeel & Associates
giulio@mcneel.com