Python Editor not opening on Rhinoceros 5 SR12

rhino
rhinopython
python

#1

Hi All,
When trying to run the “EditPythonScript” Command on Rhino, the command doesn’t do anything. Normally the editor window pops up. At that stage there is nothing happening at all. Is there any fix for this issue yet?


(Pascal Golay) #2

Hi Man - it sounds like the Python plug-in is not loading- check Options > Plug-ins for Iron Python. Is that there and enabled? (checkmark)

-Pascal


#3

SR1…??? What happened to 2 through 13?


#4

The Ironpython plugin enabled there. Is there a possibility to reinstall it?


#5

Did you used to have 2 screens for this computer and now run one monitor? After typing EditPythonScript Try holding down the windows key and then tapping either the left or right arrow key a couple of times.

-A


#6

I’m having the same problem as the OP and none of the suggested fixes work. IronPython is checked on the loaded plugins and holding the windows key and the arrows doesn’t bring up the editor.


(Pascal Golay) #7

Hi Filipe - I can’t tell if you have run the EditPythonScript command…?

-Pascal


#8

@pascal I have run _EditPythonScript on the command line and nothing happens. The windows key plus the arrows was just to make sure windows wasn’t sending the editor window away to a second screen.


(Steve Baer) #9

Try the following:

  • close Rhino
  • open file explorer and navigate to C:\Users{user}\AppData\Roaming\McNeel\Rhinoceros\5.0\Plug-ins
    • the easiest way to do this it to type %appdata% in file explorer and then navigate down to this specific directory
  • You should see a folder named “IronPython (814d908a-e25c-493d-97e9-ee3861957f49)”
  • rename this folder to something like “Backup of IronPython”
  • start Rhino and run EditPythonScript

Hopefully this will fix the issue. Rhino should automatically recreated this folder when it notices that it doesn’t exist.


#10

@stevebaer I did as you suggested. Rhino does create a new folder. But the editor window doesn’t come up.


(Steve Baer) #11

Did this ever work? I was hoping some cached values were messing things up, but it doesn’t sound like that is the case.


#12

And if I try to run any script I get this:

It has previously worked. But I haven’t used the python editor in at least a year.


(Steve Baer) #13

Did you ever install a separate copy of IronPython? That may be the problem


#14

I think I did. I don’t remember why, it might have been some plugin that required it. But I currenly have IronPython 2.7.5 installed as a separate program (on the control panel)


(Steve Baer) #15

Giulio’s post may help you with this


#16

Thanks for your help! I uninstalled IronPython, restarted Rhino and it solved the problem. I followed Piacentino suggestion and installed the 2.7.7 without the GAC thing and it still works fine.