RhinoInsideRevit refuses to work and shows outdated version

I’ve tried everything mentioned in the forum with no success.
-uninstalled rhino.inside from windows uninstaller
-cleared appdata folder of rhino.inside files
-cleared programdata folder of rhino.inside files
-even found a rogue rhino.inside folder in appdata Mcneel folder and deleted it
-cleared cache in chrome and redownloaded the latest build
-when installing, the admin permissions lists the version and it matches the version listed as the latest one (0.1.7747.22602)

However, when I open Revit, I can get Rhino to start, the rhino window opens, I can load files, but “Import” does nothing. Also, there is a orange circle on the first icon and when I hover, it lists an old version and tells me to update.

What am I missing, this is very frustrating! Thanks for the help


Can you send the sample files and definitions to me? I will test it.

Hi Scott,

It wasn’t a specific file that wasn’t working for me, all files weren’t working, no matter how complex or simple. I started a new Revit file and a new Rhino file, drew two simple boxes, and tried importing to Revit and nothing happens. No geometry shows up in Revit.

I can’t send you project files unfortunately, but is there anything else I can send to you that would be helpful?

Hi @rhinouser01

I fiexd it right now, it should be avilable if you select the Daily Builds channel.


Thank you so much, you guys are quick!

Do you mean breaking things?

I don’t know about that but you sure fixed it quick!

Another small issue I’m running into is getting a Revit error saying “name cannot include prohibited characters”. I’ve managed work around this by removing any dashes or underscores from the file name as well as anything else in the file (layer names, materials, object names). Since this is a bit labourious, any chance we could get a fix for this or at least let me know which characters are prohibited so we can avoid them in the future?


In Revit, try to renane a Family adding a : character it will show you the list of invalid ones I think.