RhinoInside Failed to convert ModelPath in to Uri

hi! to everybody, I have a “little” problem with a lot of different component in rhino inside. For me i’ts impossible to use some component that use the Query… like the component Query elements … evry times that I tryed to use came back to me this message: Failed to convert model path in to Uri
I can’t understand the reason, some person could you help me? I have the original license of last rhino and original license for Revit 2020.
I could see that for a new file there are not problems but with different files that came from other people yes. thaks a lot for your attention

1 Like

Hi Yoseph,
I am experiencing the same issue however it is only when I open one of my firm’s existing files. It seems like if I load the sample file or a default Architectural Template it works perfectly. If you find an answer please let me know!

Hi @parsonsmichael, thanks for your message, yes I could observe the same behavior… it’s neccesary to find the solution… keep in touch!

Hi @yoseph,

There were a problem with documents that come from a network share.
Could you please change to the Daily channel, there is a fix there for this.

1 Like

hi @kike, thanks for your reply. I tried to find the psot but without result. where I can find the solution?
thanks for your attention

Sorry, here.

This should notify you about a new experimental build that include this fix.

thank @kike, I have al ready activate this opsion infact I have the last version… but ti’doesn’t works,
any idea?
thanks a lot for your attention

Could you please share a screenshot of the about dialog?

my first message have the result and the message that came from the component “Failed to convert Model Path in to Uri” (the problem is with more differente componet evry typology of query present to me this message

Sure, I just nee to know the exact version you have installed in order to reproduce it here.


The one you have installed is from 4 days ago, the fix is there since today.

You will need to mark the ‘Check Updates on Startup’ to make RiR notify about a new update.

it’s strange, no messages of new relase came to me from the pannel…

thanks a lot for your kindly attention, I am going to check immidiatly (here the version that i could to unistall and install again)

Thanks, I appreciate you confirm me if it’s fixed.
We should promote this fix to the public stable channel as well.

hi @kike, no good news… same error after the installation of your file
I have th same problem

Have you uninstalled the previous version before installing?
Could you check the version in the about box now.

yes, i have unistalled my version that was 0.7.7819.23894 and after I have installed your version that is more older than my version. the number of your version is 0.6.7814…

version of my rhino is:
Versione 7 SR6 (7.6.21127.19001, 2021-05-07)

Rhino WIP: Work In Progress (8.0.21138.12305, 2021-05-18)

Revit 2020 2.4

Where are your models located?

  1. Local drive (C:\Folder\File.rvt)
  2. Network share (\\COMPANY_SERVER\Shared Folder\File.rvt)
  3. Revit Server (RSN://COMPANY_SERVER/Folder/File.rvt)
  4. BIM 630 (BIM 360://Folder/File.rvt)