RhinoCore.dll could not be loaded

image

I have this error when I tried to open rhino8 after i installed.

Does someone have simmilar problem with me?

P.S. I used to use rhino 7 and I had no problem with it

1 Like

Hi -

Have you tried rebooting the machine?
If that doesn’t do the trick, please try a “Repair” of Rhino 8 from the Windows Control Panel.
-wim

Hi!
I had my computer reboot several times

For the ‘reapair’, are you talking about this one?

Repair apps and programs in Windows - Microsoft Support

I tried to reinstall but it aslso does not work.

I am having the same problem as well.
and also tried “Repair” but still the same problem appears.

Have yours been fixed?

Hi -
Can you please verify that all updates for Windows are installed?
Also, does Rhino start in Safe Mode?
-wim

Hi Wim,
Yes. Windows are all updated


Also, I have tried Rhino start in Safe Mode but the same problem appears.
image

Hi,

I got the same issue on one of my workstations. Some WIP versions worked, than in some WIP version this issue occured, now that the official release is here, I still got the “RhinoCore.dll could not be loaded” error. Repair, reboot and save mode also did not help.

I tried installing the newest Rhino Release, I am still getting that error. The installation process is suspiciously fast, but does not throw any errors. @snoopyjeon @_정민섭 @wim Were you able to solve this issue?

The issue resolved itself after I installed another software (Bentley Plaxis2D).

I show up, too. RhinoCore.dll could not be loaded. Is there a way around this?

I am also experiencing this issue with the new Rhino 8 installer. With any/all versions of windows 10 or windows 11. The dll is not getting registered at install time instead it requires admin rights at first launch. Please fix thank you.

this issue appears to be fixed after importing this cert

McNeel incorporate this step into a new installer in the near future please and thank you.

@brian - Can you have a look at this?

We have this issue on our list as RH-79832 RhinoCore.dll could not be loaded
-wim

Well, that’s an interesting one. The theory of digital signatures is that the software itself is not supposed to install the trusted root. It bypasses the trust chain. What version of Windows are you running? Is it fully up-to-date? I don’t understand why the root certificate isn’t already on your computer.

Where can I download the evaluation of version 8.5?

Hi -

The first public release of an 8.5 build should become available as a service release candidate on February 13th.
–wim

We are an enterprise environment our QA lab has everything from Windows 11/10 current semiannual release and then versions going back to 2 years ago. This issue didnt seem to care about Windows build version in our testing. It does the same thing for me on 1909 as 2308.

Can you please install the SSL.com root certificate bundle from Install SSL.com CA Root Certificates - SSL.com and see if that helps?