Rhinoceros 2.0 question - crashes and then gives error message

Okay, I know it’s old, but I use Rhinoceros 2.0. Been using it since 2000. Until I got this new computer, I haven’t had a problem with it. I’ve used it on Windows 10 with no problem. AND it works fine on this computer. HOWEVER, on occasion, when I save a large file, it sits and spins until I finally have to close it (I’ve waited over night once to be sure it wasn’t going to stop on its own). When I shut Rhinoceros down and restart it I get this message:

Unable to locate required system plug-in file <LayerDialog_vc60u.rhp>

Rhino can not run

Uninstalling and reinstalling typically works, but this time nothing seems to work.

Again, I know it’s old, but I haven’t had a problem before. Any idea what the problem is and how to fix it or at least a good way to repair it when this happens?


Note: I managed to get it to work again by uninstalling Rhinoceros, Flamingo and the Rhino/Flamingo update. I suspect the file that keeps getting corrupt is a Flamingo file. I just don’t understand why I never had this problem before and now have it on a regular basis. I know this is an old program and there may not be a fix. Thanks for taking the time to read my problem.

It’s just too old. I have no idea how it would even install, let alone mostly run. The Windows version, the video drivers, it’s all just way too different, whatever compatibility still exists wasn’t intended for anything as elaborate as Rhino.

Hi @steven1
My guess is that a win10 update broke something - they change things with every update, and I’m pretty sure they don’t do compatibility checks on software that’s 20 years old (Happy 20th anniversary, Rhino 2.0!!! :grinning:).
Just out of professional curiosity: What’s the reason that you are still on Rhino 2?

1 Like

I’ve used Rhino 2.0 without problems all these years. I use it along with a sculpting program, a program that converts between obj and stl, and a program for slicing. I’m still not nearly as skilled as I’d like, so I stick with what I know. Plus, when this issue began, I test drove Rhino 7. Not really that much different other than a bit shinier and a few bells and whistles. Also, I can’t really afford to spend $1000 on a program I use on my hobby. If you’re curious, I have a few samples of my 3D work on my site. Just scroll down a bit. www.grimtrojan.com Thanks for your input. You pretty much said what I was thinking.


Rhino 2.0? God bless you.

It’s amazing that you were able to use it up until now. It was even hard to google search some screenshots of Rhino 2.0, I only found this, just for everbody else’s reference:

Sorry I don’t have any ideas how to make it keep running…


Cool sculpts, @steven1!
Depending on where Rhino fits in your workflow, it might be possible to explore if one of the free alternatives out there could work for you - I’m thinking Blender, FreeCAD or similar.
HTH, Jakob

1 Like

With all due respect, that statement could not be more wrong. I’ve been working with Rhino since version 1.1 so I’ve seen the evolution. I understand that it’s tough to spend $1000 for your hobby, and that’s a valid reason not to update. But to say V2 and V7 are not that much different is not an accurate statement at all.

1 Like

Hi @steven1,

Have you tried running Rhino in Windows 7 compatibility mode? Might avoid whatever W10 change has broken things.

(Find the Rhino exe in Explorer, right click on it and select Properties. There’s a Compatibility tab in the panel that pops up. Tick the Run in compatibility mode box and choose Windows 7 from the dropdown.)


Another way is using the virtualized OS.

1 Like

Thanks. I’ll give it a try. That sounds like a likely fix.

I just had exactly the same problem with Rhino 2.0 under Windows 10 → it had been working but then it didn’t. I tried Windows 7 compatibility mode but no luck. However, OK using Windows XP, service pack 3 compatibility mode. (Interestingly, I also have a Windows 7 computer with Rhino 2.0 and it runs fine there.)

Don C.

Note you would get the upgrade price.


Imho, as suggested by Nosorozec, a “safe” way to use old software is to make a virtual machine with old SO (win 7.0 or XP) and run there Rhino 2.0.
This would protect you from new updates that could break old software.

Thanks a lot for this idea, Jeremy!
I tried setting compatibility mode to “Windows 7”, which did not fix it. Then I had better luck with “Windows XP, Service Pack 2”, which made Rhino 2 run again stably since some days now.

I am running Rhino 6 on WIndows 10 and have Rhino 2 running on the same machine since it has a very reliable version of the applyMesh command (running on AGLib) that I need from time to time and which fails in Rhino 6 in some cases.

1 Like

Hi. Sorry, but I’d actually forgotten about this string until someone emailed me to ask if I’d had a solution to my problem. The answer is, yes, sort of.

The problem fixed itself. I suspect it was in one of the updates on the computer. I had to keep Flamingo uninstalled for Rhino to work, but later I installed it again and everything was okay. SO, again, I suspect there was just something about the Windows update at that time that my version of Rhino didn’t like. I guess the real problem was with the plug-in and not Rhino itself.

Thanks for all the input on this string. Given how old my version is, I didn’t really expect much help, just a lot of people making fun of me for having such an old version. Instead, you all gave some really good suggestions. Thanks.

And for the record, Rhinoceros is by far the best program that I’ve found for creating the cad-like items I need. There’s plenty out there to use instead of Rhino, but nothing as easy to work with and still do everything I need it to.