Help! Rhino bogged down

The last day I have been having trouble with Rhino. It keeps crashing, doesn’t want to save files. I get the blue spinning wheel when I do anything. I have even opened blank files, draw a line, and attempted to save and it takes forever. My file sizes are also much larger than usual, but I don’t know what is bloating them.

I have updated Rhino and my graphics card. Restarted the program and my computer numerous times. Cleared more space on my hard-drive. Deleted a few plug-ins that I know I downloaded but don’t commonly use.

There are quite a few plug-ins in my Program Files folder that I’m not sure what they are. I don’t know if they came with Rhino or other plug-ins and I am not sure what I can delete.

Here is my SystemInfo if that helps at all:

Rhino 6 SR34 2021-2-3 (Rhino 6, 6.34.21034.07001, Git hash:master @ 2fec8130f097ca52a8bc9f334c3ed4a5921c5e30)
License type: Educational, build 2021-02-03
License details: Cloud Zoo. In use by: Alyssa Bullock ()

Windows 10.0.0 SR0.0 or greater (Physical RAM: 16Gb)
Machine name: DESKTOP-I6KNPL7

Computer platform: DESKTOP

Standard graphics configuration.
Primary display and OpenGL: NVIDIA GeForce GTX 1050 Ti (NVidia) Memory: 4GB, Driver date: 1-22-2021 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 461.40
> Accelerated graphics device with 4 adapter port(s)
- Windows Main Display attached to adapter port #0
- Secondary monitor attached to adapter port #1

Secondary graphics devices.
Intel® UHD Graphics 630 (Intel) Memory: 1GB, Driver date: 9-25-2019 (M-D-Y).
> Integrated graphics device with 3 adapter port(s)
- There are no monitors attached to this device!

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 1-22-2021
Driver Version: 27.21.14.6140
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 4 GB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.34.21034.7001
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\AnimationTools.rhp “AnimationTools”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.34.21034.7001
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.34.21034.7001
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.34.21034.7001
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Chaos Group\V-Ray\V-Ray for Rhinoceros\V6\VRayForRhino.rhp “V-Ray for Rhino”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”

Hello - please disable VRay in Options > PlugIins page and then close and restart Rhino - does it behave any better?

-Pascal

I disabled it but it still seems to be having issues. The current file I am working in is just surfaces and curves, nothing complex at all. Yet its 800MB! I have tried purging the file, deleted every unnecessary object, brought the objects I want into a new file… but I can’t figure out what is making it so massive.

Even some of my other files that are much smaller seem to be larger than usual. I feel like something got downloaded that is bogging it down. It only started happening yesterday though and I haven’t recently installed any new plugins.

Hello - it is possible there is a ton of VRay user data, or possibly block definitions - run Audit3dmFile and see if you can make anything of that - or post the results here. You can a also SaveAs and disable saving plug-in data in the save dilaog - if it is a lot smaller that would certainly point to user data.

-Pascal

Wow, when I SaveAs and disable plug-in data the file shrunk to 4MB! Over 800MB of plug-in information. Thank you so much. The audit really helps.