RhinoCAM2018 Initialization error: units not supported!

When I try to load RhinoCAM for Rhino 6 it gives me the error: Units not supported! The plug-in will exit now. Please switch to inches/millimeter units before loading plug-in.

This error still occurs when opening Rhino in millimeters or inches. Uninstalling and reinstalling RhinoCAM and Rhino has not solved the issue. I’ve tried using a RhinoCAM 2019 demo and a purchased RhinoCAM2018 license which resulted in the same error.

Any help would be appreciated,


Hello - please check with RhinoCAM tech support first. If they think it is a Rhino problem, they’ll get in touch.


I remembered the easy way to get my RhinoCAM 2019 working in Rhino 6:

  1. Start Rhino and click thru RhinoCAM error message.
  2. Go to File - > New and select a Millimeters or Inches template and then at the bottom select: Use this file when Rhino starts, and click Open. Now the RhinoCAM plug-in should start working.

This is also what MecSoft recommends.


1 Like

Hello RJ,

As your default units template is not set to inches or millimeters at start up, RhinoCAM unloads the plug-in.

Please follow the steps below to set the default units template.

  1. Open Rhino 6.0
  2. Select File->New from the menu bar in Rhino.
  3. Select a template (Millimeters or Inches)
  4. Make sure to select Use this file when Rhino starts (located at the bottom of the open template file dialog).
  5. Click Open.

Hope this helps!

Quelly del Mundo
MecSoft Corporation

Hi Terry,

I’ve tried doing this by opening a new template in inches and checking the box to use when Rhino opens. However, when I open rhino it still opens the template options, with it already selecting centimeters but I do have the option at this point to click inches. When it launches, even in an inches template, it still gives me the same error of “Units not supported”.

Thanks for the response,


When you see the template choice window, there is a checkbox in the lower left corner to “Use this file when Rhino starts”… If you check that when selecting the inches template, it will always start in inches.

This I don’t understand though, never seen this happen with RhinoCAM…

Hi Helevetosaur,

Sorry, I meant to say I tried what you suggested with checking the “Use this file when Rhino starts” box and opening a new file in inches, but when I relaunch Rhino it still opens the template choices with centimeters in bold.

Hmm, what happens if you go to Options>Files and try to set your template from there?

So I tried what you suggested, and set it in options and even tried deleting the one it keeps going back to (Small objects - centimeters) but it still goes back to this centimeter template after closing and opening Rhino.

Try saving to a named .3dm file after setting to inches and checking box and then restarting Rhino and selecting this file. Does Rhino come up in inches and RhinoCAM work?

1 Like

Oh my goodness, I don’t know why I didn’t think of that. It actually worked!

Thank you Terry and everyone else who helped.