Duel units issue in Rhino 6


I work in the UK film industry which uses Rhino as one of the standard modelling softwares and also has a tradition of using different units between the different departments. I personally prefer to model in mm, so the drawings I issue use have duel units mm to the nearest mm and imperial to 1/16" to 1/4" depending on the requirements. The issue that I’m having is that because the main units (mm) are rounded up to the nearest integer, the inches aren’t triggering until around 31mm. So my dims read 25mm [0’-0"]. This is obviously wrong and very time consuming checking and manually adjusting many times. I guess this is a bug that need fixing? Is this on the cards?

Many thanks,

Try setting your alternate units roundoff to the nearest 1/16" or 1/32" so they are closer to your mm unit.

That’s what I do have set. It appears that the round off on the mm affects the “Starting” inch round off. It all works perfectly above 32mm but fails below that.

Maybe you found a bug.

Are your primary units mm and alternate units inches?
Can you send a screenshot of the settings on your Annotation Style > [name] > Length units page so I can duplicate your setup please?

Also what are the file Units and tolerance setting?

I’ll do that tomorrow morning, thanks

Oh and yes primary mm , secondary inches (feet and inches)

With your description, I was able to make a sample file that illustrates the problem.
It has been reported as:

I see this as well. As a work around, you can set your primary units to a lower linear resolution (say 0.001), then set your round off to 1, and set your zero suppression to suppress trailing zeros. With those setting, the primary units will read as 25, alternate units set to Feet - feet & inches will show as [15/16"]


Yep, got the work around working and saved as a style. Cheers

Thankyou :grinning: