Rhino8 print and scaled cotation

i 've got a problem… when i print this:
capture from the printerwindow
image
i’ve got this:
capture from my pdfviewer

an idea?

with rhino 7, the same file print this:
capture from my pdfviewer

1 Like

As in your other post, please provide the SystemInfo data.
-wim

1 Like

et voilà:
Rhino 8 SR4 2024-2-13 (Rhino 8, 8.4.24044.15001, Git hash:master @ 5d3f86ffffae3c2ed84d21147c008b3907a40a2e)
License type: Commerciale, version 2024-02-13
License details: Cloud Zoo

Windows 10 (10.0.19045 SR0.0) or greater (Physical RAM: 32GB)
.NET 7.0.16

Computer platform: DESKTOP

Standard graphics configuration.
Primary display and OpenGL: NVIDIA Quadro P2200 (NVidia) Memory: 5GB, Driver date: 12-29-2021 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 511.09
> Accelerated graphics device with 4 adapter port(s)
- Secondary monitor attached to adapter port #0
- Windows Main Display attached to adapter port #1

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 12-29-2021
Driver Version: 30.0.15.1109
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 5 GB

Rhino plugins that do not ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Karamba\License\Karamba3D_LicensePlugin_Rhino7.rhp “Karamba3DLicense”
C:\Program Files\ADA 3D\Mesh2Surface for Rhino 6\m2s_for_Rhino.rhp “MESH2SURFACE”

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 8\Plug-ins\Commands.rhp “Commands” 8.4.24044.15001
C:\Program Files\Rhino 8\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 8\Plug-ins\AnimationTools.rhp “AnimationTools”
C:\Program Files\Rhino 8\Plug-ins\RhinoRenderCycles.rhp “Rendu de Rhino” 8.4.24044.15001
C:\Program Files\Rhino 8\Plug-ins\RhinoRender.rhp “Ancien rendu de Rhino”
C:\Program Files\Rhino 8\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 8.4.24044.15001
C:\Program Files\Rhino 8\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 8\Plug-ins\MeshCommands.rhp “MeshCommands” 8.4.24044.15001
C:\Program Files\Rhino 8\Plug-ins\IronPython\RhinoDLR_Python.rhp “IronPython” 8.4.24044.15001
C:\Program Files\Rhino 8\Plug-ins\RhinoCycles.rhp “RhinoCycles” 8.4.24044.15001
C:\Program Files\Rhino 8\Plug-ins\RhinoCode\RhinoCodePlugin.rhp “RhinoCodePlugin” 8.4.24044.15001
C:\Program Files\Rhino 8\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 8.4.24044.15001
C:\Program Files\Rhino 8\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 8\Plug-ins\Displacement.rhp “Displacement”
C:\Program Files\Rhino 8\Plug-ins\SectionTools.rhp “SectionTools”

Hi hopefully this is related 7 to 8 issue, with annotation styles and PDF prints.

Can’t seem to scale the annotation to print as seen view without shrinking the text to nothing.

having to open in 7 to print :roll_eyes:

1 Like

Rhino 8 SR4 2024-2-13 (Rhino 8, 8.4.24044.15001, Git hash:master @ 5d3f86ffffae3c2ed84d21147c008b3907a40a2e)
License type: Commercial, build 2024-02-13
License details: Cloud Zoo

Windows 11 (10.0.22621 SR0.0) or greater (Physical RAM: 32GB)
.NET 7.0.0

Computer platform: DESKTOP

Standard graphics configuration.
Primary display and OpenGL: NVIDIA RTX A2000 (NVidia) Memory: 6GB, Driver date: 8-14-2023 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 537.13
> Accelerated graphics device with 4 adapter port(s)
- Windows Main Display attached to adapter port #0

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 8-14-2023
Driver Version: 31.0.15.3713
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 6138 MB

Rhino plugins that do not ship with Rhino
C:\Program Files\Rhino 8\Plug-ins\RhinoCAM 2023 for R8\RhinoCAM 2023 For Rhino8.0.rhp “RhinoCAM 2023 - The cutting edge CAM plug-in for Rhino 8.0 from MecSoft Corporation”
C:\Program Files\Rhino 8\Plug-ins\RhinoCAM 2023 for R8\RhinoArt1FileExporter For Rhino8.0.rhp “RhinoArt1FileExporter”

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 8\Plug-ins\Commands.rhp “Commands” 8.4.24044.15001
C:\Program Files\Rhino 8\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 8\Plug-ins\AnimationTools.rhp “AnimationTools”
C:\Program Files\Rhino 8\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 8.4.24044.15001
C:\Program Files\Rhino 8\Plug-ins\RhinoRender.rhp “Legacy Rhino Render”
C:\Program Files\Rhino 8\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 8.4.24044.15001
C:\Program Files\Rhino 8\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 8\Plug-ins\MeshCommands.rhp “MeshCommands” 8.4.24044.15001
C:\Program Files\Rhino 8\Plug-ins\RhinoCycles.rhp “RhinoCycles” 8.4.24044.15001
C:\Program Files\Rhino 8\Plug-ins\RhinoCode\RhinoCodePlugin.rhp “RhinoCodePlugin” 8.4.24044.15001
C:\Program Files\Rhino 8\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 8.4.24044.15001
C:\Program Files\Rhino 8\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 8\Plug-ins\Displacement.rhp “Displacement”
C:\Program Files\Rhino 8\Plug-ins\SectionTools.rhp “SectionTools”

Hi -

I can’t debug that issue from images. Please post a 3dm file with an annotation that has scaling issues.
-wim

2 Likes

Mary Ann Fugier has solved it on another thread!

1 Like

I Update my Rhino8, and no change…, i add my system info on the layer, and whith this, the outprint is different… sometimes, scalling is so little, we cannot see the text, so I doubleclick in view, make a extendzoom, and it be better…
TEST rhino8 scalling.3dm (300.4 KB)

Get down the list of this beasty thread and you’ll see there are some screen grabs from Ann, two little check boxes before the annotation styles options, give’em a toggle and “what you see what you get printing enabled”

“enable model space spacing” and “enable layout space scaling”

I’ve been using these scaling options for quite some time now on version 7, and today on version 8, with the same settings, it’s not working… I can read English, speak it a little, but the shared thread isn’t the easiest English to understand, and even with translation tools… it’s not great.

No problem!

Play with these settings

1 Like

This setting affects the layout space, and on the layout, everything is fine; even the preview in the print window looks good. However, when I click on print, the window closes, a new window opens with a miniature preview of the print, and there, we see that there is a problem, and the result on the PDF is not good.

I made a lot of test, i tried to take a video, and now, the cotation text desappear…


Hi @onlyforpeace,
I am using the internal build, so you may need to wait and test with the sr6 Release Candidate that will be released on March 12 if you are experiencing something different.
You can set your Updates to Service release so that you can at least run Rhino 8 sr5 release candidate.

Your file behaved like I expected.
Layout scaling is on to even with dimension in the perspective with is variable scale, and the paralell viewport at fixed scale, and 1:1; dimension on the layout - they all display the uniform size.


Here is your file that I worked on and printed to PDF.
TEST rhino8 scalling2.3dm (356.0 KB)
TEST rhino8 scalling2.pdf (422.6 KB)

Should I test something else?
Thanks,
Mary Ann Fugier

i’ll try on the march 12…
with the new release…
but what do you think about the video…

Hello

I’m new in Rhino (8 months)
I came from Sketchup, and before for autocad.

I am trying hard to understand how to set dimension (annotations) scales to the same size in Model view and Layout display what ever the Display scale is.

Enable model space scaling & Enable layout space scaling do NOT work as I expect.
My annotation are far to big !

What’s the regular workflow to follow ?

Please help
My annotation are in model space.
I need to print the same plan layout display in three different scales, keeping annotation sizes the same.

Thanks