Rhino PDF Print

Hello, I have an issue with exporting Rhino PDF from Top view, when I click print which would pop up the window where I want to save the file as usually as it works. But now it seems something is wrong and I do not have any pop up when clicking on print button. Nothing happens. Anyone have dealt with same issue?

Hi Zhaidarbek, Lets start troubleshooting by running SystemInfo in your Rhino command line.

https://discourse.mcneel.com/t/please-read-this-if-you-are-logging-a-bug-or-issue/173971/3

Rhino 7 SR36 2023-12-12 (Rhino 7, 7.36.23346.16351, Git hash:master @ 11a364321297eb8cdb34405a3308d8911f58706d)
License type: Educational Lab License, build 2023-12-12
License details: Cloud Zoo

Windows 11 (10.0.22631 SR0.0) or greater (Physical RAM: 64Gb)

Computer platform: DESKTOP

Standard graphics configuration.
Primary display and OpenGL: NVIDIA GeForce RTX 3060 (NVidia) Memory: 12GB, Driver date: 10-4-2023 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 537.58
> Accelerated graphics device with 4 adapter port(s)
- Windows Main Display attached to adapter port #0
- Secondary monitor attached to adapter port #1

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 10-4-2023
Driver Version: 31.0.15.3758
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 12 GB

Rhino plugins that do not ship with Rhino
C:\ProgramData\McNeel\Rhinoceros\7.0\Plug-ins\Datasmith Rhino Exporter (d1fdc795-b334-4933-b680-088119cdc6bb)\DatasmithRhino7.rhp “Datasmith Exporter” 5.3.2.0
C:\Program Files\Doliwa Workshop\Rhino Nature\Rhino Nature.rhp “Rhino Nature” 1.0.3.33161
C:\Program Files\Chaos Group\V-Ray\V-Ray for Rhinoceros\V7\VRayForRhino.rhp “V-Ray for Rhino”

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.36.23346.16351
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RPC.rhp “RPC”
C:\Program Files\Rhino 7\Plug-ins\AnimationTools.rhp “AnimationTools”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.36.23346.16351
C:\Program Files\Rhino 7\Plug-ins\RhinoRender.rhp “Legacy Rhino Render”
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.36.23346.16351
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.36.23346.16351
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.36.23346.16351
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”

The next for troubleshooting is to disable 3rd party plugins and try again. You can do this in File>Properties>Plugins (sort by 3rd party) then uncheck and restart Rhino.

It says “Failed to create instance of VBScript scripting engine.”

After I click Ok to that window it freezes the whole file…

At what point in the process is this happening?

When I click File > Properties then the Failed window pops up

I have no Idea what is wrong, just yesterday everything was completely ok without trouble

Lets do a repair install.

Go to Window>Add & Remove Program Select Rhino 7 and modify the install> Repair

Oh gosh I wanted to avoid that but if there is no other way then it is what it is. Does the repair install removes settings and plugins?

Was there anything new installed (plugins, windows updates, anything…) since yesterday?

Repair will remove custom settings, the plugins will remain.

https://wiki.mcneel.com/rhino/settingstransfer

Yes there was a windows update. Ok thanks I will try repair install. Will let you know if it worked.

Repair install did not worked. Cannot print export Rhino PDF and also same issue with the File Properties

If you open Rhino in Safe mode (Type Rhino 7 in Safe mode in the Windows start) can you access the properties and disable plugins?

Safe mode disables plugins and video drivers, you will need to agree to some of the default ones to get the properties up.

Ok I found a solution. I just copied everything that I had in this file into new file and everything works. No idea how but I am not complaining. Thank you very much for your time Japhy.

1 Like