Rhino8 display+3dconnexion bug

Rhino8 Windows,
experiencing a bug while oribiting in viewports with a 3d connexion mouse. While orbiting is ongoing all is good, but when it stops, the display jumps to a previous frame that was displayed in the orbiting process and stops there. Basically the viewpoint changes again after there is no 3d connexion input, back to a random frame that was displayed previously.

Rhino 8 SR0 2023-10-31 (Rhino 8, 8.0.23304.09001, Git hash:master @ 20e15cf9bd66e6676f849f22e485cb3e82a8beac)
License type: Educational Lab License, build 2023-10-31
License details: Cloud Zoo

Windows 10 (10.0.19045 SR0.0) or greater (Physical RAM: 64Gb)
.NET 7.0.0

Computer platform: DESKTOP

Standard graphics configuration.
Primary display and OpenGL: NVIDIA GeForce RTX 2080 SUPER (NVidia) Memory: 8GB, Driver date: 6-8-2023 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 536.23
> Accelerated graphics device with 4 adapter port(s)
- Windows Main Display attached to adapter port 0
- Secondary monitor attached to adapter port 1

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 6-8-2023
Driver Version: 31.0.15.3623
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 8 GB

Rhino plugins that do not ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\RhinoCAM 2021 for R7\RhinoArt1FileExporter For Rhino7.0.rhp “RhinoArt1FileExporter”
C:\Users\isvoranu\AppData\Local\Apps\Evolute\EvoluteTools PRO Panelisation for Rhino 6\EvoluteCoutHook.rhp “EvoluteCoutHook”

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 8\Plug-ins\Commands.rhp “Commands” 8.0.23304.9001
C:\Program Files\Rhino 8\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 8\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 8.0.23304.9001
C:\Program Files\Rhino 8\Plug-ins\RhinoRender.rhp “Legacy Rhino Render”
C:\Program Files\Rhino 8\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 8.0.23304.9001
C:\Program Files\Rhino 8\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 8\Plug-ins\MeshCommands.rhp “MeshCommands” 8.0.23304.9001
C:\Program Files\Rhino 8\Plug-ins\RhinoCycles.rhp “RhinoCycles” 8.0.23304.9001
C:\Program Files\Rhino 8\Plug-ins\RhinoCode\RhinoCodePlugin.rhp “RhinoCodePlugin” 8.0.23304.9001
C:\Program Files\Rhino 8\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 8.0.23304.9001
C:\Program Files\Rhino 8\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 8\Plug-ins\Displacement.rhp “Displacement”
C:\Program Files\Rhino 8\Plug-ins\SectionTools.rhp “SectionTools”

Two things that are usually suggested for issues like this:
Nvidia driver is 6 months old: update it and test.
Disable all plugins that don’t ship with Rhino and test again.
If disabling plugins fixes it, install one at a time and test to determine which one causes the problem.

From other discussions on 3dconnexion in R8: if you have the properties panel open, try with it closed. Let us know whether that helps (that would provide a clue to what the root cause is).

Regards
Jeremy

Jeremy,
I don’t know what you mean by the “properties panel open”. There is no panel, open on my desktop, but there is a bunch of software that I see running in task manager. Without those processes running, the 3d mouse won’t work. I will update the nvidia driver and report back, but won’t have the time to remove/install plugins.

Hi Florin,

In Rhino:

Regards
Jeremy

Hihihi, this is funny, I thought you meant the 3d connexion panel :slight_smile:
I updated the nvidia driver, and it seems the cuprit is the object properties panel. Having it open, docked or undocked, causes the frame jump. Keeping another panel open, like layers, seems to eliminate the problem. Although it doesn’t happen immediately so maybe other panels are also making the 3d mouse orbiting display misbehaving ?

Just a guess but it may be influenced by whether the properties panel is displaying object properties or viewport properties. As you move about the view its positional data is constantly changing and that has to be updated in viewport properties.

Had no object selected so, viewport properties.

Hi @VIZIBLE,
Thanks for your help with this issue, @jeremy5.

I have logged: RH-79226/Viewpoint-display-changes-again-after-there-is-no-3d-connexion-input

There are few 3d connexion devices in house.
Hopefully with your description, someone will be able to reproduce it.

Just curious, wondering if you tested this issue with your Plugins disabled.
If you have a chance and can disable these plugin and see if the issue still happens?
you can do that from Options → Plugins and filter on “Plugins that do not ship with Rhino”.
Uncheck these, close and reopen Rhino.

  • C:\Program Files\Rhino 7\Plug-ins\RhinoCAM 2021 for R7\RhinoArt1FileExporter For Rhino7.0.rhp “RhinoArt1FileExporter”
  • C:\Users\isvoranu\AppData\Local\Apps\Evolute\EvoluteTools PRO Panelisation for Rhino 6\EvoluteCoutHook.rhp “EvoluteCoutHook”

Sincerely,
Mary Ann Fugier

Hi Mary,

I think this is another instance of the issue reported here: 3DConnexion Spacemouse jumpy in Rhino 8 WIP.

That is one of several threads now referenced from: Viewport jump when using a 3D Connexion device in Rhino 8 : RH-78291 (myjetbrains.com).

Regards
Jeremy

Checking what century it is, yep it’s the 21st century :coffee: :relieved:

These problems might someday be solved when they can say ‘more than a few’ in house.

Their usage is a rounding error, and always will be, it doesn’t matter how cool they are.

1 Like

lol, 6 degrees of freedom has nothing to do with rounding errors or coolness.

Even with Rhino’s broken 6-degree navigation, a user that doesn’t get dizzy using one … well is a butterfly cooler than a caterpillar :thinking: maybe… :coffee:

Maybe if Rhino’s 3D navigation algos were better than rounding errors :sweat_smile:

@lander - Keep in mind that support for 3Dconnexion devices in Rhino is developed by 3Dconnexion, not McNeel. The 3dxRhino plug-in, which controls 3Dconnexion devices, is distributed with Rhino on their behalf.

That said, we are looking into reported issues to make sure we’ve not broken something.

– Dale

1 Like

Yeah mm k but, the legacy Rhino support characteristics still have residue and redundancies.

Sure if Rhino want’s to make it logitec’s problem then that’s one thing… But there’s still conflict from the pre R6 days of Rhino drivers for said matter.

Although, it would probably be better if there were more collaboration between logitec and Rhino on the matter.

And the future should be more 3D mouse compatible. Unless we all want to continue living in the stoneages.

There’s no reason why the world couldn’t have more 3D mouse brands by now and more plug n’ play compatibility.

But the human race is still relying on what like 2 or 3 brands for 6 axes navigation devices :joy: – there should be 10 or more. :sob: it’s sad really. Maybe in 20 more yrs…

Thanks again, @jeremy5
Sure appreciate the additional links. They have been added to the thread.

1 Like

Hi Mary Ann,
I can confirm issue persists with no 3rd party plugins loaded.

I am having the same problem with 3D connexion. There seem to occur when the object properties panel is open as mentioned before, not all the time but often enough.

Rhino 8 SR3 2024-1-9 (Rhino 8, 8.3.24009.15001, Git hash:master @ 3541fa287a013b0f17849f0740f1e43a44031bfc)
License type: Commercial, build 2024-01-09
License details: Cloud Zoo

Windows 11 (10.0.22000 SR0.0) or greater (Physical RAM: 64Gb)
.NET 7.0.14

Computer platform: LAPTOP - Plugged in [100% battery remaining]

Non-hybrid graphics configuration.
Primary display and OpenGL: NVIDIA RTX A4500 Laptop GPU (NVidia) Memory: 16GB, Driver date: 12-1-2023 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 537.99
> Integrated accelerated graphics device with 4 adapter port(s)
- Secondary monitor is laptop’s integrated screen or built-in port
- Windows Main Display attached to adapter port #1
- Secondary monitor attached to adapter port #2
Primary OpenGL: NVIDIA RTX A4500 Laptop GPU (NVidia) Memory: 16GB, Driver date: 12-1-2023 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 537.99
> Integrated accelerated graphics device with 4 adapter port(s)
- Secondary monitor is laptop’s integrated screen or built-in port
- Windows Main Display attached to adapter port #1
- Secondary monitor attached to adapter port #2

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 12-1-2023
Driver Version: 31.0.15.3799
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 16 GB

Rhino plugins that do not ship with Rhino
C:\Program Files\Chaos Group\V-Ray\V-Ray for Rhinoceros\V7\VRayForRhino.rhp “V-Ray for Rhino”

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 8\Plug-ins\Commands.rhp “Commands” 8.3.24009.15001
C:\Program Files\Rhino 8\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 8\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 8.3.24009.15001
C:\Program Files\Rhino 8\Plug-ins\RhinoRender.rhp “Legacy Rhino Render”
C:\Program Files\Rhino 8\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 8.3.24009.15001
C:\Program Files\Rhino 8\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 8\Plug-ins\MeshCommands.rhp “MeshCommands” 8.3.24009.15001
C:\Program Files\Rhino 8\Plug-ins\RhinoCycles.rhp “RhinoCycles” 8.3.24009.15001
C:\Program Files\Rhino 8\Plug-ins\RhinoCode\RhinoCodePlugin.rhp “RhinoCodePlugin” 8.3.24009.15001
C:\Program Files\Rhino 8\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 8.3.24009.15001
C:\Program Files\Rhino 8\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 8\Plug-ins\Displacement.rhp “Displacement”
C:\Program Files\Rhino 8\Plug-ins\SectionTools.rhp “SectionTools”