3d mouse is no longer smooth since last update


#1

Hi I am using a 3dConnexion 3d Mouse with the latest beta version of Rhino for Mac. Since the last update I am unable to smoothly move around with the 3d mouse, the views are slightly laggy and jittery. Up to now rhino has worked really well with my space navigator and it is usable but far less easy to use. Anyone else have this problem?. I have tested and calibrated the mouse and its working fine.


#2

Hi. It would be very useful to be able to see a short video while moving an object with the mouse 3d and then with a normal mouse … I am planning to buy a short 3Dconnexion mouse. Thank you.


(Marlin Prowell) #3

I cannot duplicate this. When I rotate a model on my mid 2012 MacBook Pro with a 3DConnexion mouse, the screen redraws at about 40 fps.

You didn’t mention anything about your environment. Please see this post which will tell you how to tell us your hardware and software environment.

Also, there have been a lot of releases recently, so latest version and previous version are pretty ambiguous. What was the version number (YYYY-MM-DD) that worked for you? What is the version number that now is not working?


#4

Hi thanks so much for your prompt reply :^)
I have here my open gl settingsSoftware information

Software versions
Rhinoceros version: 5.0 Wenatchee 2014-02-11 (502)
OS X version: Version 10.9.1 (Build 13B42)

Plug-ins
/Library/Frameworks/3DconnexionClient.framework/Versions/A/3DconnexionClient

Hardware information

Computer hardware
Hardware model: MacBookPro10,2
Processor: Intel Core i5-3210M CPU @ 2.50GHz
Memory: 8 GB
Architecture: Intel 64 bit

Video hardware
Graphics: Intel HD Graphics 4000 1024 MB
Memory: 1024 MB
Screen size: 1280 x 800
Displays: Color LCD

USB devices
Apple Inc.: Apple Internal Keyboard / Trackpad
Apple Inc.: Bluetooth USB Host Controller
Apple Inc.: FaceTime HD Camera (Built-in)

Bluetooth devices
None

OpenGL information

OpenGL software
OpenGL version: 2.1 INTEL-8.18.29
Render version: 2.1
Shading language: 1.20
Maximum texture size: 16384 x 16384
Z-buffer depth: 24 bits
Maximum viewport size: 16384 x 16384

Implementation settings
Use texture compression: No

Appearance settings
Antialiasing: 4x
Mip map filtering: None
Anisotropic filtering: None

It is still not working correctly however have just been advised there is a new build to download so will try that and report back.


(Marlin Prowell) #5

Nothing has changed for a long time that would affect drawing speed, which is what would affect the perceived responsiveness. Does this happen with even simple models (a couple of boxes) or only on more complex models? Does setting anti-aliasing to none in OpenGL preferences affect the perceived speed?


#6

I’m having the same issue with my 3DConnexion mouse. I upgraded to build 503 today. Earlier today in the previous build, moving objects was smooth. Immediately after upgrading I noticed the glitchiness. Long pauses before anything happens and then the geometry moves quickly - usually past where I wanted it since it was not dragging or rotating in real time. Everything on my system was exactly the same before and after updating.

This happens with even a simple circle when moving in perspective view.


#7

Michael you describe exactly( and better than I put it) what I am seeing. I’m not sure what to do now. it is still useable but once you have got used to a 3D mouse, to go back to drawing without it is no fun!
please help McNeel! what is going on?!
Cheers,
Simon :^)


#8

An update: I’ve observed that when this 3D mouse glitchiness occurs, if I click outside the window to another application or even another Rhino window, and then come back, the 3D mouse behaves normally again.


#9

Hi,

Just wanted to add that I have also had performance issue when using a 3D Connexion Space Navigator.

I am using R503 (2014-02-18) on OSX10.9.1 but noticed it first happen with the previous release. This is on a mid 09 15" 2.66GHz mac book pro with 8Gb RAM.

I’ve been manipulating a couple of models (one with 10 or so curves and one with many surfaces) (EDIT: Curves are obv. just wireframe and surface model is set to shaded, no textures) with the space navigator and watching the CPU load. With both models, the CPU load goes in to the 90’s and up to 100 immediately.

Here’s the OpenGL preferences page info…

Software information

Software versions
Rhinoceros version: 5.0 Wenatchee 2014-02-18 (503)
OS X version: Version 10.9.1 (Build 13B42)

Plug-ins
/Library/Frameworks/3DconnexionClient.framework/Versions/A/3DconnexionClient

Hardware information

Computer hardware
Hardware model: MacBookPro5,3
Processor: Intel Core2 Duo CPU P8800 @ 2.66GHz
Memory: 8 GB
Architecture: Intel 64 bit

Video hardware
Graphics: NVIDIA GeForce 9400M 256 MB
Memory: 256 MB
Screen size: 1440 x 900
Displays: Color LCD

USB devices
Apple: Internal Memory Card Reader
Apple Inc.: Bluetooth USB Host Controller
Apple Inc.: Built-in iSight
Apple Inc.: Apple Internal Keyboard / Trackpad
Apple Computer, Inc.: IR Receiver

Bluetooth devices
None

OpenGL information

OpenGL software
OpenGL version: 2.1 NVIDIA-8.18.28 310.40.05f01
Render version: 2.1
Shading language: 1.20
Maximum texture size: 8192 x 8192
Z-buffer depth: 24 bits
Maximum viewport size: 8192 x 8192

Implementation settings
Use texture compression: No

Appearance settings
Antialiasing: 2x
Mip map filtering: None
Anisotropic filtering: High

Hope that’s useful!


(Marlin Prowell) #10

I am trying to help, but I need the questions I ask to be answered so I can figure out how to duplicate this. If I cannot duplicate this, I cannot fix it.

@simon_gosling: I asked what “previous version” you were using that worked. I asked if this happened for simple models or just particular models. I asked if setting anti-aliasing to none changed the perceived speed.

@Michael_Hackney: I asked for OpenGL settings. I asked what “previous version” you were using that worked. I asked if setting anti-aliasing to none changed the perceived speed.

Michael_Hackney now says that this is not a permanent condition, which is new information. For now, I am assuming these are two unrelated problems, since simon_gosling has never described this as transient behavior.

New questions for Michael_Hackney: does this slow behavior immediately start when you start Rhino? When you make it go away, does it stay away permanently? If not, what do you do to make the slow behavior return again?

New questions for both of you: Install your “previous version” of Rhino. You can find previous install files (.dmg) in your Downloads folder. Does the behavior return? If not, what is the filename of this release that works?

Reinstall the 2014-02-18 WIP release. Does the behavior immediately return?

Do you have more than one previous release in your Downloads folder? If so, work backwards from the release you have that is just before the 2014-02-18 WIP release until you can find exactly where this problem started. I need to know, of the WIP releases you have, the last one that works correctly, and the first one that does not work correctly.

Even more questions: What version of 3DxWare 10 are you running? Exactly what 3DConnexion device are you using? What is its firmware version? All three of these questions can be answered from System Preferences > 3DConnexion > Tools.

I am running the current release of the 3DConnexion software, version 10.1.0 and released 11/25/2013. I have a SpaceNavigator with firmware version 3.18.


#11

Sorry marlin. I’ve been really busy the last few days.

The previous version was the one immediately before this release. I always grab the new release as soon as I see it.

This problem does happen as soon as I launch Rhino almost always. If I click out of the Rhino window and come back it almost always acts normally. But if I browse away and come back to this window it will sometimes have the jitters again. Clicking out of the window and back fixes it - sometimes I might have to click out and back two times but it will always get to a usable state.

I’ll post Open GL settings tomorrow and set anti-alias to none and report back.

I’ve been able to work fine once I get to a state where the 3D mouse is working properly as long as I stay in that Rhino window, I’m fine. It’s when I go to read mail, browse, etc and come back that this condition occurs - not 100% of the time but about 4 out of 5 times.

I’ll also install the previous release and report back. Moving forward, I’ll keep the previous version rather than overwriting it so it will be easier to compare. For me, this problem started with this burl 503 - I’ve NEVER seen this problem until now. I got my 3D mouse in January and its been working fine until 503.

I have 3DxWare version 10.1.0 and SpaceNavigator firmware version 4.35 - these are the most current versions (no release date on Preferences panel).

Hope this helps and I’ll dig in a little deeper per your requests tomorrow.

thanks,
Michael


#12

Hi Marlin I will try all you suggest over the weekend and report back monday. I do very much appreciate your time and help with this. I can see that ‘yelling’ help is not much help to you(!) I can see i need to be more specific so will try :^)
best regards,
Simon.


#13

Here is my OpenGL config.

Software information

Software versions
Rhinoceros version: 5.0 Wenatchee 2014-02-18 (503)
OS X version: Version 10.9.1 (Build 13B42)

Plug-ins
/Library/Frameworks/3DconnexionClient.framework/Versions/A/3DconnexionClient

Hardware information

Computer hardware
Hardware model: iMac13,2
Processor: Intel Core i5-3470S CPU @ 2.90GHz
Memory: 32 GB
Architecture: Intel 64 bit

Video hardware
Graphics: NVIDIA GeForce GTX 660M 512 MB
Memory: 512 MB
Screen size: 2560 x 1440
Displays: iMac

USB devices
Western Digital: My Book 1140
UltiMachine (ultimachine.com): RAMBo
Apple Inc.: iPhone
American Power Conversion: Back-UPS RS 1000 FW:7.g4 .D USB FW:g4
Logitech: Logitech Wireless Headset
3Dconnexion: SpaceNavigator
Kingston: FCR-HS219/1 Mobile Reader
Apple Inc.: FaceTime HD Camera (Built-in)
Apple Inc.: Bluetooth USB Host Controller

Bluetooth devices
Apple: Apple Magic Mouse
Apple: Apple Wireless Keyboard

OpenGL information

OpenGL software
OpenGL version: 2.1 NVIDIA-8.18.22 310.40.05f01
Render version: 2.1
Shading language: 1.20
Maximum texture size: 16384 x 16384
Z-buffer depth: 24 bits
Maximum viewport size: 16384 x 16384

Implementation settings
Use texture compression: No

Appearance settings
Antialiasing: 4x
Mip map filtering: None
Anisotropic filtering: None


#14

Well, try as I might I have not seen the jerkiness problem at all today. I did reinstall rhinoceros_wip_20140211 but did not see it there either. Inconclusive since I’m not experiencing it at all. I did nothing different today, just sat down and started working. I did look at the antialise setting but did not change it. I’ll keep watching and know what to do if it happens again.


(Marlin Prowell) #15

I noticed that my SpaceNavigator firmware is older than Michael_Hackney’s, so I asked 3DConnection about a firmware update. My SpaceNavigator is too old for a firmware update, but they say it’s likely not an issue. However, they pointed out some things to try:

A couple of general things:
When someone is seeing navigation issues with a new Space Navigator, one thing
to check is whether their computer has had previous 3Dconnexion software
installed.The differences between the current software - 3DxWare for OS X - and
the older 3DxMacWare are significant and the two drivers cannot co-exist.

The 3DxMacWare driver has an uninstall utility in Applications|Utilities -
‘Uninstall 3Dconnexion Driver.app’. Finding this utility indicates that the
3DxMacWare driver has been installed and the utility should be used to remove
it.

Another thing we check when there is a navigation issue reported for an
application is whether the problem occurs outside that application.It can be
useful to know if the problem also occurs in other applications that provide
native support - ie Google Earth or Poser or Second Life.

So, everyone might try uninstalling and reinstalling their 3DConnexion driver software. I know we are hoping for magic to happen here, but I’m at a loss about why this is happening for a few of you, and not for others (including me).


#16

I have tried changing anti aliasing to ‘None’ and that did not make a difference. This problem only manifest itself after I updated Rhino to the version before the present one. I have downloaded the latest drivers from 3dconnexion and calibrated and tested the mouse which appears to be working correctly. It works fine in Google Earth. One thing i have realised is that the mouse is controlling the move but it is not showing the movement between the start and finish of the move. For example, if I rotate an object, as soon as I rotate, the drawing freezes and then as soon as I finish moving it immediately draws the end position. this happens about 95% of the time. sometimes It will be fine and fluid but after a minute or so becomes glitchy again. This happens with an empty drawing or an object or surface. Michael I am glad you seem to have recovered from this!


#17

Oh by the way I did try to reinstall the previous version of rhino from my downloads folder but every time I tried to do it I got a window saying that this version of rhino has expired and i am the prompted to either ‘quit’ or ‘go to website’ to download the latest version. How do you ctually reinstall previous versions I can’t seem to do it?


#18

Hi Marlin,
I have just noticed something! If I am moving my apple magic mouse, the problem disappears.For example if I draw a simple cube and ‘fly around it’ in the perspective viewport when my magic mouse pointer is stationary then the viewport freezes from the start of the move and does not refresh itself until I finish the move with my 3d mouse at which point it displays the end position. If I do the same again whilst moving my magic mouse anywhere at all on the screen, then the problem disappears and movement is smooth. Once I am in motion I can stop moving my magic mouse and i will continue to het a smooth draw rate until i stop ‘flying’ then the problem will recur as soon as I start to move in 3d unless I move my magic mouse. do you think there emay be some conflict with my magc mouse going on?
best regards,
Simon :^)

Simon Gosling
simon.gosling@gmail.com
www.simongosling.com


#19

The “symptoms” of this problem (shooting while moving, rotating) are the same that I had until about 10 days ago with my Wacom tablet. The problem in my case was 99% due to Wacom driver (Wacom forums there are thousands of users who have the same problem, especially with Photoshop). On the advice of Marlin, I installed the drivers from Wacom USA (I live in Italy) but the problem is getting worse. Then I installed another driver from the European site and the problem is gone. However I noticed that when Rhino takes so much ram (about 7gb) and remain with a few hundred mb of ram available (out of a total of 16GB), the problem reappears.


#20

Some more info from me…

As I mentioned, yesterday the problem did not present at all. Today it has. So I immediately went to preferences and changed anti-aliasing to none. Problem went away. So I went and changed back to “4”. Problem returned a little later. I did this several times to verify “the fix”. Then, just to make sure, when I set to “4” again and the problem returned, I opened the Preferences dialog but did not change the anti-alias value (a “blind test”). Guess what, the problem went away. Simply bringing up the dialog and dismissing it returns to normal operation.

One other point, I do have a Wacom tablet installed but it is turned off. The driver is probably a year or more old. I will disable / remove it and see if I experience any issues.