Rhino 8 - Spacemouse 'jumping'

Unfortunately in my case, disabling V-Sync inside Nvidia doesn’t work ( Suggested by @tay.othman . )The problem remains. As I do a lot of “on-sight” modeling, the problem for me is really serious.

If you can use my settings etc. please let me know and I will post them.

Licensed Rhino 8.

Another suggestion is to disable cursor tooltips. Give it a try and let me know

Already tried no difference. For the time being I had to go back to Rhino 7. For me the correct operation of Space Mouse Pro is indispensable. I hope the problem will be solved soon. On Rhino 7 it works perfectly, so the problem is related to Rhino 8.

@BrianJ I made a short video to show the problem.

1 Like

I spent last night working with a pointcloud for an entire building, no issue for me, here are my nvidia settings for rhino.

I have the same settings. Rhino 7 perfect, Rhino 8 there are jumps that make it unusable for me for the time being. It would also be to understand if there is a possible “conflict” between the settings or something else of the Space Muse between Rhino 7 and 8. I also tried configuring all the buttons manually, but nothing changes. Also, I could never uninstall Rhino 7 since Rhino 8 is too “young”.

I’ve been running V8 for almost a year with a daily use of V7. here are few items you can test out.
1- Run the Reset Command on V8 to restore your UI to default state, do not load your options or customizations and give it a try.
2- Use the default 3Dxware settings, instead ise Rhino’s _Spacemouse Popup Objectmode instead

let me know if you get any hope with that.

Thank you but it’s not a test I want to take. It has to work with my settings. I can’t and don’t want to change my workflow. They have to fix it.

Hi @Zsimon ,

I only use an old 3D connexion space navigator device I have here to test for any reported bugs but I don’t use it on a daily basis. I just hooked it up to Rhino 8 running on a Windows 11 drive for the first time and I’m not seeing the problem. I also haven’t installed any driver for it from 3DC yet. The only change to the right click preferences for it that I made in Rhino 8 was to switch to Object mode.

I wonder if the issue you’re seeing happens with certain files only and maybe has to do with screen resolution as well as other settings in the OS or Nvidia control panel. If you can DM a link to a model it happens with on your end I can test it as well here. I’m sure it’s frustrating but I don’t know what might have changed in Rhino 8 from 7 to cause this issue with your set up, 3DC device and settings yet.

Have you reached out to 3DC yet to run your OS, device driver and settings by them? I don’t currently have a suggestion to try other than what has been posted here already.

Update @Zsimon: I may have just seen the issue! I’ll keep digging and let you know when I get something filed.

1 Like

Tomorrow I’ll give it a try with another file, but I used the same file I’m working on on both Rhino 7 and 8. On the 7 it goes perfectly, on the 8 it doesn’t. I had a lot of work to bring all the settings from Rhino 7 to 8, because a lot of things I had to add them manually. I’ve been using Rhino Mac for a long time and have been using Rhino Windows for a couple of years. In a few weeks I will buy a workstation so that will be the real test.

I also see the jumps every now and then but I also see them in other programs such as Artec Studio. I’m on the latest Rhino Service Release and latest 3Dconnexion drivers.

I’m a little tired of people suggesting to use a spacemouse without the 3Dconnexion driver as I have two CadMouse Pro, a SpaceMouse Pro and a keyboard which all require the driver.

1 Like

I didn’t suggest using it without a driver, I just said I hadn’t installed one yet as a variable to my own experience.

Sorry Brian.

I know you didn’t suggest that.

It just pops up as a response to pretty much every 3Dconnexion related issue.

1 Like

@Zsimon I filed https://mcneel.myjetbrains.com/youtrack/issue/RH-78291 with what I’ve found. It was definitely intermittent but I got it captured once for the video file. So this is good news so far but a developer will probably need to reproduce it as well to look deeper into why this is happening. Thanks for the report.


I’ve dealt with this problem before, just changing the USB port where my receiver is plugged in helped.

I have a Space Mouse Pro with a cable, so this doesn’t work for me.

Update. A few days later I tried and tried again in every way to eliminate or reduce the problem of “jug” using the Space Mouse. I couldn’t. The frustration is really great, also because I find Rhino 8 a really great program but at the moment, for me the proper functioning of the Space Mouse is indispensable, consequently, at least for me, Rhino 8 is unusable. I am confident that the problem will be solved as soon as possible. Thank you for your attention. @BrianJ

I know the developers are currently looking into this and a related viewport issue I’ve been seeing. Can you tell me @Zsimon if the viewport jump happens for you if 1) the Properties panel is closed and 2) an object is selected when you manipulate the view?

I read your post and tried for 10 minutes ( I will update the post if I notice any changes).
The phenomenon occurs in a limited way at Rhino 8 startup and increases as time goes by, about two hours ago I had given up using Rhino 8 because the problem occurred about every 30 seconds).
Fingers crossed YES… I confirm that in these 10 minutes of testing the problem did not occur once with the side panel set to layers, while with the properties panel selected the problem occurred over and over again. No difference between objects selected or not, the problem with the properties panel open still occurred.

Thanks, I added that info to the report.

1 Like