Rhino7 Not printing any display mode other than wireframe

Hi all, me again,

So, I model and draw in the model space and then put together my pages in layout with different details in different display modes.
Over the past 2 days rhino has stopped printing anything that is not wireframe.

This happens on many different files.

I have tried:
-refreshing the detail views by switching back to wireframe and then back to arctic or shaded.
-copying the file
-turning rhino on and off
-turning my computer on and off
-updating rhino (I have now Rhino 7 7.5)
-updating Mac (I have now Big Sur 11.3)

I have uploaded:

  • one of this files
  • screenshots of what the layout page looks like
  • print option/preview looks like
  • the printed pdf, where you can see that the 2 left details (wireframe) are printed fine while the 2 on the right (shaded at the top and arctic at the bottom) are not.

Any idea?

Thank you!

Soggiorno_Test1.pdf (1.3 MB) soggiorno.3dm (18.0 MB)

do you think it might be something to do with my computer?
I’ve asked a friend to open my file and he could print it just fine.
This is not the first glitch I have since I’ve upgraded to 7, I wonder if my Mac is just too old? Here are the specs:
Screenshot 2021-04-27 at 10.58.16

I’ve also tried uninstalling and re-installing rhino. No joy

Hello,

maybe it’s the plotter and paper size. Have you tried selecting a standard size like A4 / A3 in your print dialogue box.

this worked fine, pen/arctic/rendered/technical in each box, both printed straight and saved as PDF.

good luck.
Blauzac.pdf (3.5 MB)

Hello,
yes I’ve tried all printers and plotters in various sizes including a standard a4/a3 photocopier as well as the Mac print to pdf.
also tried vector against raster prints, no difference, fiddled with the visibility options in the print window, no difference.

copied the whole content of a file into a new one, no difference.

it seems that as long as it’s wireframe, therefore vector (and lighter maybe?), it prints fine but as soon as rhino sends the request to flatten on a page a rasterise picture my Mac says na…

the IT team at work here is looking into it as well but they haven’t found a solution yet.

Ok, I’ve just tried to print arctic straight from the ‘model space’ as in in front view but not in layout and it printed fine…
still not ideal as I desperately need layout but it’s something…

Hello
We have a similar problem with the printing on rhino7
rhino doesn’t print alls blocks objects.
see the attached file.
if I have one bloc instance in the document and i needed prit him then rhino 7 didn’t print. rhino print a beautifull whit square paper. but if i copy the bloc and explode it then rhino print correctly the blocs instance!

for info, rhino 6 print corectly the block instance.

do you see the bug on our machine?

Best regards

my configuration machine is
Rhino 7 SR6 2021-5-7 (Rhino 7, 7.6.21127.19001, Git hash:master @ aec74c050f3ca28ab3cfd6882e9453a52366a9b7)
License type: Commerciale, version 2021-05-07
License details: Cloud Zoo

Windows 10.0.19042 SR0.0 or greater (Physical RAM: 32Gb)

Computer platform: LAPTOP - Plugged in [60% battery remaining]

Non-hybrid graphics configuration.
Primary display and OpenGL: NVIDIA Quadro RTX 3000 (NVidia) Memory: 6GB, Driver date: 10-22-2020 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 452.57
> Integrated accelerated graphics device with 4 adapter port(s)
- Secondary monitor is laptop’s integrated screen or built-in port
- Windows Main Display attached to adapter port #1

Secondary graphics devices.
Intel(R) UHD Graphics (Intel) Memory: 1GB, Driver date: 5-5-2020 (M-D-Y).
> Integrated graphics device with 3 adapter port(s)
- There are no monitors attached to this device. Laptop lid is probably closed

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 10-22-2020
Driver Version: 27.21.14.5257
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 6 GB

Rhino plugins that do not ship with Rhino
C:\Program Files (x86)\Lynx\Lynx.rhp “Lynx” 0.0.0.0

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.6.21127.19001
C:\Program Files\Rhino 7\Plug-ins\WebBrowser.rhp “WebBrowser”
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino 7\Plug-ins\RPC.rhp “RPC”
C:\Program Files\Rhino 7\Plug-ins\IdleProcessor.rhp “IdleProcessor”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.6.21127.19001
C:\Program Files\Rhino 7\Plug-ins\RhinoRender.rhp “Legacy Rhino Render”
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.6.21127.19001
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\Alerter.rhp “Alerter”
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.6.21127.19001
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.6.21127.19001
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”

Print bug rhino7.3dm (1.8 MB)

Hi SMC2,

I assume that your problem occurres, same as mine, when on a Mac, from layout, you simply go ‘print’ and either send it to a printer/plotter or do 'save as pdf.

I had our IT person have a look at it with no result but we found out this way around it:

when you are in layout, with your page ready to print, go:
→ file
→ export

when in that window select PDF in the format bar.
I know it looks wrong because it doesn’t show any printing options but go ahead, choose a name and a place for your file to be saved.
when you proceed it will take you to an actual printing/format/page window where you’ll be able to choose paper size, scale, vector/raster etc.
I find something a bit hard to understand on the scale, it almost seems it is printing on the wrong one as the preview will show a big white margin around it, but again, go ahead and check the pdf for scale. mine weirdly seem to print on the correct scale even if the preview suggest differently.
Try that. hope it works for you.