{Rhino7-Crash} «TDR has been detected» | My solution through NVIDIA-Settings

I leave it here in case someone is looking for a solution to a similar problem. Before posting, I searched for similar threads on the forum. I only found topics related to Rhino 6 or 5

Rhino 7 crash after program start on Windows 8.1 with Quadro 600 graphics card.
The Error-Message is “A TDR has been detected. The application must close. Error code 7


…and then a link to the NVIDIA page

On the NVIDIA page it is recommended:
1. “Reduce the graphics workload if possible, such as by rendering to a lower resolution or by reducing the detail.”
2. “Increase the timeout value to allow more time to complete more intensive rendering.”

By trying to change the settings in the NVIDIA control panel I was able to successfully run Rhino 7. I have recorded my search for the problem and published it on youtube, so that someone with similar problems can figure out how to fix their problem.

There is no sound in the video and my operating system has a german interface, but I hope the video helps anyway.

***Updated on 6.2.2021***: SystemInfo-Content attached (you can also see the same at the end of video)

Rhino 7 SR2 2021-1-21 (Rhino 7, 7.2.21021.07001, Git hash:master @ 96ff97351fbdf5d2acdeaf781aea1577f2ff60f7)
License type: Evaluation, Build 2021-01-21
License details: Stand-Alone
Expires on: 2021-05-02

Windows (Physical RAM: 24Gb)
VersionMajorMinorServicePack failed

Computer platform: DESKTOP

Standard graphics configuration.
Primary display and OpenGL: NVIDIA Quadro 600 (NVidia) Memory: 1GB, Driver date: 2-6-2017 (M-D-Y). OpenGL Ver: 4.5.0 NVIDIA 376.84
> Accelerated graphics device with 2 adapter port(s)
- Windows Main Display attached to adapter port #0

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.5
Shading Language: 4.50 NVIDIA
Driver Date: 2-6-2017
Driver Version:
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 1 GB

Rhino plugins that do not ship with Rhino

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.2.21021.7001
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.2.21021.7001
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.2.21021.7001
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.2.21021.7001
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.2.21021.7001
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”

It would be useful if you posted the results of the Rhino command _SystemInfo

Thanks for the tip, added the contents of the file “_SystemInfo” to the spoiler at the end of the text.

This GPU is already very old.

The Raytraced mode and Rhino Render in Rhino 7 does not support this GPU, because of that.

It has only 1GB of VRAM, and with Rhino 7 pushing the GPU more it is not a surprise you had to tweak settings as you did. I don’t know how future proof that tweak is going to be though.

With the GPU in its eleventh year it may be a good idea to look into upgrading where you can.

1 Like

You can get out a bit of vram

And under Systemsteuerung\Darstellung und Anpassung\Anpassung
set Desktophintergrund auf einfarbig

A TDR has been detected. The application must close. Error code 7
TDR can be increased via registry, but effect questionable.

As Natan says, GPU Rendering nopes

1 Like