Rhino6 Trial 'not responding' & saved file empty

Hello,
My Rhino 6 trial stopped responded when I tried to move a part. I had saved the file right before I moved the part. I waited for like 30 mins and when I saw it still did not respond I force closed my computer and opened it again. However, when I tried to open the file again it gave me this error I attached below. When I close the error window the file looks empty, without layers, parts, not even a default layer, nothing. However, the file still appears to be 21MB. I opened the backup file but it was not the version I had saved before, even though the update time is correct it showed me the version that was 1 hour before. Why is the program giving me this error, and how can I get my latest version back?
Thank you.

rhino

Hi - you could try to run the Rhino Rescue3dmFile command on that file but it looks like it might have been altered too much during the computer hang and reboot.

As for earlier backups: do you have the “Create backup (*.*BAK) files” and / or “Autosave” features turned on?
-wim