Rhino6 runs extremely slow on my laptop

rhino

(Shiqi Deng11) #1

Hey guys, I have both rhino 6 and rhino 5 installed on my laptop, and I am dealing with a model which has many replications of blocks… the file itself is not heavy at all…like 10mb … but the geometry displayed in the viewport is a lot…

My problem is this file runs extremely slow in Rhino6, but very fast in Rhino 5 on the same laptop!!!

I assume it is because of the display setting? So I have tried to use jagged fast mesh… bounding box display… switched off the GPU Tessellation, No antialiasing, lower the dynamic redrew…, like every setting I can find to speed up Rhino… but it is still very very very very slow… takes forever to do a simple rotate. .And this is driving me crazy right before my deadline!

BTW this is my main laptop, I have another small laptop which is less powerful, but the file is perfectly running on it. So mysterious.

Waiting for help!! Come a hero Plz, save me !!~

Here attached is my systeminfo:

Rhino 6 SR13 2019-2-27 (Rhino 6, 6.13.19058.371, Git hash:master @ 17cd8b51accbe17dd04b48028f49d5e77a67f17b)
License type: 试用版, 版本2019-02-27
License details: Cloud Zoo. In use by: shiqi deng ()
Expires on: 2019-04-02

Windows 8.1 (Physical RAM: 16Gb)
Machine name: SHIQI

Hybrid graphics system.
Primary display: Intel® HD Graphics 4600 (Intel) Memory: 1GB, Driver date: 3-23-2016 (M-D-Y).
Primary OpenGL: AMD Radeon ™ R9 M390X (AMD) Memory: 4GB, Driver date: 7-4-2017 (M-D-Y). OpenGL Ver: 4.5.13476 Compatibility Profile Context 22.19.171.1024

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: None
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: ATI Technologies Inc.
Render version: 4.5
Shading Language: 4.50
Driver Date: 7-4-2017
Driver Version: 22.19.171.1024
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 4 GB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.13.19058.371
C:\Program Files\Rhino 6\Plug-ins\WebBrowser.rhp “WebBrowser”
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino 6\Plug-ins\AnimationTools.rhp “AnimationTools”
C:\Program Files\Rhino 6\Plug-ins\IdleProcessor.rhp “IdleProcessor”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.13.19058.371
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\Alerter.rhp “Alerter”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.13.19058.371
C:\Program Files\Rhino 6\Plug-ins\Grasshopper\GrasshopperPlugin.rhp “Grasshopper” 6.13.19058.371
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.13.19058.371
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Chaos Group\V-Ray\V-Ray for Rhinoceros 6\VRayForRhino.rhp “V-Ray for Rhino”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”

Thank you guys in advance!


(Pascal Golay) #2

Hello - is the slowness in every display mode?

If you can find newer drivers for both Intel and Radeon, I’d get those installed - see the ‘Notifications’ panel (Panel menu), and double-click on the notification about the drivers and follow along… Please let us know if that sorts it out and run SystemInfo again and post the results.

Also, please try running Rhino with VRay disabled in Options > Plug-ins page (restart Rhino). Is that any better?

-Pascal


(John Brock) #3

It looks like you’re running an older system that is no longer being updated.
AMD quit updating that R9 a couple years ago.

My best advice would be to stick with V5 until you can replace the computer with a newer setup.
V6 just requires more capabilities that your setup can currently supply.


(Shiqi Deng11) #4

Hey Pascal, thanks for the reply!
I have updated both graphic drivers to newest version direct from their offical website, and disabled the vray as well…
but nothing changed, and it is still slow in every display mode… even shade / wireframe mode…

Rhino 6 SR13 2019-2-27 (Rhino 6, 6.13.19058.371, Git hash:master @ 17cd8b51accbe17dd04b48028f49d5e77a67f17b)
License type: 试用版, 版本2019-02-27
License details: Cloud Zoo. In use by: shiqi deng ()
Expires on: 2019-04-02

Windows 8.1 (Physical RAM: 16Gb)
Machine name: SHIQI

Hybrid graphics system.
Primary display: Intel® HD Graphics 4600 (Intel) Memory: 1GB, Driver date: 3-23-2016 (M-D-Y).
Primary OpenGL: AMD Radeon ™ R9 M390X (AMD) Memory: 4GB, Driver date: 7-4-2017 (M-D-Y). OpenGL Ver: 4.5.13476 Compatibility Profile Context 22.19.171.1024

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: None
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: ATI Technologies Inc.
Render version: 4.5
Shading Language: 4.50
Driver Date: 7-4-2017
Driver Version: 22.19.171.1024
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 4 GB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.13.19058.371
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.13.19058.371
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.13.19058.371
C:\Program Files\Rhino 6\Plug-ins\Grasshopper\GrasshopperPlugin.rhp “Grasshopper” 6.13.19058.371
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.13.19058.371
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”

Seems nothing changed… maybe is because of my hardware? but this laptop should not be that slow and has two graphic cards???


(Shiqi Deng11) #5

Thhanks John!

So it is actually a problem of the graphic card? the latest driver they released is in 2017 and mine is 2017… So there is no way to fix it, unless I upgrade my hardware?
BTW a stupid question: Does ‘V5’ means rhino 5 and ‘V6’ means rhino 6?

Best,


(John Brock) #6

Yes, Rhino V5 and Rhino V6.
Rhino V5 used a much older OpenGL specification than V6 requires.
It appears that the changes to Windows and display tools just went beyond what your AMD card can do.


(Shiqi Deng11) #7

BTW there is the systeminfo of another less powerful laptop I have which is surface pro…

Rhino 6 can runs smoothly without any stuck in this file…

I have no idea about the hardware till this moment my Rhino6 Stuck… Seems the only thing slows my big laptop down is the Graphic card? …So upset…

Thanks for your replys

T_T

hino 6 SR13 2019-2-27 (Rhino 6, 6.13.19058.371, Git hash:master @ 17cd8b51accbe17dd04b48028f49d5e77a67f17b)
License type: Evaluation, build 2019-02-27
License details: Cloud Zoo. In use by: shiqi deng ()
Expires on: 2019-04-02

Windows 10.0 SR0.0 or greater (Physical RAM: 16Gb)
Machine name: DESKTOP-7JTGS2C

Non-hybrid graphics.
Primary display and OpenGL: Intel® Iris® Plus Graphics 640 (Intel) Memory: 1GB, Driver date: 5-25-2018 (M-D-Y). OpenGL Ver: 4.5.0 - Build 24.20.100.6136

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: None
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: Intel
Render version: 4.5
Shading Language: 4.50 - Build 24.20.100.6136
Driver Date: 5-25-2018
Driver Version: 24.20.100.6136
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 1 GB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.13.19058.371
C:\Program Files\Rhino 6\Plug-ins\WebBrowser.rhp “WebBrowser”
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino 6\Plug-ins\IdleProcessor.rhp “IdleProcessor”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.13.19058.371
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\Alerter.rhp “Alerter”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.13.19058.371
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.13.19058.371
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”


(John Brock) #8

Yes, I have a little Surface Pro I use for working remotely, and it runs Rhino V6 pretty well. It’s not nearly as capable as the desktop system at work with an nVidia Quadro P2000, but it does what I need it to do.


(Wim Dekeyser) #9

You could hold off running to the shop to get a new GPU. In a future Service Release (probably SR15) there will be a test command to force Rhino to use lower OpenGL calls. That might (note the stress on might) get your Rhino 6 working as Rhino 5. But we won’t know that until that test command is available for you to test.

That said, note that modern hardware will perform better than what you got out of Rhino 5…