Rhino 6 VS Rhino 5 : some speed issues

unhandled

(Akeswins) #1

Hi,
I currenty use Rhino 5 in 2 pc, and recently downloaded and used Rhino 6 wip and beta.
First pc is a 5 years old core-i5 desktop, with 8 gb ram and a pretty old invidia Gt 220 ,
Second pc is a 1 year old notebook acer aspire f5, i7 core, 8 gb ram, geforce gt 940 video.

These software have big differences in speed and smoothnessdepending on the PC in which are installed.
In the desktop pc, rhino 5 runs smoothly and quickly, but rhino 6 is way way slower , almost unusable even using small cad models (<100 MB)

On the other hand, in the notebook, rhino 5 is fast exactly as the desktop pc, and Rhino 6 is way faster and also with a better graphic .
How is possible?

it would say “simple, the better videocard gives better performances on a software designed for it”… but the issue is not as simple.

I noticed the slowness of RHino6 in my desktop pc since i downloaded the first wip versions and initially stopped to use it in this pc. But after some updates, i used some wip versions that were very fast also in desktop pc, so i imagined that there were some incompatibility that had been solved. So i enjoyed R6 in both my pc , until they launched another wip version that -again- turned slow. It lags , and rotating/moving the model, sometimes they appears some “rips” on the screen. Also the latest beta has the same issue.

You can show here a video comparison, 5 vs 6 on desktop pc.

Have you experienced something alike? Is there some option (video, etc etc) that I can change to improve ?
I think R6 could be quick as 5 also in this pc, but needs to change some settings.Otherwise, it could not have been possible that some WIP ran faster.
Thanks and Best Regards
Alessandro


#2

First thing to check is to update your video drivers… Rhino 6 needs the most recent possible. --Mitch


(Akeswins) #3

Thanks Mitch.
Drivers updated just few minutes ago, but no improvements in Rhino 6


(Pascal Golay) #4

Hi Alessandro - as a test, turn off ‘GPU Tessellation’ in Options > View > OpenGL page on the desktop - any better or different?

-Pascal


(Akeswins) #5

Hi Pascal, I tried, no differences.


(David Eränen) #8

Hi @akeswins,

Is it very slow even when you just have a single box? Is there a significant speed-up if you make the viewport smaller?

-David


(Akeswins) #9

Hi David,

there is a small amount of speed if I reduce the view, of course, anyway I have some lags also reducing the viewport to very small dimensions. It happens using shaded view; if I set rendered view, the model becomes almost impossibile to manage.
The same model (almost simple) runs perfectly even using rendered view maximized in Rhino 5.



(David Eränen) #10

@akeswins

I think this has to do with Rhino doing per-pixel shading/lighting. This is too much for the GT 220 (from 2009). @jeff Do you agree? Is it because the GT 220 is better suited for the fixed pipeline of V5?

-David


(Steve Baer) #11

Can you go to the help menu in Rhino, select system information and paste the results here for your slow system? We may be able to glean some ideas from this about what is happening.


(Akeswins) #12

@David
I don’t know if Gt220 is the problem, because in some version of the WIP , Rhino 6 ran almost well.

@Steve
here it is

Rhino 6 SR0 2018-1-12 (Rhino WIP, 6.0.18012.13241, Git hash:master @ 00ae144185bd9d3bd331a5464cb37a9e051f7258)

Windows 7 SP1 (Physical RAM: 8Gb)

GeForce GT 220/PCIe/SSE2 (OpenGL ver:3.3.0)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 3.3
Shading Language: 3.30 NVIDIA via Cg compiler
Driver Date: 11-14-2016
Driver Version: 21.21.13.4201
Maximum Texture size: 8192 x 8192
Z-Buffer depth: 24 bits
Maximum Viewport size: 8192 x 8192
Total Video Memory: 1 GB

C:\Program Files\Rhino WIP\Plug-ins\Commands.rhp “Commands”
C:\Program Files\Rhino WIP\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino WIP\Plug-ins\RPC.rhp “RPC”
C:\Program Files\Rhino WIP\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino WIP\Plug-ins\rdk_etoui.rhp “RDK_EtoUI”
C:\Program Files\Rhino WIP\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino WIP\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino WIP\Plug-ins\RhinoCycles.rhp “RhinoCycles”
C:\Program Files\Rhino WIP\Plug-ins\Toolbars\Toolbars.rhp “Toolbars”
C:\Program Files\Rhino WIP\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino WIP\Plug-ins\Displacement.rhp “Displacement”


(Lentakffm) #13

i would also be eager to know the answer…

i have a similar system (i7, 12gb RAM, nvidia geforce gtx285 1gb) with similar issues.


(Jari) #14

Try lowering Anti-aliasing to 2x


(Akeswins) #15

Tried all changes to antialiasing, no difference


(Akeswins) #16

well… I solved.
Purchased a new pc with xeon E3, 16GB ram, SSD, nVidia quadro m2200… now rhino 6 goes fast.