V6 much slower than V5

Dear Helpdesk

I used taking Rhino models with me on my laptop (Samsung New Series 9) to clients. Although not extremely fast, it worked quite well. Now with V6, the speed went down to a level it is not workable even not with only one view in wireframe mode . Pls advice what settings to select to get old speed back or advice otherwise
(Reason for upgrade was promise of increased speed.)

Processor Intel i5-3317u
Installed RAM 8 GB
Intel® HD graphics 4000
Render version 4.0
Video mem: 2GB

Hi Rob,

Can you run the command SystemInfo and paste the result here, it can give a first insight on the possible cause.

Furtermore it’s always wise to update GPU drivers.

Also it’s good to know what type of files and geometry you are working with. Can you drop a file here that you experience this slowdown with so we can test possible causes?


Hi Willem,

Dat kan alleen maar nederlands zijn. :slight_smile:

Zoals verzocht, output hieronder.

Verder alles langzaam op deze laptop. Zelfs model met maar 1 lijn.



Rhino 6 SR6 2018-6-26 (Rhino 6, 6.6.18177.16151, Git hash:master @ abeff9e9af62a0e02a9eb52efa77e179a682f2c7)

Licence type: Commercial, build 2018-06-26

License details: Cloud Zoo. In use by: rob.hoekstra ()

Windows 10.0 SR0.0 or greater (Physical RAM: 7.6Gb)

Machine name: LT_SEACAMEL

Intel® HD Graphics 4000 (OpenGL ver:4.0.0 - Build

OpenGL Settings

Safe mode: Off

Use accelerated hardware modes: On

Redraw scene when viewports are exposed: On

Anti-alias mode: None

Mip Map Filtering: Linear

Anisotropic Filtering Mode: Height

Vendor Name: Intel

Render version: 4.0

Shading Language: 4.00 - Build

Driver Date: 12-21-2015

Driver Version:

Maximum Texture size: 16384 x 16384

Z-Buffer depth: 24 bits

Maximum Viewport size: 16384 x 16384

Total Video Memory: 2112 MB

C:\Program Files\Rhino 6\Plug-ins\Commands.rhp"Commands"6.6.18177.16151

C:\Program Files\Geometry Gym\Rhino3d\BullAnt.rhp"bullant"

C:\Program Files\Rhino 6\Plug-ins\rdk.rhp"Renderer Development Kit"

C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp"Rhino Render"

C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp"RDK_EtoUI"6.6.18177.16151

C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp"Renderer Development Kit UI"

C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp"Snapshots"

C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp"RhinoCycles"6.6.18177.16151

C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp"Toolbars"6.6.18177.16151

C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp"3Dconnexion 3D Mouse"

C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp"Displacement"

C:\Program Files\Common Files\McNeel\Rhinoceros\6.0\Plug-ins\SectionTools (fbdb1d7f-8cfb-42c1-9858-87cb6315932c)\2018.4.17.851\SectionTools.rhp"SectionTools"

Hi Rob - see if getting the latest driver from Intel helps at all. I would say don’t rely on Windows giving the right info about driver availabilty - check yourself on the Intel website. That said, I don’t know how the 4000 is going to work with V56. V6 makes many more demands on the video card…


Something else to try is to disable the bullant plugin in Rhino’s plugin manager. Restart Rhino and see if that makes a difference. Bullant may (or may not) be slowing Rhino down. It’s just a good thing to test.

Bullant disabled and video drivers updated. No diff. :-/

After running SystemInfo I also noted:

‘Use accelerated hardware modes: On’

If I am correct, this had to be Off at V5. Should it be on at V6? If not, how to switch off?



It should be On in V6.
What is the date of your display adapter driver now?

Driver Date: 12-11-2017

This might be newer:


I downloaded and installed the driver from site indicated by you. Same site as I visited 1hr ago and downloaded same driver (again). Re-installed the driver, restarted the laptop and started Rhino again.

While the intel site indicates a more recent date, SystemInfo gives again Driver Date: 12-11-2017. Nothing seems to have changed. However,…

…and I do not understand. The laptop is up to speed again???

So problem not solved but gone any way which is okay for me as well.

IT moves in a mysterious way


tx for your effort and have a nice evening.



Any thoughts here @stevebaer?

I don’t quite understand. It sounds like the driver update took effect after a reboot and everything is working now.

Maybe that’s it.
@rob.hoekstra: Did you reboot after the first driver update?

Yes rebooting all the time.


Kind regards, vriendelijke groet,

Rob Hoekstra

message sent by mobile phone so might be short.


Just to revert a bit more clear,

Just to be follow John’s advice, while knowing I know it should be useless as I had done it already, I went twice through the cycle.

  1. download latest driver,
  2. install driver
  3. reboot and check Rhino speed.

Only after the second cycle it worked and Rhino was back up to speed.

Strange? Yes!

Problem solved? No

Problem disappeared? Yes

tx again for your help.