Rhino6 Options Menu Size

Has anyone else had a problem with the Options menu being too large for 15" screen?

I am not able to size the menu smaller, and I’m in the finest resolution possible for my laptop - 1920x1080. But still I can not even see the Save button. This is making it almost impossible to customize Rhino6 and is posing a very annoying barrier.

Any solution for this that anyone found?

Hmm, I don’t have that problem here on my 15.6" 1920 x 1080 screen laptop - the Options panel is maybe 600 px high at its smallest. Somehow maybe the size handle in the lower right corner ended up off-screen? Can you resize the panel from the upper left or upper right corners?

If you find

C:\Users\<username>\AppData\Roaming\McNeel\Rhinoceros\6.0\settings\ window_positions-Scheme__Default.xml

and open it you should have as the first entry the position and size of the Options dialog:


The first two numbers are the position in pixels from the upper left corner, the second two are the size of the dialog box… Can you see what your values in there are?

I’m not sure if you can simply modify the values in the xml file in a text editor and re-save it…??

You can try to move or resize the dialog by keyboard.
Hit Alt+Space on the keyboard and select the wanted function from the system menu.
Then go on with the cursor keys.

1 Like

I can’t get the xml to save in that state, it seems. I restart, reopen, and then everything is back in its original size, which is slightly larger than the screen in its Height.

I’ll take a look into it further in a couple of hours - see if adjusting to your specific dimensions is the key, but I’m really a bit confused by it because I can’t resize the window at all beyond making it larger in its width.

No effect. The smallest possible size is seemingly the one slightly taller than my screen. Thanks, though!

Have you got some sort of display scaling set in Windows?

Hello - can you try the test command


Does that do anything good?


I have the same problem on a 13 inch 1920 x 1080 “ultrabook” laptop. The bottom of the options window is always outside of my screen and I can’t resize it to a smaller height by dragging any of the upper corners/side, so I can’t save any options. Only once I connect to an external larger screen, I can change the options by dragging the window to the other screen…at the end of the day though, I can’t change and save Rhino settings in my laptop. The above mentioned tips didn’t change anything. Is it possible to make the window properly resizable?

Hi - what is your display scaling set at?

Ah yes, its automatically at 150% so setting that to 100% does make the entire window show up, so I do have the possibility to change the settings on my laptop by switching the monitor scale. So Thanks for this hint.
But I do still wonder if one day I could be able to do that by shortening the vertical size of the “Options” window in Rhino. With my display’s pixel density, it’s impossible to work at 100% screen scale at all times, and switching it repeatedly is quite a drag.
Nevertheless, thanks for the workaround solution.