Options Window

unhandled
options

#1

I just installed Rhino WIP just to check it out and right out of the gate I have an issue…The “Options Window” won’t let me apply changes. I went to change units and grid properties, but there are no buttons at the bottom of the form. Am I missing something, or are they just not there yet?


(Nathan 'jesterKing' Letwory) #2

Have you tried resizing the Options window? Before you do please make a screenshot and post here.

/Nathan


#3

Yes. There is no maximize/minimize button on the window. Only an X. It appears that the window is sizable, but its minimum size is fixed; which just happens to be the entire width of the screen. I can see the whole form and no buttons at the bottom. What should I do with this screenshot?


#4

Yes happens here too luckily I can move the screen and get to the ok and cancel buttons but the options dialog won’t let one resize it even though it has the grab thing in the corner. It just fits on my laptop screen see the screen shot I posted for the fbx thread.
RM


(Nathan 'jesterKing' Letwory) #5

If your screenshot is still in the clipboard just paste the text editor of a new comment. Most browsers support that. If it is alread a file you should be able to drag&drop it in the text editor.

What screen resolution are you working with?


#6


#7

Here is what I see with Work In Progress (6.0.17227.14151, 8/15/2017):

What version of the V6 WIP do you have?

What is you system configuration and graphics?


(Nathan 'jesterKing' Letwory) #8

It looks like the options window doesn’t get layed out properly on resolution with tiny height.


#9

The version is 6.0.17227.14151, 8/15/2017. I think nathanletwory is correct. I thought I was seeing the entire form. But, I can drag it up by the title bar just a tiny amount and see the tops of the buttons; even after changing the resolution on my screen. Maybe it just my problem, but its not an issue with Rhino 5…image


#10

I can duplicate what you see with the V6 WIP if I set my display resolution to 1280x768. Rhino 5 does not have the problem at that display resolution.

Update:
1280x920 V6 WIP - no problem.
1280x800 - buttons are visible behind task bar at bottom of Wndows 10 screen.
1280x768 - only top of buttons are visible behind task bar.
1280x720 - buttons are not visible.

What is your display resolution?


#11

David, for me Rhino 5 doesn’t have a problem at any resolution because the frame for the options window is smaller. I have a Lenovo Yoga running Windows 10. I hide my taskbar because it gives me a little extra screen to view. So, it’s not in the way of anything. Below is a shot of my available screen resolutions. I’ve tried every one with nothing more than the tops of the buttons showing when I drag the window up with the taskbar.


#12

@peternic Looks like 768 is the largest vertical screen resolution available on you Yoga. Based on my experiments that’s not enough vertical resolution to display the entire Options panel including buttons in the current V6 WIP.


(Nathan 'jesterKing' Letwory) #13

I have reported the issue as RH-40893.

/Nathan


(Nathan 'jesterKing' Letwory) #14

The next public WIP will have the minimum size shrunk so that the options window fits in a 678 pixel height.

/Nathan


(Dan Belcher) #15

RH-40893 should be fixed in the latest WIP. Please give it a try.


(Marten) #16

I have the same problem with the options window. I can’t hit OK and I can’t resize the window.
Version 6 SR6
(6.6.18177.16151, 06/26/2018)
Screen resolution is 1920x1080, Windows 10 Home.


(Marten) #17

Ok, if I disable the Windows Bar at the bottom, I can just see the OK button.


(Nathan 'jesterKing' Letwory) #18

Do you have windows set to scale the UI to something larger than 100%?


(Marten) #19

Hi Nathan, thanks.
Yes, true. I have it set to 150%. Didn’t think of that.
Still, should I not be able to resize the Options window?


(Marten) #20

At 100% the window has plenty of space: