Rhino3d compatibility inquiry for Apple iPadOS

When I open a .3dm file containing a mesh object in the Rhino3d application on Apple iPadOS, the file does not open. Is it possible to open only NURBS data?

Hi -

The Rhino3d application does not run on iOS - is this a question about iRhino3d, the iOS viewer for Rhino files?
If so, I believe that all objects need to have display meshes attached to them to be able to view them. Saving the 3dm file in Rhino with a viewport in a shaded display mode will create those.

I was referring to the app in the iPad App Store. The viewer you mentioned is correct.
But the question I asked is that a .3dm file containing a general polysurface or single surface object opens as well as the image attachment below, but the file containing a mesh object does not open in the processing state like the last image, so I wrote a question.

Hi -

I don’t have an iOS device to test this on, but the following post seems to suggest that both the render meshes and regular mesh objects are read by the app:

Perhaps there is something out of the ordinary with the meshes in that one file? Can you post that here?

The attachment does not open even though it is a simple object converted from a simple polysurface cylinder to _Mesh. A typical polysurface object file can be opened with no problem even with a file of several hundred megabytes.
메쉬.3dm (60.4 KB)

I hope that the 7 version save file compatibility and subd object can also be opened.

Hi Flawless -
There won’t be any updates to the app in the foreseeable future.
You might want to look into one of the web apps that can read 3dm files.


It’s a pity that there are no plans yet.
thanks for the help though

I agree…None of those web apps worked for me. Todays iPads and iPhones have plenty of graphics and processor power to view any of my models. I’d gladly pay $200 for a viewing app that worked well.


@flawless8862 , @brianscottwheeler you’re probably aware of the new iRhino3D iOS app we’re working on.
You can join the beta here: iRhino WIP Available - #88 by mkarimi


Cannot open a single file in iRhino3D… using Dropbox. App simple fails as soon as I’m trying to open… what am I doing wrong?

Hi @H2O , can you please verify the version of the app you’re using?


It actually works on my iPhone but not my iPad… both are running same IOS - Also, same version of the app, as below:

I’m thinking maybe there is a setting issue I’m missing? :man_shrugging:t3:

Best regards,

Joachim Schia

We are seeing some issues with different iPad models right now that we are trying to fix. There must be some subtle differences in what the difference GPUs on these devices support that we haven’t quite figured out yet.

This is our current top priority for iRhino as we don’t want to make any sort of public announcement about the app until we have this fixed.

Can you share which exact iPad model you have? This can be found in the general settings for your iPad.

Hei Joachim -
It looks like the part with the iPad model information did not make it in your last post…


Very sorry. Don’t know what happened…

iPad model Pro 2nd generation… iOS 16.

As a pro CAD user and educated helpdesc in CAd as well as experienced tester of a lot of CAD-sytemes and versions as well as all Rhino versions I must tell you that Rhino distributed a total inoperapable app on IOS and for IPAD of all kind! Sorry…but Rhino has to make its lession before publishing, but other apps are free and readig all step, Iges and STL…and fast toooooo!

No need to double-post, you already mentioned it not working on your device (but it has been tested to work on a number of devices). In your original thread (New Ipad free Rhino viewer is totaly out of order) you may want to add some system information to help identify what might be the problem.

edit: apparently you were already asked to do so in your first thread.

@H2O we just released a new version of iRhino (version 8.0.22334) that we think should work on your iPad now. Please update and let us know if things start working.


It now works with smaller files. For larger files still crashes, but that might be the iPad rather than iRhino version…

Many thanks.

1 Like