Rhino files will not initialize on the iPad app

Hello

I can’t get files to initialize on the Rhino iPad app. I’ve tried different versions 3-7, different iPads but can’t get them to initialize. I can upload files no problem. I can view the provided models when I download the app but can’t get my files to open.

I’m using Rhino 7 on a PC.

1 Like

Hi -
You might want to take a look at rview as an alternative to view Rhino models outside of Rhino.
-wim

Just saw this.
Does that mean that iRhino is being abandoned?

Not officially no.
That said, there have been other higher development priorities so it has been on the “back burner” for some time.

I didn’t know it was broken and I advised our customers to use it. Now they are complaining that they wasted their time and effort trying to make it work. I also wasted some time trying to figure out why it tells me that it can not open Rhino 6 files when I tried to open a Rhino 7 file.
Either you should fix it or remove it from the App Store to eliminate the confusion.

I figured out that iRhono 3D actually works but not with Rhino 7 files, in which case it says that it can not open Rhino 6 files. So as long as you save your file as Rhino 6 you can preview it there.
So in the meantime it would do if this message was changed to ‘can not open Rhino 7 files’.

Any news on when the app will be updated to read Rhino 7 files?
Seems pointless to keep models in rhino 6 and 7 formats…

Hi Morten -

That’s not on the table at this point.
Perhaps you should look into one of the viewers out there…

-wim

After much trial and error I got iRhino to accept files again. My starting point is Rhino 7 on Mac

  1. Export as Rhino 5
  2. Open in Rhino 5 (because I have 5, might work for 6)
  3. View in rendered mode and make sure materials are Rhino 5 materials.
  4. Save in shaded mode
  5. Save file in google drive, Dropbox or http/…
  6. Open iRhino, go to +, then Dropbox, select file to import
  7. Should work! (Although saved in shaded mode, displays as rendered mode.)

Because IRhino is old, I found that it requires file to be opened and saved using Rhino5, exporting from 7 to 5 alone did not work. Thus all materials get substituted for Rhino Basic material Types, but this might get messed up, hence step 3.

2 Likes