Rhino Viewports black after loading a second scene


If I load a scene, open the Octane Viewport, close the Octane Viewport, then load any other scene, I get all black Rhino viewports on Rhino7. I had this problem a while back, and Nathan resolved the problem at the Rhino end, but it seems to have returned. Running the latest Nvidia drivers.



@pkinnane opening the Octane viewport - does that mean a separate window with Octane running in, something custom. Or a Rhino viewport that you set to Octane mode?

Is this with Octane version 4? If it is with a newer version I’ll have to get access to that newer version - if you could ensure that, please.

Hi @nathanletwory - I doubt Octane 4 would work with the latest Nvidia drivers, so I don’t know. But I tried with the DEMO version at OTOY Forums • View topic - OctaneRender 2020 for Rhino (TEST and STABLE) (OctaneRender for Rhino6 2020.2.3.126) and it reproduces the problem.


I tested here with a current Rhino 7 build using the mentioned demo version, but I am unable to reproduce the problem. Steps taken:

  1. Load a model
  2. Click the Octane icon in the Octane toolbar to get the setup window
  3. Click Open Viewport
  4. Close the Octane viewport
  5. Load a different model.

All viewports still function as expected. Tested with local developer build 7.11.21243.01000 and current service release candidate 7.10.21236.11001.

Thanks @nathanletwory - at step 5, are you doing a File->New?

Showing my workflow…start a blank scene in Rhino.

Start rendering in Octane

Stop rendering in Octane, the File->New

After the File->New, I get


These are my OpenGL settings

File > New, or loading a different model, but work just fine here.

OpenGL settings

Have you tried the Rhino 7.10 SRC?

My SystemInfo is:

Rhino 7 SR10 2021-8-24 (Rhino 7, 7.10.21236.11001, Git hash:master @ c1c1a0be2c74a937d5bb85aafdab68e56ed1ab43)
License type: Commercial, build 2021-08-24
License details: Cloud Zoo

Windows 10.0.19042 SR0.0 or greater (Physical RAM: 32Gb)

Computer platform: DESKTOP 

Standard graphics configuration.
  Primary display and OpenGL: NVIDIA RTX A6000 (NVidia) Memory: 48GB, Driver date: 4-5-2021 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 462.30
    > Accelerated graphics device with 4 adapter port(s)
        - Windows Main Display attached to adapter port #0
        - Secondary monitor attached to adapter port #1

Secondary graphics devices.
  NVIDIA RTX A5000 (NVidia) Memory: 24GB, Driver date: 4-5-2021 (M-D-Y).
    > Accelerated graphics device with 4 adapter port(s)
        - There are no monitors attached to this device!
  Intel(R) HD Graphics 630 (Intel) Memory: 1GB, Driver date: 9-5-2020 (M-D-Y).
    > Integrated graphics device with 3 adapter port(s)
        - Secondary monitor attached to adapter port #0

OpenGL Settings
  Safe mode: Off
  Use accelerated hardware modes: On
  Redraw scene when viewports are exposed: On
  Graphics level being used: OpenGL 4.6 (primary GPU's maximum)
  Anti-alias mode: 4x
  Mip Map Filtering: Linear
  Anisotropic Filtering Mode: High
  Vendor Name: NVIDIA Corporation
  Render version: 4.6
  Shading Language: 4.60 NVIDIA
  Driver Date: 4-5-2021
  Driver Version:
  Maximum Texture size: 32768 x 32768
  Z-Buffer depth: 24 bits
  Maximum Viewport size: 32768 x 32768
  Total Video Memory: 49140 MB

Rhino plugins that do not ship with Rhino
  D:\Dev\Rhino\rhino-developer-samples\cpp\x64\Debug\SampleRealtimeRenderer.rhp	"SampleRealtimeRenderer"	
  C:\Users\Nathan\AppData\Roaming\McNeel\Rhinoceros\7.0\Plug-ins\Crayon (43f0446f-00a7-4ff3-864f-0d3af5e47e2b)\1.0.7751.36916\Crayon.rhp	"Crayon"
  C:\Program Files\Doliwa Workshop\Rhino Nature\Rhino Nature.rhp	"Rhino Nature"
  C:\Users\Nathan\Downloads\OctaneRenderForRhino6_2020.2.3.126_DEMO\RHI Installer 6\Rhino 6.0\x64\OctaneRenderForRhino.rhp	"OctaneRenderForRhino"	2020.2.3.126
  C:\Users\Nathan\AppData\Roaming\McNeel\Rhinoceros\packages\7.0\AMDDenoiser\0.5.2\AMDDenoiser.Windows.rhp	"AMDDenoiser.Windows"
  C:\Users\Nathan\AppData\Roaming\McNeel\Rhinoceros\packages\7.0\EleFront\4.2.2\ElefrontProperties.rhp	"ElefrontProperties"
  C:\Users\Nathan\AppData\Roaming\McNeel\Rhinoceros\packages\7.0\IntelDenoiser\0.6.3\IntelDenoiser.Windows.rhp	"IntelDenoiser.Windows"
  C:\Users\Nathan\AppData\Roaming\McNeel\Rhinoceros\packages\7.0\NVIDIADenoiser\0.4.1\NVIDIADenoiser.Windows.rhp	"NVIDIADenoiser.Windows"
  C:\Users\Nathan\AppData\Roaming\McNeel\Rhinoceros\packages\7.0\ProRender\\ProRender.Windows.rhp	"ProRender"
  C:\Users\Nathan\AppData\Roaming\McNeel\Rhinoceros\packages\7.0\raytraced-blend-material\1.6.7891.23645\RaytracedBlendMaterial.rhp	"RaytracedBlendMaterial"	1.6.7891.23645
  C:\Users\Nathan\AppData\Roaming\McNeel\Rhinoceros\packages\7.0\raytraced-materials\1.7.7774.33931\RaytracedMaterials.rhp	"RaytracedMaterials"	1.7.7774.33931
  C:\Users\Nathan\AppData\Roaming\McNeel\Rhinoceros\packages\7.0\SubstanceImporter\2.0.1\Substance.Win.rhp	"SubstanceImporter"

Rhino plugins that ship with Rhino
  C:\Program Files\Rhino 7\Plug-ins\Commands.rhp	"Commands"	7.10.21236.11001
  C:\Program Files\Rhino 7\Plug-ins\WebBrowser.rhp	"WebBrowser"	
  C:\Program Files\Rhino 7\Plug-ins\rdk.rhp	"Renderer Development Kit"	
  C:\Program Files\Rhino 7\Plug-ins\RhinoScript.rhp	"RhinoScript"	
  C:\Program Files\Rhino 7\Plug-ins\IdleProcessor.rhp	"IdleProcessor"	
  C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp	"Rhino Render"	7.10.21236.11001
  C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp	"RDK_EtoUI"	7.10.21236.11001
  C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp	"Renderer Development Kit UI"	
  C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp	"Snapshots"	
  C:\Program Files\Rhino 7\Plug-ins\Alerter.rhp	"Alerter"	
  C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp	"RhinoCycles"	7.10.21236.11001
  C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp	"Toolbars"	7.10.21236.11001
  C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp	"3Dconnexion 3D Mouse"	
  C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp	"Displacement"	
  C:\Users\Nathan\AppData\Roaming\McNeel\Rhinoceros\packages\7.0\PanelingTools\2021.3.2.446\PanelingTools.rhp	"PanelingTools"	

Thanks @nathanletwory. I will put it down as a quirk with my system, as there have not been reports from other users about the problem.