Rhino using Courier font instead of Windows font

Hi - I have some users that use the OctaneRender for Rhino plugin, where the plugin (and Rhino itself) is displaying with what appears to be the Courier font, rather than the Windows font (which is causing the labels in my plugin to overlap with the checkboxes). Is there a way to set the font that the Rhino UI uses pls?



Nothing other than the command prompt font, no. AFAIK…

Thanks @wim. I don’t understand why Rhino would be using the courier font for it’s UI. How would this happen pls? How does it pick which font to use?



I saw that too yesterday - I don’t use OctaneRender, but some dialogs showed the Courier font in Rhino. Could it be related to a recent Windows update?

I have to say though, that today I don’t see it anymore. Have your users performed the tried-and-tested “have you tried turning it off and on again”? :wink:

1 Like

You just have to love his T-shirt… :sunny:

1 Like

I still don’t have an answer on this. The user’s fonts for the Rhino UI appear as follows:

How can the user reset the font back to the normal one pls?



Reboot many times. Reinstall the octanerender. It didn’t work:joy:

If you start Rhino in safe mode, do you still see the UI in Courier?

I saw a different font, as I said earlier. I think it was Windows System font.
What you’re seeing looks like the Japanese font I sometimes see. Don’t know if that is helpful info :rolling_eyes:

Yes, Still see the UI in Courier.

I delete the Courier font. Still the same.
So I google that there is a soft named Process Explorer can find which font is used in the soft,
It’s not the courier font, it is a chinese font named simsun :frowning:
I delete it in the regedit (cant delete in the control panel).
Now it works.

Any fix planned on this from McNeel’s ?
I’ve got the same issue, all my custom panels on Rhino get that (ugly) font instead of the using the components fonts.
I’m using rhino 6.5, from what I remember a year ago or so I didn’t have the issue.
On the left what is shown in rhino, on the right what I have in visual studio.


Hi @Matthieu_from_NAVINN,

Do built-in panels look this way?

Can you provide the source code to a sample plug-in that displays a panel in this manner, so we can repeat what you are seeing here?

– Dale

Hi @dale,
Built-in panels don’t look this way. Even for my panels, the Font override does not occurs on every controls. If you look at my screenshots, you can see that the labels are wrong, while the groupboxes’ texts are fine.
I’ll create a sample for you to test

After several trials to reproduce the issue in a basic sample, I’ve found out that the font problem only happens with my skin loaded. However this is even weirder, because there isn’t a single ref. to fonts in the skin:

Namespace MSP_Skin
Public Class MyMSPSkin
    Inherits Rhino.Runtime.Skin
    Protected Overrides ReadOnly Property ApplicationName() As String
            Return "Mass Summary Project - test"
        End Get
    End Property

    Protected Overrides ReadOnly Property MainRhinoIcon() As System.Drawing.Bitmap
            Return My.Resources.LogoMSW_v3.ToBitmap
        End Get
    End Property

    Protected Overrides Sub OnEndLoadPlugIn()

        'Customize appearance Settings
            Rhino.ApplicationSettings.AppearanceSettings.SelectedObjectColor = System.Drawing.Color.LightSkyBlue
            Rhino.ApplicationSettings.AppearanceSettings.ViewportBackgroundColor = Drawing.Color.Lavender
            Rhino.ApplicationSettings.AppearanceSettings.MenuVisible = False
            Rhino.ApplicationSettings.AppearanceSettings.CommandPromptPosition = Rhino.ApplicationSettings.CommandPromptPosition.Bottom
            Rhino.ApplicationSettings.AppearanceSettings.CommandPromptBackgroundColor = Drawing.Color.Black
            Rhino.ApplicationSettings.AppearanceSettings.CommandPromptTextColor = Drawing.Color.Lavender
            Rhino.ApplicationSettings.AppearanceSettings.ShowSideBar = True
            Rhino.ApplicationSettings.ModelAidSettings.GridSnap = False
            Rhino.ApplicationSettings.ModelAidSettings.Osnap = False
        Catch ex As Exception
            MsgBox(ex.Message, MsgBoxStyle.Exclamation, "Error")
        End Try

        'Open MSP_ToolBar
            Dim ToolBarFile As Rhino.UI.ToolbarFile = Rhino.RhinoApp.ToolbarFiles.Open(My.Computer.FileSystem.CombinePath(My.Application.Info.DirectoryPath, "MSP_ToolBar.rui"))
            Dim ToolBarID As Guid = ToolBarFile.Id

            'hide every toolbar exept MSP_ToolBar
            For Each TpToolbar As Rhino.UI.ToolbarFile In Rhino.RhinoApp.ToolbarFiles
                If TpToolbar.Id <> ToolBarID Then TpToolbar.Close(False)
            Rhino.UI.ToolbarFileCollection.MruSidebarIsVisible = False
            Rhino.UI.ToolbarFileCollection.SidebarIsVisible = False
        Catch ex As Exception
            MsgBox(ex.Message, MsgBoxStyle.Exclamation, "Error")
        End Try
    End Sub
End Class
End Namespace

Hi @Matthieu_from_NAVINN,

Is this still an issue for you? If so, can you post the source code to a sample project that repeats this?


– Dale

Hi @dale,
I checked just now and it seems it has been solved by a Rhino Update since then.
Thanks for helping
Best regards