Rhino Sketchup export not closed when imported back into Rhino 8 WIP

The Rhino file attached contains a closed polysurface. I exported the polysurface as Sketchup 2017 with the option to Export planar regions as polygons and imported it back into Rhino again. The import joins all surfaces except one.

I’m using the latest Rhino 8 WIP, updated today.

23_03_08_export_polysurface_sketchup.3dm (173.5 KB)

Here’s a polysurface exported as Sketchup in Rhino 7. It imports into Rhino 7 as closed polysurface.When imported into Rhino 8, the polysurface is open. One surface doesn’t join.

I also exported a closed polysurface from Rhino 5 as Sketchup file and imported it back again into Rhino 5 and the imported object is closed. The Sketchup file from Rhino 5 imports as closed polysurface into Rhino 7 but in Rhino 8 WIP is not closed.

Since this export import test worked successfully in Rhino 5 and 7, I suspect there were some changes in Rhino 8 WIP and maybe this could be fixed?

23_03_08_test_export_rhino_5.skp (6.9 KB)

23_03_08_test_export_rhino_7.skp (7.4 KB)

23_03_08_test_export_rhino_8.skp (7.4 KB)

1 Like

I can repeat that problem.

Thanks for the report.

1 Like

Hi Martin,

This is going to take a little while to figure out. If you open the skp file, instead of importing it, it comes in closed. The exact same code is called in the SketchUp import plugin on import and open. Additionally, running the same test in a debug version does not have the problem, import makes a closed mesh.

I have other irons in the fire that need attention right now, I’ll circle back to this in the future.


1 Like

Thanks for the reply, Tim.

I’m importing the Sketchup file as Trimmed Planes.

I just tried opening the file and that works fine.

However, the Sketchup export is a file with imperial units. Opening the file I end up with an imperial file. The original polysurface I created has a side length of 100 mm.

I’m in no rush with this problem. I just thought I’d let you know something might be off, especially since it worked in the past.

Hi Martin,

SketchUp files have a fundamental unit system of inches. I thought that in more recent file SU versions they let you set a unit system but maybe I’m confused. If you switch your units to mm and allow it to scale you’ll find your box is 100mm despite being opened as inches. I’ll see if there’s something I can figure out regarding units too. If you open the file in SketchUp what are the units reported as?


I should have mentioned that, at least for me, V7 opened the file in inches too.

1 Like

I’m using Sketchup Make 2017 only to export files for clients in the climbing wall / accessory business.

I figured out I need to create blocks in an imperial Rhino file and export from there to get the components in Sketchup right. I’m fine with Sketchup being imperial under the hood. A metric Rhino file is converted into an imperial Sketchup file automatically and when imported into a metric Sketchup file the sizes are correct. Opening the Rhino exported Sketchup file the units in the Sketchup file are imperial. I think this makes sense and I don’t need anything changed on the unit side of things…